Help Chromium wont play any videos

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
bambi76
Level 1
Level 1
Posts: 22
Joined: Sat Dec 19, 2015 10:19 pm

Help Chromium wont play any videos

Post by bambi76 » Thu May 26, 2016 3:39 am

Hello i am using Linux Mint Rafaela with KDE desktop and i use Chromium for navigation but for some reason is not playing videos anywhere, it doesnt tell me an error or anything but when i press play stays black i can hear the voices and music but no picture! I try using Firefox and i had no problem watching videos, can someone please help me? T.I.A

User avatar
killer de bug
Level 14
Level 14
Posts: 5397
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Help Chromium wont play any videos

Post by killer de bug » Thu May 26, 2016 6:19 am

Would it be a problem with the hardware acceleration? Could you please try to disable it by right clicking on the video?
Image
If it ain't broke, fix it until it is.

0ddity
Level 3
Level 3
Posts: 140
Joined: Wed Jul 15, 2009 6:19 pm

Re: Help Chromium wont play any videos

Post by 0ddity » Thu May 26, 2016 9:15 am

Have you tried downloading Chrome and playing videos in that? Is there a reason you use Chromium instead of Chrome?

bambi76
Level 1
Level 1
Posts: 22
Joined: Sat Dec 19, 2015 10:19 pm

Re: Help Chromium wont play any videos

Post by bambi76 » Thu May 26, 2016 11:57 am

[img=http://s33.postimg.org/q1d3tmtgv/Screen ... _52_10.png]
It looks like this, i tried to disable but i cant see no options, and i use Chromium because i heard is a fast navigator.. whats the difference between Chrome and Chromium?

User avatar
mank_in
Level 6
Level 6
Posts: 1390
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: Help Chromium wont play any videos

Post by mank_in » Thu May 26, 2016 12:31 pm

Look like you need install flash player.
Chromium is the basis of Google Chrome , Google chrome including proprietary component like flash.
You can try install pepperflashpluggin-nonfree package ( This package will download Chrome from Google, and unpack it to make the
included Pepper Flash Player available for use with Chromium ).
Obviously the simplest method just use google chrome.
Image
Sorry for my bad English , I am Indonesian.

User avatar
killer de bug
Level 14
Level 14
Posts: 5397
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Help Chromium wont play any videos

Post by killer de bug » Thu May 26, 2016 12:49 pm

I don't think advising to install Chrome and flash is acceptable. First because flash is full of security holes and its usage is not advised (nor needed) anymore. Second because Chrome has a google layer and you should only use it if your don't care about your privacy.

The screenshot is clearly showing that the HTML5 player is in use and this should be working without any problem. I see two things. First, please let us know the version of Chromium you are using: apt policy chromium

Second, could you please post a screenshot of this page: www.youtube.com/html5
Image
If it ain't broke, fix it until it is.

0ddity
Level 3
Level 3
Posts: 140
Joined: Wed Jul 15, 2009 6:19 pm

Re: Help Chromium wont play any videos

Post by 0ddity » Thu May 26, 2016 3:39 pm

I don't think it's unacceptable to suggest Chrome over Chromium. Performance-wise its no different, and if you're already using the Google ecosystem (which most people are with Gmail and Youtube and Android) , it is much more convenient. Some people just want things to work the way they're used to, and Chrome does that. You sign in, you have all your bookmarks and extensions ready to go, you're logged into gmail and youtube, nbd. If you're worried about security you can easily disable flash from chrome://plugins/.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Help Chromium wont play any videos

Post by Cosmo. » Thu May 26, 2016 4:12 pm

0ddity wrote:if you're already using the Google ecosystem (which most people are with Gmail and Youtube and Android)
If you do not care about privacy, it is your decision. But where did you ask the OP about that matter? This is especially true in this case, where the problem has obviously nothing to do with flash (which has been given as argument for installing Chrome).

User avatar
killer de bug
Level 14
Level 14
Posts: 5397
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Help Chromium wont play any videos

Post by killer de bug » Thu May 26, 2016 4:17 pm

killer de bug wrote:Would it be a problem with the hardware acceleration? Could you please try to disable it by right clicking on the video?
I think you can find this setting in the preferences also. Please try to change its state and report back if it changes the situation or not.
Image
If it ain't broke, fix it until it is.

0ddity
Level 3
Level 3
Posts: 140
Joined: Wed Jul 15, 2009 6:19 pm

Re: Help Chromium wont play any videos

Post by 0ddity » Thu May 26, 2016 8:27 pm

Cosmo. wrote:
0ddity wrote:if you're already using the Google ecosystem (which most people are with Gmail and Youtube and Android)
If you do not care about privacy, it is your decision. But where did you ask the OP about that matter? This is especially true in this case, where the problem has obviously nothing to do with flash (which has been given as argument for installing Chrome).
Google Chrome is the most used web browser, so it stands to reason a lot of people coming to Linux for the first time will want to install it, looking for continuity regardless of their previous OS. However, when they search the software manager for Chrome, it doesn't show up, just Chromium. Since they logo is similar, they install it, expecting it is just a linux version of Chrome. The issue the OP had was videos not playing in Chromium. Using Chrome instead of Chromium would solve the OP problem. What privacy issues are you referring to? Signing into Chrome with google? General usage statistics sent to Google? It doesn't hurt to let people know there are options, and that they can continue using Chrome (which obviously functions better ootb) instead of switching to Firefox or a community version of Chrome that isn't what they're used to. If the OP is worried about privacy, that is their choice to not use Chrome, but to not tell people they have the choice because of a choice YOU made is counter-productive.

bambi76
Level 1
Level 1
Posts: 22
Joined: Sat Dec 19, 2015 10:19 pm

Re: Help Chromium wont play any videos

Post by bambi76 » Fri May 27, 2016 2:08 am

Guys can someone please help me instead of talking about security :'( i will appreciated it

User avatar
jimallyn
Level 18
Level 18
Posts: 8469
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Help Chromium wont play any videos

Post by jimallyn » Fri May 27, 2016 2:18 am

It might help to post a couple of links to videos that won't play. Perhaps there will be something in common with them that will provide a clue as to what's going on: maybe they are all Flash videos, or maybe they are HTML5 videos, or who knows what?
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

bambi76
Level 1
Level 1
Posts: 22
Joined: Sat Dec 19, 2015 10:19 pm

Re: Help Chromium wont play any videos

Post by bambi76 » Fri May 27, 2016 2:21 am

Image
Last edited by killer de bug on Fri May 27, 2016 3:26 am, edited 1 time in total.

User avatar
killer de bug
Level 14
Level 14
Posts: 5397
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Help Chromium wont play any videos

Post by killer de bug » Fri May 27, 2016 3:22 am

bambi76 wrote:Guys can someone please help me instead of talking about security :'( i will appreciated it
Can you answer my questions?
killer de bug wrote:
killer de bug wrote:Would it be a problem with the hardware acceleration? Could you please try to disable it by right clicking on the video?
I think you can find this setting in the preferences also. Please try to change its state and report back if it changes the situation or not.
and please return the output of

Code: Select all

apt policy chromium
Image
If it ain't broke, fix it until it is.

User avatar
killer de bug
Level 14
Level 14
Posts: 5397
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Help Chromium wont play any videos

Post by killer de bug » Fri May 27, 2016 3:25 am

jimallyn wrote:maybe they are all Flash videos,
Look at the first screenshot. Flash has nothing to do here. I don't even understand why it's being discussed in this topic. Same for Chrome.
Please focus on this HTLM5 and Chromium issue.
Image
If it ain't broke, fix it until it is.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Help Chromium wont play any videos

Post by Cosmo. » Fri May 27, 2016 5:56 am

0ddity wrote:Google Chrome is the most used web browser
And Windows is the most used OS. What do you want to prove with this?
0ddity wrote:What privacy issues are you referring to?
Never heart about it? Time to ask the search engine of your choice. Alone this site gives you enough to read.
0ddity wrote:The issue the OP had was videos not playing in Chromium.
The issue is, that html5 does not work. It might be a problem with the Chromium profile.

User avatar
killer de bug
Level 14
Level 14
Posts: 5397
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Help Chromium wont play any videos

Post by killer de bug » Fri May 27, 2016 7:42 am

As I said, can we please focus on HTML5 and Chromium?
Image
If it ain't broke, fix it until it is.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Help Chromium wont play any videos

Post by Cosmo. » Fri May 27, 2016 7:59 am

Focused on that:
Cosmo. wrote:The issue is, that html5 does not work. It might be a problem with the Chromium profile.
Close Chromium.
Open the file manager and make hidden files visible (ctl-h). Go into the folder .config and rename the folder chromium to chromium.bck
Start Chromium. Does this change anything about the issue?

ZakGordon
Level 4
Level 4
Posts: 280
Joined: Thu Feb 12, 2015 11:07 am

Re: Help Chromium wont play any videos

Post by ZakGordon » Sat May 28, 2016 2:34 am

I use either Chromium or Chrome (you can have both installed bambi76) for watching video content (youtube, flash videos on news channels like the BBC etc).

Firefox is for everything else, i use NoScripts on that so it makes watching video's a bit fiddly (if more secure). I remember when i started using Chromium that not all video's would play, so i had to install pepperflash to get it working for those.

Now if the op wants to, they could try the same and see if those video's now work. It is obviously worth following the process Cosmo and Killer de bug have started in checking if you have an issue with your HTML5 playback, as HTML5 is the much preferred method these days, with Flash being such a security hole etc.

Here is a link to help setup pepperflash in chromium if the op wants to (and i invite others to say wether this is a good idea or not):

http://www.wikihow.com/Upgrade-Adobe-Fl ... Linux-Mint

Personally i would not do the last suggestion, update flash in firefox as Flash on Linux is SO OLD and so insecure it is not funny! But pepperflash in Chromium might be a possible option?
Laptop overheating issues? Check link below:
TLP

User avatar
killer de bug
Level 14
Level 14
Posts: 5397
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Help Chromium wont play any videos

Post by killer de bug » Sat May 28, 2016 5:29 am

ZakGordon wrote:Here is a link to help setup pepperflash in chromium if the op wants to (and i invite others to say wether this is a good idea or not):

http://www.wikihow.com/Upgrade-Adobe-Fl ... Linux-Mint

Personally i would not do the last suggestion, update flash in firefox as Flash on Linux is SO OLD and so insecure it is not funny! But pepperflash in Chromium might be a possible option?
This was addressed 3 posts above yours...
Image
If it ain't broke, fix it until it is.

Post Reply

Return to “Newbie Questions”