Page 1 of 1

Cannot update Linux Mint

Posted: Wed Jun 15, 2016 1:36 pm
by kylerickards
Hi

I have just gone to update Linux Mint 13 but am getting the following error message:

: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://security.ubuntu.com precise-security Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>

W: GPG error: http://archive.ubuntu.com precise Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http://archive.canonical.com precise Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http://ppa.launchpad.net precise Release: The following signatures were invalid: BADSIG 8540356019F7E55B Launchpad PPA for hjmooses
W: GPG error: http://packages.linuxmint.com maya Release: The following signatures were invalid: BADSIG 3EE67F3D0FF405B2 Clement Lefebvre (Linux Mint Package Repository v1) <root@linuxmint.com>
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists ... ty/Release

W: Some index files failed to download. They have been ignored, or old ones used instead.

Is anyone able to help please?

Many thanks
Kyle

Re: Cannot update Linux Mint

Posted: Wed Jun 15, 2016 4:00 pm
by 0ddity
This thread on Ubuntu looks like a probable solution:

http://ubuntuforums.org/showthread.php?t=1983220

Re: Cannot update Linux Mint

Posted: Wed Jun 15, 2016 4:51 pm
by wmh
Does Mint 13 still gets updates?

Re: Cannot update Linux Mint

Posted: Wed Jun 15, 2016 5:29 pm
by Cosmo.
Yes, for the next 9 months.

Re: Cannot update Linux Mint

Posted: Wed Jun 15, 2016 10:50 pm
by wmh
Oh, that's nice! Then his/her problems can be fixed. :mrgreen:
Cosmo. wrote:Yes, for the next 9 months.

Re: Cannot update Linux Mint

Posted: Thu Jun 16, 2016 1:54 pm
by kylerickards
Thanks all!

Out of interest, would I be able to alter anything so I can get updates in 9 months time, even if it's not officially supported? I love the system I have

Re: Cannot update Linux Mint

Posted: Thu Jun 16, 2016 1:56 pm
by Moem
As far as I know, that's a No, sorry. The only way is up(grade).

Re: Cannot update Linux Mint

Posted: Thu Jun 16, 2016 3:00 pm
by kylerickards
Ok, thank you - I take it upgrading in place isn't an option?

Re: Cannot update Linux Mint

Posted: Thu Jun 16, 2016 6:02 pm
by Moem
13 to 17.x?
I'm afraid that's another big Nope. I'm sorry I don't have better news!

Re: Cannot update Linux Mint

Posted: Thu Jun 16, 2016 8:45 pm
by 0ddity
In the future, create separate partitions for / and /home, that way you can keep all your files and program settings if you decide you want to reinstall/upgrade mint.

Re: Cannot update Linux Mint

Posted: Sat Jun 18, 2016 2:33 pm
by kylerickards
All

Many thanks.

I can easily back up personal files and folders but is there a way of migrating the programs across when I upgrade or do I just need to remember what I've installed or write a list?

Sorry for all the questions.

Kyle

Re: Cannot update Linux Mint

Posted: Sat Jun 18, 2016 4:23 pm
by 0ddity
You can use Backup Tool (should already be installed) to backup your software selection. This will only backup software downloaded from repositories though, not software downloaded from a third party.

Re: Cannot update Linux Mint

Posted: Sat Jun 18, 2016 6:01 pm
by Cosmo.
Note, that the programs, that you installed in an old system, are written just for this old system. With a new system you will probably need program versions for the new system. In case, that you installed the programs from the official repositories, this is no problem; you will get offered the matching program versions. If you have programs from other sources, you have to check, if versions for the new OS are available.

Re: Cannot update Linux Mint

Posted: Sun Jun 19, 2016 5:36 am
by kylerickards
Thanks all!

Kyle