Hardware Clock Sync

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
adromidon
Level 1
Level 1
Posts: 1
Joined: Sun Jun 26, 2016 11:48 am

Hardware Clock Sync

Post by adromidon » Sun Jun 26, 2016 11:57 am

Hi all,

I am not an expert in Linux I cam from mostly windows but have dabled in Fedora a bit. My issue is I dual boot windows 10 and Linux Mint as Well as Fedora 23. I can boot into Fedora and then back to windows the the time is fine but once i have loaded Mint and go back to windows my clock is off as Mint syncs its time with my hardware clock and as you guys I am sure are aware windows bases its time on intial boot on the hardware clock.so until I force it to update via the internet or manually correct the time it remains off.

My question now that you know a bit of my circumstance, is how do you prevent Mint from updating the hardware clock? I realize this is against what most users want but in my case Windows is my primary OS for now (trying to slowly get more into LInux) so rather then dive into registry edits and risk borking Windows I thought i would see if there was a simple way to disable time sync on here. In Fedora it was a simple as going into the date and time settings and disable Synch UTC with hardware clock however no such option (that i have found) exists on Mint.

Thanks in advance for any help you guys can give and please try to keep the solutions down to a newb level I am not to keen of modifying RC scripts as they rarely work when I do. I will try anything you suggest if i can but keep the explanation simple as I am not yet a Linux Master!
"There is only Do or Do not, there is no Try"

--Yoda

Cosmo.
Level 23
Level 23
Posts: 17827
Joined: Sat Dec 06, 2014 7:34 am

Re: Hardware Clock Sync

Post by Cosmo. » Sun Jun 26, 2016 4:47 pm

The problem is caused by the fact, that Windows sets the time following the local time, whereas Linux sets it following UTC. You can solve this by either changing the behavior in Windows or in Linux.

For letting Windows follow UTC do this in Command-window (cmd.exe):

Code: Select all

reg.exe add HKLM\SYSTEM\CurrentControlSet\Control\TimeZoneInformation /v RealTimeIsUniversal /t REG_DWORD /d 1 /f
For letting Linux follow the local time you can do this:
Open the file /etc/default/rcS with elevated rights in your text-editor (sorry, not more precise can be given, because you did not tell your desktop environment) and search for this part:

Code: Select all

# assume that the BIOS clock is set to UTC time (recommended)
UTC=yes
Change yes to no

The problem with the latter approach will be, that some files will have a date of creation in the future, which can give several kind of trouble. So I recommend to change the Windows setting.

Lou Guay
Level 1
Level 1
Posts: 1
Joined: Fri Jul 22, 2016 5:01 pm

Re: Hardware Clock Sync

Post by Lou Guay » Fri Jul 22, 2016 5:23 pm

Cosmo: I am also a Linux newbie - recently went dual-boot - Windows 7 and Linux Mint 18.
Thanks for the information about why dual-boot systems may have clock issues, and showing
ways to fix.
I have the same problem with the desktop clock in Linux being 5 hours (exactly) behind local time.
And I can live with that short term until I find the time and energy to fix it.
but
Hoping someone can offer an explanation/speculation/possible direction to investigate as to why my Linux Mint 18
desktop clock display is correct (local time) once every 7 to 10 boot-ups, and 5 hours behind local all the other times?

Thank you

Post Reply

Return to “Newbie Questions”