Linux Mint MATE wont load

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Linux Mint MATE wont load

Post by banjodaddy »

Hello everyone. Well, I had Linux Mint MATE working perfectly on my computer along with Cinnamon that I could switch at the login screen. I had recently been on Cinnamon and went to switch back to MATE. That's when the computer went to a black screen with a pointer and wont go any further. I have done hard boot a few times to try and see if that fixed it, but each time I get the Linux Mint splashscreen as it loads, then the black screen with a pointer where it sits. It's not frozen but wont load past that. Anyone have any ideas on how to fix this? I do have files on here I dont want to lose and would rather not reinstall if I can help it. Thanks in advance.

User avatar
WharfRat
Level 21
Level 21
Posts: 13749
Joined: Thu Apr 07, 2011 8:15 pm

Re: Linux Mint MATE wont load

Post by WharfRat »

I usually recommend not mixing major desktop environments, I think that's the reason a Mate and Cinnamon desktop is distributed.

When you reach the point of a black screen with a pointer press ctl-alt-f1, login then enter:

Code: Select all

sudo service mdm stop

Code: Select all

sudo apt-get install --reinstall mdm
It might start after the re installation completes, but if it doesn't try

Code: Select all

sudo service mdm start
This should set the display manager back to its defaults.

Good luck :wink:
ImageImage

zaileion
Level 4
Level 4
Posts: 226
Joined: Sun Jan 25, 2015 6:01 pm

Re: Linux Mint MATE wont load

Post by zaileion »

Follow WharfRat recommendations first. :wink:
Might be kernel updates having issues with GPU

Reboot PC

at GRUB menu press e
Fine the line that says "quiet splash"
Delete "quiet splash" and replace with "nomodeset"

if you are able to successfully boot
open a command prompt and type

Code: Select all

sudo update-initramfs -u
then

Code: Select all

sudo update-grub
Further reading: http://askubuntu.com/questions/162075/m ... -to-fix-it

User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Re: Linux Mint MATE wont load

Post by banjodaddy »

WharfRat wrote:I usually recommend not mixing major desktop environments, I think that's the reason a Mate and Cinnamon desktop is distributed.

When you reach the point of a black screen with a pointer press ctl-alt-f1, login then enter:

Code: Select all

sudo service mdm stop

Code: Select all

sudo apt-get install --reinstall mdm
It might start after the re installation completes, but if it doesn't try

Code: Select all

sudo service mdm start
This should set the display manager back to its defaults.

Good luck :wink:
I just tried this. I was successful up to the last command when it tried to load and went back to the black screen with pointer. Yea, I'm never mixing Mate and Cinnamon again. I've learned my rookie lesson.

User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Re: Linux Mint MATE wont load

Post by banjodaddy »

zaileion wrote:Follow WharfRat recommendations first. :wink:
Might be kernel updates having issues with GPU

Reboot PC

at GRUB menu press e
Fine the line that says "quiet splash"
Delete "quiet splash" and replace with "nomodeset"

if you are able to successfully boot
open a command prompt and type

Code: Select all

sudo update-initramfs -u
then

Code: Select all

sudo update-grub
Further reading: http://askubuntu.com/questions/162075/m ... -to-fix-it
I was able to get to the "nomodeset" but then it went back to the black screen with a pointer. I must have jacked it up good this time.

zaileion
Level 4
Level 4
Posts: 226
Joined: Sun Jan 25, 2015 6:01 pm

Re: Linux Mint MATE wont load

Post by zaileion »

hold alt and press the f3, f4, f5.. etc. One of them will drop you to a shell prompt.

Login with your username and password

type

Code: Select all

sudo service mdm stop
(it could be lightdm or gdm in place of mdm depending on which display manager you have currently selected
type

Code: Select all

sudo dpkg-reconfigure gdm
or it might be

Code: Select all

sudo dpkg-reconfigure mdm
or maybe

Code: Select all

sudo dpkg-reconfigure lightdm
but one of them will pop up a blue red and white window and will allow you to select the different display managers installed. use arrow keys or tab to navigate and space to select mdm.

type

Code: Select all

sudo reboot
Additional reading: http://www.webupd8.org/2011/07/how-to-s ... dm-or.html

User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Re: Linux Mint MATE wont load

Post by banjodaddy »

zaileion wrote:hold alt and press the f3, f4, f5.. etc. One of them will drop you to a shell prompt.

Login with your username and password

type

Code: Select all

sudo service mdm stop
(it could be lightdm or gdm in place of mdm depending on which display manager you have currently selected
type

Code: Select all

sudo dpkg-reconfigure gdm
or it might be

Code: Select all

sudo dpkg-reconfigure mdm
or maybe

Code: Select all

sudo dpkg-reconfigure lightdm
but one of them will pop up a blue red and white window and will allow you to select the different display managers installed. use arrow keys or tab to navigate and space to select mdm.

type

Code: Select all

sudo reboot
Additional reading: http://www.webupd8.org/2011/07/how-to-s ... dm-or.html
The gdm and lightdm came back saying package not installed.

The mdm line I got the follwing reply:

Code: Select all

Upstart detected. Removing re.d links.
Removing any system startup links for /etc/init.d/mdm ...
Linking /usr/bin/gdmflexiserver to /usr/bin/mdmflexiserver
I have no idea what that reply means, but it never popped up and red, white and blue box. It just went back to command prompt.

zaileion
Level 4
Level 4
Posts: 226
Joined: Sun Jan 25, 2015 6:01 pm

Re: Linux Mint MATE wont load

Post by zaileion »

then you only have mdm installed. so the sudo dpkg-reconfigure mdm command should have worked, try a reboot.
or at the shell type

Code: Select all

startx

User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Re: Linux Mint MATE wont load

Post by banjodaddy »

zaileion wrote:then you only have mdm installed. so the sudo dpkg-reconfigure mdm command should have worked, try a reboot.
or at the shell type

Code: Select all

startx
OK, that brought up the cinnamon desktop. Now my shutdown buttons are gone. If I reboot through terminal it goes right back to black screen/pointer. I get to shell, type startx and it goes into Cinnamon. Something is still messed up but at least now I can access Cinnamon.

User avatar
WharfRat
Level 21
Level 21
Posts: 13749
Joined: Thu Apr 07, 2011 8:15 pm

Re: Linux Mint MATE wont load

Post by WharfRat »

banjodaddy,

Usually re-installing mdm fixes that problem.

Do you have a file ~/ .dmrc containing

Code: Select all

[bill@rosa] ~ $ cat ~/.dmrc
[Desktop]
Session=mate
Language=en_US.UTF-8
ImageImage

User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Re: Linux Mint MATE wont load

Post by banjodaddy »

WharfRat wrote:banjodaddy,

Usually re-installing mdm fixes that problem.

Do you have a file ~/ .dmrc containing

Code: Select all

[bill@rosa] ~ $ cat ~/.dmrc
[Desktop]
Session=mate
Language=en_US.UTF-8
I entered the code and here was the reply it gave me:

Code: Select all

$ cat ~/.dmrc


[Desktop]
Session=gnome-fallback-compiz

User avatar
WharfRat
Level 21
Level 21
Posts: 13749
Joined: Thu Apr 07, 2011 8:15 pm

Re: Linux Mint MATE wont load

Post by WharfRat »

Change the session to mate like mine.

Since you're in the console you will have to use the nano editor.

Code: Select all

nano ~/.dmrc
Also what does this return

Code: Select all

ls -l /etc/alternatives/x-session-manager
ImageImage

User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Re: Linux Mint MATE wont load

Post by banjodaddy »

WharfRat wrote:Change the session to mate like mine.

Since you're in the console you will have to use the nano editor.

Code: Select all

nano ~/.dmrc
Also what does this return

Code: Select all

ls -l /etc/alternatives/x-session-manager
I'm not sure how to get back to MATE. I'm stuck in Cinnamon. When I try to log out, I get a black screen with a bunch of text talking about errors and a command prompt.

Code: Select all

noah@eva ~ $ ls -l /etc/alternatives/x-session-manager
lrwxrwxrwx 1 root root 25 Apr 26 21:23 /etc/alternatives/x-session-manager -> /usr/bin/cinnamon-session
Last edited by banjodaddy on Wed Jun 29, 2016 11:26 pm, edited 1 time in total.

User avatar
WharfRat
Level 21
Level 21
Posts: 13749
Joined: Thu Apr 07, 2011 8:15 pm

Re: Linux Mint MATE wont load

Post by WharfRat »

Use this

Code: Select all

sudo update-alternatives --config x-session-manager
to select mate
ImageImage

User avatar
banjodaddy
Level 1
Level 1
Posts: 30
Joined: Sun Mar 13, 2016 4:34 pm

Re: Linux Mint MATE wont load

Post by banjodaddy »

WharfRat wrote:Use this

Code: Select all

sudo update-alternatives --config x-session-manager
to select mate
OK. I'm back on MATE. But whenever I shutdown and startup I still get the black screen/pointer. I have to hit ctrl+alt+F1 and type startx, then it brings up MATE. If I go to Reboot, it takes me to a shell window with command prompt.

User avatar
WharfRat
Level 21
Level 21
Posts: 13749
Joined: Thu Apr 07, 2011 8:15 pm

Re: Linux Mint MATE wont load

Post by WharfRat »

If you have auto login set, use

Code: Select all

sudo /usr/sbin/mdmsetup
to disable it and set the default session to mate.

When logging back in select mate for the desktop session.

That's about all I can think of at the moment.

UPDATE: Also what does this show

Code: Select all

cat /etc/X11/default-display-manager
Good luck :wink:
ImageImage

Post Reply

Return to “Newbie Questions”