debugging shutdown/reboot

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
don250r
Level 3
Level 3
Posts: 143
Joined: Thu Feb 11, 2016 2:41 pm

debugging shutdown/reboot

Post by don250r » Thu Jul 07, 2016 10:02 pm

One small problem with LM18 Cinnamon.
Hung shutdown/reboot thru the mint menu

Code: Select all

System:    Host: localhost Kernel: 4.6.3 x86_64 (64 bit gcc: 6.1.1)
           Desktop: Cinnamon 3.0.6 (Gtk 3.18.9-1ubuntu3)
           Distro: Linux Mint 18 Sarah
Machine:   Mobo: ASUSTeK model: P8P67 PRO REV 3.1 v: Rev 1.xx
           Bios: American Megatrends v: 3602 date: 11/01/2012
CPU:       Quad core Intel Core i5-2500K (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27196
           clock speeds: max: 5900 MHz 1: 4699 MHz 2: 4699 MHz 3: 4699 MHz
           4: 4699 MHz
Graphics:  Card: NVIDIA GK104 [GeForce GTX 670] bus-ID: 01:00.0
           Display Server: X.Org 1.18.3 driver: nvidia
           Resolution: 1366x768@59.79hz
           GLX Renderer: GeForce GTX 670/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 367.27 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GK104 HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.6.3
Network:   Card: Intel 82579V Gigabit Network Connection
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 500.1GB (25.6% used)
           ID-1: /dev/sda model: ST3500320SV size: 500.1GB
Partition: ID-1: / size: 20G used: 9.1G (50%) fs: ext4 dev: /dev/sda5
           ID-2: /home size: 202G used: 109G (57%) fs: ext4 dev: /dev/sda7
           ID-3: swap-1 size: 2.00GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 72.0C mobo: 27.8C gpu: 0.0:40C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 204 Uptime: 18:55 Memory: 2656.1/16016.8MB
           Init: systemd runlevel: 5 Gcc sys: 6.1.1
           Client: Shell (bash 4.3.421) inxi: 2.2.35 
The offending program appears to be Firetools, and only when i use the firefox(or some other program) icon within it.
Kernel doesnt matter, tried 4.4.0-21, 4.4..0-28 and ofc 4.6.3
The problem disappears when i close firetools first(Im thinking a SIGTERM issue?), then reboot/shutdown.
At the moment, it escapes me how to see the logs for shutdown/reboot.
I thought i saw a similar problem on the arch forums, but the fixes do not apply in my case.
Mint 18 Cinnamon, 4.6.3 kernel
Intel i5-2500k@4.8GHz
16 Gb DDR3
Nvidia GTX670

Jonasrye
Level 1
Level 1
Posts: 4
Joined: Thu Jul 07, 2016 9:00 am

Re: debugging shutdown/reboot

Post by Jonasrye » Fri Jul 08, 2016 6:36 am

I found a solution to the shutdown/reboot problem by:

#1 edit the file
sudo nano /etc/modprobe.d/blacklist.conf
sudo update blacklist.conf
#2 add these
blacklist dw_dmac
blacklist dw_dmac_core
#3
sudo apt-get update

This worked for me on my Acer aspire Es1-311 laptop :)

I hope this helps :)

User avatar
don250r
Level 3
Level 3
Posts: 143
Joined: Thu Feb 11, 2016 2:41 pm

Re: debugging shutdown/reboot

Post by don250r » Fri Jul 08, 2016 3:17 pm

So sorry, didnt work.Didnt take long to try.
A couple of clicks later, i see this was a problem mostly for Acer laptops.
Mint 18 Cinnamon, 4.6.3 kernel
Intel i5-2500k@4.8GHz
16 Gb DDR3
Nvidia GTX670

Post Reply

Return to “Newbie Questions”