keyboard layout for login prompt

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
lsatenstein
Level 1
Level 1
Posts: 16
Joined: Sat Dec 03, 2011 2:33 pm

keyboard layout for login prompt

Post by lsatenstein » Sun Jul 10, 2016 10:44 am

Help

I set up Canada French Keyboard (CA) as the only Keyboard layout. In terminal mode, it is respected, and after a successful cinnamon/mate, it is respected.

but

when I try the GUI login, the layout presented is US. It matters because characters like # ! are in the wrong location, and characters LIKE «»É are missing. Some of those characters are used within passwords.

in terminal mode localectl status shows ca for both

Laurent85
Level 16
Level 16
Posts: 6115
Joined: Tue May 26, 2015 10:11 am

Re: keyboard layout for login prompt

Post by Laurent85 » Thu Jul 14, 2016 7:52 am

You may reconfigure the system keyboard layout, from a terminal:

Code: Select all

sudo dpkg-reconfigure keyboard-configuration
Select Generic 105-key (Intl) PC > French (Canada) > then the default options offered

Reboot to complete.
Image

Post Reply

Return to “Newbie Questions”