Page 1 of 3

No WIFI, like others

Posted: Sun Jul 31, 2016 10:37 am
by bcripps
Just downloaded Mint 18 Sarah yesterday using USB Universal Installer, (no disc burner).

Download and install went fine but can't connect to a WIFI hotspot. No internet at home so rely on hotspot at Wendy's Bar.

I can see the available hotspots in the vicinity and select Wendy's and enter the password. It seems ok but Firefox can't find a server.

In Device Manager, it says that drivers can't be installed and to reinsert the USB stick. I did that and thought I installed a driver, but apparently not.

Someone on form suggests setting up a Profile in Network Manager before downloading a driver. I don't see that listed.

I'm sure there is a simple fix for this. Hope someone can help.

Thank you,
Bry

Re: No WIFI, like others

Posted: Sun Jul 31, 2016 11:10 am
by Flemur
reinsert the USB stick
Please post output of these commands:

Code: Select all

lsusb
sudo lshw -C network

Re: No WIFI, like others

Posted: Mon Aug 01, 2016 10:38 am
by bcripps
Thanks for your reply Flemur, but this is the newbe section of the forum and you'll have to forgive me, but I need specific instructions here.

Insert memory stick: before I turn on the computer and repeatedly press F12? Or after I have booted up Mint?

And these commands? Where do I type them?

I know your time is valuable, but please be a little more forthcoming so I can provide the information you require.

Once again, thank you. I do appreciate your assistance.

Bry

Re: No WIFI, like others

Posted: Tue Aug 02, 2016 10:20 am
by MajorMuff
Hit Ctrl+Alt+T to open the terminal and paste the commands there (using middle mouse button or Ctrl+Shift+V)

Re: No WIFI, like others

Posted: Wed Aug 03, 2016 9:17 am
by bcripps
Thanks so much Muff...
Here is the output for both commands (Hope I did it right):

bcripps@bcripps-ThinkPad-11e ~ $ lsusb
Bus 002 Device 003: ID 5986:0367 Acer, Inc
Bus 002 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0489:e07a Foxconn / Hon Hai
Bus 001 Device 002: ID 0438:7900 Advanced Micro Devices, Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
bcripps@bcripps-ThinkPad-11e ~ $


bcripps@bcripps-ThinkPad-11e ~ $ sudo lshw -C network
[sudo] password for bcripps:
*-network
description: Wireless interface
product: BCM4352 802.11ac Wireless Network Adapter
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:01:00.0
logical name: wlp1s0
version: 03
serial: ac:d1:b8:de:c3:e7
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=wl0 driverversion=6.30.223.248 (r487574) latency=0 multicast=yes wireless=IEEE 802.11abg
resources: irq:36 memory:f0a00000-f0a07fff memory:f0800000-f09fffff
*-network
description: Ethernet interface
product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:03:00.0
logical name: enp3s0
version: 10
serial: 2c:60:0c:84:9f:78
size: 10Mbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168g-3_0.0.1 04/23/13 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
resources: irq:33 ioport:1000(size=256) memory:f0f04000-f0f04fff memory:f0f00000-f0f03fff
bcripps@bcripps-ThinkPad-11e ~ $

Re: No WIFI, like others

Posted: Thu Aug 04, 2016 12:55 pm
by Hoser Rob
SInce Mint 18 is ubuntu 16.04 based, try the first answer here (chili555 knows more about wireless than pretty much everyone here put together):

http://askubuntu.com/questions/770490/b ... date-16-04

Re: No WIFI, like others

Posted: Thu Aug 04, 2016 4:53 pm
by JeremyB
Hoser Rob wrote:SInce Mint 18 is ubuntu 16.04 based, try the first answer here (chili555 knows more about wireless than pretty much everyone here put together):

http://askubuntu.com/questions/770490/b ... date-16-04
I don't think that is the problem as the lshw results show that the wl module is loaded. The secure boot issue keeps the module from loading and we would likely see

Code: Select all

network: UNCLAIMED
in the lshw results. Bcmwl-kernel-source has seen better days and it has not been performing well in Ubuntu 16.04

Re: No WIFI, like others

Posted: Fri Aug 05, 2016 10:22 am
by bcripps
Okay. Would like to try Chilli555's solution of turning off the Secure Boot.

“It appears that the only solution so far is to enter the computer's BIOS and turn off Secure Boot.
Secure Boot is a security standard developed by the PC industry to help make sure that your PC boots using only software that is trusted by the PC manufacturer”

But can't figure how to enter BIOS. F2 doesn't do it. Computer is a Lenovo ThinkPad 11e with no disc drive.

Thank you both for your comments.
Bry

Re: No WIFI, like others

Posted: Fri Aug 05, 2016 1:31 pm
by JeremyB
Post the results for

Code: Select all

lspci -nnk | grep -iA2 net
sudo modprobe -r wl
sudo modprobe -v wl

Re: No WIFI, like others

Posted: Sat Aug 06, 2016 9:02 am
by bcripps
Thanks Jeremy. As you can see, the second post you requested would not accept my password.


bcripps@bcripps-ThinkPad-11e ~ $ lspci -nnk | grep -iA2 net
01:00.0 Network controller [0280]: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter [14e4:43b1] (rev 03)
Subsystem: Lenovo BCM4352 802.11ac Wireless Network Adapter [17aa:0623]
Kernel driver in use: wl
Kernel modules: bcma, wl
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 10)
Subsystem: Lenovo RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [17aa:5046]
Kernel driver in use: r8169
Kernel modules: r8169
bcripps@bcripps-ThinkPad-11e ~ $


bcripps@bcripps-ThinkPad-11e ~ $ sudo modprobe -r wl
[sudo] password for bcripps:


Sorry, try again.
[sudo] password for bcripps:
Sorry, try again.
[sudo] password for bcripps:
bcripps@bcripps-ThinkPad-11e ~ $ sudo modprobe -r wl
bcripps@bcripps-ThinkPad-11e ~ $


bcripps@bcripps-ThinkPad-11e ~ $ sudo modprobe -v wl
[sudo] password for bcripps:
insmod /lib/modules/4.4.0-21-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/4.4.0-21-generic/updates/wl.ko
bcripps@bcripps-ThinkPad-11e ~ $

Re: No WIFI, like others

Posted: Thu Aug 11, 2016 11:31 am
by bcripps
Would sure appreciate some help. Anyone?
Bry

Re: No WIFI, like others

Posted: Sat Aug 13, 2016 8:21 am
by JeremyB
Is there someone at this Wendy's that you can watch access the internet? I suspect they are using a redirect to a webpage for you to agree to their terms and conditions and firefox isn't working with it. The next time you try to connect there use

Code: Select all

route
and it should show a gateway IP, enter that into the browser window and see what happens

Re: No WIFI, like others

Posted: Sat Aug 13, 2016 10:00 am
by bcripps
Thanks Jeremy.
My second computer with Win 7 connects to Wendy's just fine. But I don't use Firefox; I use the Midori browser. Others here do use Firefox though, without problem. And my Internet Explorer works fine, when I use it.

I entered “route” and tried to take a screen shot but the forum responded saying the file was too big to be included as an attachment. But here's what I got: Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface

Hope that means something to you. I'm at a lose. And I'm not sure what you mean when you say “enter that into the browser window”

Sorry for being a dolt, but I guess I am...

Thanks again,
Bry

Re: No WIFI, like others

Posted: Sat Aug 13, 2016 10:48 am
by JeremyB
So in windows7 do you have some screen after connecting to Wendy's in the browser to agree to conditions or do you have internet immediately?

It seems that you connect in LM but get no DNS or that route command would have shown you IP addresses, here is what mine shows when connected

Code: Select all

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    600    0        0 wlp1s0
link-local      *               255.255.0.0     U     1000   0        0 wlp1s0
192.168.1.0     *               255.255.255.0   U     600    0        0 wlp1s0
The driver is working or you wouldn't even see wireless networks

Re: No WIFI, like others

Posted: Sat Aug 13, 2016 11:15 am
by bcripps
Yes, in Win 7, I connect directly to the internet via wifi. The password is stored. I am using that computer right now to write this thread.

In Mint, when I press the icon in the task bar in the lower right, I get a window with all the available hotspots, about five of them.

When I click on “Wendy's Bar” I am prompted for the password. I enter it and press connect. That seems fine but Foxfire can't find the server at Mint.

When I again click on “Wendy's” it asks me for the password allover again.

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    600    0        0 wlp1s0
link-local      *               255.255.0.0     U     1000   0        0 wlp1s0
192.168.1.0     *               255.255.255.0   U     600    0        0 wlp1s0

I don't get those last three lines.

Thanks again, Jeremy. Appreciate you taking the time.
Bry

Re: No WIFI, like others

Posted: Sat Aug 13, 2016 11:19 am
by Tomgin5
Coming from left field. Question! Is there a switch in system configuration, under network manager, for airline mode that is switching off your WIFI?

Re: No WIFI, like others

Posted: Sat Aug 13, 2016 12:16 pm
by bcripps
Thanks for the input, Tomgim5...

But I don't see “system configuration” or “network manager” listed anywhere. And a search on “Airline Mode” and “Airplane Mode” yields nothing. I know it's got to be there somewhere! Could you give an old guy a hint?

Thanks for pointing me in the right direction...
Bry

Re: No WIFI, like others

Posted: Sat Aug 13, 2016 12:51 pm
by JeremyB
After trying to connect to Wendy's Bar go into terminal and enter

Code: Select all

dmesg | tail -20
There might be an error explaining what the issue is.

I doubt it is an issue with airplane mode as it disables the wifi

Re: No WIFI, like others

Posted: Sun Aug 14, 2016 9:53 am
by bcripps
bcripps@bcripps-ThinkPad-11e ~ $ dmesg | tail -29
[ 194.289923] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 194.289926] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[ 194.289930] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[ 194.289934] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[ 194.289938] cfg80211: (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[ 194.289941] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[ 194.289944] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[ 206.012352] ------------[ cut here ]------------
[ 206.012425] WARNING: CPU: 2 PID: 669 at /build/linux-Ay7j_C/linux-4.4.0/net/wireless/sme.c:850 cfg80211_roamed+0x86/0xa0 [cfg80211]()
[ 206.012430] Modules linked in: bnep wl(POE) btusb btrtl btbcm kvm btintel uvcvideo bluetooth irqbypass videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core v4l2_common videodev media crct10dif_pclmul crc32_pclmul aesni_intel snd_hda_codec_realtek snd_hda_codec_hdmi snd_hda_codec_generic thinkpad_acpi cfg80211 snd_hda_intel aes_x86_64 snd_hda_codec nvram snd_hda_core lrw gf128mul glue_helper ablk_helper snd_seq_midi joydev input_leds cryptd snd_seq_midi_event serio_raw snd_rawmidi snd_hwdep snd_seq snd_pcm snd_seq_device i2c_piix4 snd_timer snd soundcore fam15h_power k10temp ccp edac_mce_amd edac_core shpchp mac_hid binfmt_misc parport_pc ppdev lp parport autofs4 btrfs xor raid6_pq dm_mirror dm_region_hash dm_log amdkfd amd_iommu_v2 radeon i2c_algo_bit ttm drm_kms_helper syscopyarea sysfillrect
[ 206.012541] sysimgblt fb_sys_fops drm psmouse ahci libahci r8169 mii wmi fjes video
[ 206.012563] CPU: 2 PID: 669 Comm: wl_event_handle Tainted: P W OE 4.4.0-21-generic #37-Ubuntu
[ 206.012569] Hardware name: LENOVO 20ED000EUS/20ED000EUS, BIOS JIET17WW (1.02 ) 02/03/2015
[ 206.012574] 0000000000000286 00000000097ab46e ffff8800b5e1fdc8 ffffffff813e93c3
[ 206.012582] 0000000000000000 ffffffffc05c6bd0 ffff8800b5e1fe00 ffffffff81080f62
[ 206.012590] ffff8800bee7b000 ffff8800b5da9240 000000000000009e ffff8800beea4300
[ 206.012597] Call Trace:
[ 206.012612] [<ffffffff813e93c3>] dump_stack+0x63/0x90
[ 206.012622] [<ffffffff81080f62>] warn_slowpath_common+0x82/0xc0
[ 206.012630] [<ffffffff810810aa>] warn_slowpath_null+0x1a/0x20
[ 206.012678] [<ffffffffc05a3b86>] cfg80211_roamed+0x86/0xa0 [cfg80211]
[ 206.012789] [<ffffffffc0a0b955>] wl_notify_roaming_status+0xc5/0x140 [wl]
[ 206.012888] [<ffffffffc0a0afb0>] wl_event_handler+0x60/0x1d0 [wl]
[ 206.012987] [<ffffffffc0a0af50>] ? wl_notify_scan_status+0x320/0x320 [wl]
[ 206.012996] [<ffffffff810a0528>] kthread+0xd8/0xf0
[ 206.013003] [<ffffffff810a0450>] ? kthread_create_on_node+0x1e0/0x1e0
[ 206.013012] [<ffffffff8182488f>] ret_from_fork+0x3f/0x70
[ 206.013018] [<ffffffff810a0450>] ? kthread_create_on_node+0x1e0/0x1e0
[ 206.013023] ---[ end trace abc9f0b20e44bd9e ]---
bcripps@bcripps-ThinkPad-11e ~ $

Hope this helps, Jeremy.
And I'll add this: When I open “Drive Manager” a window opens up and tells me “Drivers cannot be installed. Please connect to the internet or insert the LM USB stick.”

OS tries to update the cashe from the stick but a window opens with, “Failed to download repository information.”

In “Details” I get a blurb about “Repository does not have release file. Data from such a repository can't be authenticated and therefore potentially dangerous.”

Once again, means nothing to me but thank you so much for your help.
All best,
Bry

Re: No WIFI, like others

Posted: Sun Aug 14, 2016 10:34 am
by JeremyB
Next time you can, don't try to connect but run

Code: Select all

iwlist scan | egrep -i 'ssid|mac|cipher'
There may be more than one access point using the Wendy's Bar name and your system may be trying to switch from one to another and if that is the case see http://askubuntu.com/a/425617/300665