Page 1 of 1

Mint 18 and time issue (Solved)

Posted: Tue Aug 02, 2016 12:37 am
by Lumikki
Hi!

I seem to have issue to get computer time correct when using networktime (internet). It seems that for some reason Mint 18 is using UTC time when it should use local time. If I choose my local timezone +3 and then use get time from internet, time is UTC after computer is rebooted. Only way to get correct time in my computer is use wrong timezone or not allow computer get time from internet. Of cause using wrong timezone then cause calendar issue as weeks first day doesn't work correctly. Meaning if local timezone has sunday as first day of week. If I chose monday for first, it has no affect at all.

Anyone know what's causing this or how to fix it?

Re: Mint 18 and time issue

Posted: Tue Aug 02, 2016 1:46 am
by xenopeek
Lumikki wrote:for some reason Mint 18 is using UTC time
That's the default and recommended to be used. But indeed Windows can't handle it/the truth. Your hardware clock will flip out every time you switch from Windows to Linux Mint or vice versa, as the one is using local time and the other is using UTC.

You'll have to switch Linux Mint to use local time. On Linux Mint 18 and above you do this with the command: timedatectl set-local-rtc 1 (on earlier version of Linux Mint you'd have to edit the file /etc/default/rcS but that won't work on Linux Mint 18). It will not reply anything unless there is a problem.

(If you're not an administrator you will need to prefix the command with sudo, so sudo timedatectl set-local-rtc 1 would be the command to use then.)

You can confirm the change was done by running grep LOCAL /etc/adjtime and that should reply "LOCAL".

With the system set to local time you should be aware (RTC = real-time clock, your hardware clock):
Warning: The system is configured to read the RTC time in the local time zone. This mode can not be fully supported. It will create various problems with time zone changes and daylight saving time adjustments. The RTC time is never updated, it relies on external facilities to maintain it. If at all possible, use RTC in UTC by calling 'timedatectl set-local-rtc 0'.

Re: Mint 18 and time issue

Posted: Tue Aug 02, 2016 11:34 am
by blockhead47
To fix it on the Windows side see @Cosmo's reply to this issue:

viewtopic.php?f=90&t=224183&p=1181583&h ... l#p1181583

Re: Mint 18 and time issue

Posted: Tue Aug 02, 2016 12:27 pm
by rene
xenopeek wrote:It will ask for your password to authorize the change
But only if you not just leave out the "sudo" ...

Administrator-level users, such as the default and often one and only Mint user, are granted the set-local-rtc privilege through PolicyKit. I wondered if I was looking at a privilege escalation bug first time I noticed this working without sudo, and this comment added just to help future googlers not wonder similarly. It's by design.

Re: Mint 18 and time issue

Posted: Tue Aug 02, 2016 12:33 pm
by xenopeek
Thanks. Something new learned. Edited my post.

Re: Mint 18 and time issue

Posted: Wed Aug 03, 2016 11:53 pm
by mattlach
xenopeek wrote: You'll have to switch Linux Mint to use local time. On Linux Mint 18 and above you do this with the command: timedatectl set-local-rtc 1 (on earlier version of Linux Mint you'd have to edit the file /etc/default/rcS but that won't work on Linux Mint 18). It will not reply anything unless there is a problem.
Thank you for this! I edited /etc/default/rcS and couldn't figure out why it wasn't working like before.

I don't understand why they have to keep changing things from the way they've always been...

Pretty soon we won't even be able to use /etc/fstab to mount stuff at boot anymore :p

I LIKE using:
/etc/fstab for file system mounts,
/etc/network/interfaces to configure my network settings
/etc/modules to define which modules load on boot
etc.
etc.


The best way to configure anything is via a commented editable text file, not some GUI junk or command line tool. I wish they'd just leave everything alone :p The best function is that of Ubuntu 12.04 and 14.04 server release ISO's, where everything can be configured this way.

It's bad enough that my NIC's are now eno1 and enp10s0 instead of eth0 and eth1...

Re: Mint 18 and time issue (Solved)

Posted: Mon Jul 02, 2018 9:20 am
by Felim_Doyle
Is there no GUI solution to this problem?

Can DST not be corrected from Date & Time (without selecting an incorrect locale)?

It's not very intuitive for newcomers to Linux and things like this which require editing system files and using root permissions are likely to put potential users off migrating to Linux. I built Linux Mint 17.2 Live on a USB stick yesterday only to discover that it didn't have Wi-Fi support built in. When I tried using Device/Driver Manager to install the missing drivers there were none present. At least I had a wired Ethernet connection to allow me to research the issue but non-technical users would have been stumped. In the end, I decided to go with 18.3 Sylvia but, if the process is not for the faint-hearted, the faint-hearted will drop Linux in despair!

P.S. I agree about network device naming. I was pleasantly surprised that Linux Mint 17.2 used eth0 just like the good old days :) but then it reverted to enp7s0 and wlp13s0 when I installed Linux Mint 18.3. :?

Re: Mint 18 and time issue (Solved)

Posted: Mon Jul 02, 2018 10:03 am
by rene
Felim_Doyle wrote:
Mon Jul 02, 2018 9:20 am
It's not very intuitive for newcomers to Linux and things like this which require editing system files and using root permissions are likely to put potential users off migrating to Linux.
If this had been a forum for most any other Linux distribution the comment at this point would have been
No, it's likely to put potential wankers off migrating to Linux.
This is however not a forum for most any other Linux distribution...

Re: Mint 18 and time issue (Solved)

Posted: Mon Jul 02, 2018 10:20 am
by Pierre
Note that it's not just for that Windows System - either,
as I've struck the same issue when multi_booting various Linux Systems.
IE: they All have to use Local Time
:)
and LinuxMint is one of those that doesn't use Local Time.
:(