Linux 18 sarah wont shut down

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
lattkktx
Level 1
Level 1
Posts: 1
Joined: Tue Aug 02, 2016 7:28 am

Linux 18 sarah wont shut down

Post by lattkktx » Tue Aug 02, 2016 7:35 am

Hello unless I force shut it by keeping the button pressed it wont shut down .

I tried

shutdown -h now
poweroff
and halt .

nothing works . all of those just reboot the system

altair4
Level 19
Level 19
Posts: 9320
Joined: Tue Feb 03, 2009 10:27 am

Re: Linux 18 sarah wont shut down

Post by altair4 » Tue Aug 02, 2016 8:22 am

There's a bug report for the OS Mint forks from: Poweroff or reboot hangs. Laptop won't shutdown. 16.04
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 422
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Linux 18 sarah wont shut down

Post by Joe2Shoe » Thu Nov 23, 2017 10:21 am

After dealing with this issue in LM 18.2 Cinnamon Sonya, I finally "fixed" it and now the laptop reboots and shuts down normally.
1. Edit GRUB:
sudo gedit /etc/default/grub

2. Add this ADDITIONAL line to GRUB:
GRUB_CMDLINE_LINUX_DEFAULT="reboot=acpi"

3. Save File.

4. Update GRUB:
sudo update-grub

5. Reboot and/or shutdown to test.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

JeremyB
Level 19
Level 19
Posts: 9471
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux 18 sarah wont shut down

Post by JeremyB » Thu Nov 23, 2017 10:41 am

You should try shutdown now
The -h option doesn't allow power off so a user can see errors during shutdown that would normally disappear when the machine powered off

Post Reply

Return to “Newbie Questions”