scrolling

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
ginjabunny
Level 3
Level 3
Posts: 144
Joined: Sun Mar 09, 2008 4:04 pm
Location: West London, UK

scrolling

Post by ginjabunny » Mon Sep 05, 2016 5:16 am

this is bugging me, it seems to have appeared in Mint 18 (I'm running Cinnamon 64bit), on any window with scroll bars on the right hand side when I click above or below the slider it jumps to where I clicked whereas before it only moved one page, how do I change this behaviour?
I can't see anything it in system settings, so is it hidden away in dconf or something?

User avatar
xenopeek
Level 24
Level 24
Posts: 24182
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: scrolling

Post by xenopeek » Mon Sep 05, 2016 6:09 am

Firefox is finally a Gtk3 application. Gtk3 is a toolkit for building graphical user interfaces for applications (some applications might still use Gtk2 or may instead use Qt). Gtk3 handles scrolling this way for all Gtk3 applications:
  • Left-click on the scrollbar jumps to that position
  • Shift + left-click, or just right-click, on the scrollbar scrolls up or down by one page
If you want to revert this for all Gtk3 applications, press Alt+F2 to open the run dialog or open a terminal and give the command:
xed ~/.config/gtk-3.0/settings.ini

This opens your text editor with probably a blank file. Put the following two lines of text in it then save & close the file.

Code: Select all

[Settings]
gtk-primary-button-warps-slider=false
Restart Firefox to apply the change. Now left-click scrolls by one page and Shift + left-click jumps to that position on the scrollbar.
Image

Post Reply

Return to “Newbie Questions”