Folder Deletion Problem...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 11
Joined: Sun Mar 08, 2009 7:52 pm

Folder Deletion Problem...

Postby Xaeon88 » Tue Mar 10, 2009 9:50 pm

Hello. Recently I put a game folder on Mint from a CD. Now I want it gone and deleted... Every time I try to delete it from the Trash it says I have insufficient privileges. So I took it out and typed

Code: Select all

chmod g+w (foldername)
It worked but then when I put it back in the trash bin I still can't delete it with the same error...Any help?

Thanks in advance!

User avatar
Level 10
Level 10
Posts: 3339
Joined: Fri Jan 04, 2008 11:59 am
Location: NC USA

Re: Folder Deletion Problem...

Postby Fred » Tue Mar 10, 2009 10:17 pm


Put (foldername) into your /home. Then open a terminal and type:

sudo rm -r foldername

That should do it.

Insanity: Doing the same thing over and over and each time expecting a different result.

Democracy is 2 wolves and a lamb voting on the menu. Liberty is an armed lamb protesting the electoral outcome. A Republic negates the need for an armed protest.

Level 1
Level 1
Posts: 7
Joined: Tue Mar 10, 2009 5:55 pm

Re: Folder Deletion Problem...

Postby Newtoallthis! » Thu Mar 12, 2009 2:57 pm

I've had this problem when a folder had a little padlock icon next to it. If you have this problem, just right click and go into properties, then under permissions change the "owner" option to "create and delete files" or something like that. Then, click "apply changes to all subfolders" and you will be able to delete the entire thing. =)

Return to “Newbie Questions”