Trying to fix known wifi bug in kernel 2.6.27

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 4
Level 4
Posts: 268
Joined: Fri Apr 18, 2008 5:23 pm

Trying to fix known wifi bug in kernel 2.6.27

Postby jacatone » Wed Mar 11, 2009 9:10 pm

I'm running LM 6 Main. I've found that there is a known bug with the wifi driver rtl8187b. It unexpectedly drops my connection while the network manager still shows it's connected. Since kernel 2.6.27, RTL8187B is supported natively by the RTL8187 driver. I've installed the Win98 rtl8187b driver using ndiswrapper and it shows as installed, but when I "blacklist" the default rtl8187 driver, my wifi won't connect. How would I fix this?

The link below recommends forcibly removing the default driver, but I'm afraid I'll just makes things worse. Thanks.

Level 23
Level 23
Posts: 19590
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: Trying to fix known wifi bug in kernel 2.6.27

Postby Husse » Thu Mar 12, 2009 4:52 pm

I see no risk with this
try these module parameters (unload the module first using rmmod rtl8187):
modprobe rtl8187 force_card=0x8189
modprobe rtl8187 force_card=0x8187

except that you may not have a connection
I have a solution for this card I think but I can't find the post :)
Well one more try and I found it
This might really be for you
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Newbie Questions”

Who is online

Users browsing this forum: ForestH11, norm.h and 13 guests