Realtek RTL8187 Wireless Adapter on fresh Mint 18 cannot connect to WiFi

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 1
Level 1
Posts: 4
Joined: Sun Jun 21, 2015 1:13 pm

Realtek RTL8187 Wireless Adapter on fresh Mint 18 cannot connect to WiFi

Post by sucrerouge »

Hey everyone!

So yesterday I decided to install Linux Mint 18 on my desktop. Everything went as planned, but unfortunately I can't figure out how to connect to a WiFi network (and I am saying "a" WiFi cause simply it's not mine and I don't have access to the router either).

Here I am copy pasting the info provided in the terminal by "inxi -Fxz" command.

Code: Select all

sucrelinux-mint sucrelinux # inxi -Fxz
System:    Host: sucrelinux-mint Kernel: 4.4.0-21-generic i686 (32 bit gcc: 5.3.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18 Sarah
Machine:   Mobo: Foxconn model: G31MVP v: FAB:1.0 Bios: Phoenix v: 6.00 PG date: 09/11/2008
CPU:       Dual core Pentium E5300 (-MCP-) cache: 2048 KB flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 10443 
           clock speeds: max: 2600 MHz 1: 2000 MHz 2: 2000 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Juniper PRO [Radeon HD 5750] bus-ID: 01:00.0
           Display Server: 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa)
           tty size: 158x62 Advanced Data: N/A for root
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] Juniper HDMI Audio [Radeon HD 5700 Series]
           driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel NM10/ICH7 Family High Definition Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: ce00 bus-ID: 03:00.0
           IF: enp3s0 state: down mac: <filter>
           Card-2: Realtek RTL8187 Wireless Adapter driver: rtl8187 usb-ID: 001-007
           IF: wlx00871c0c035a state: N/A mac: N/A
Drives:    HDD Total Size: 250.1GB (3.2% used) ID-1: /dev/sda model: ST9250320AS size: 250.1GB temp: 28C
Partition: ID-1: / size: 143G used: 4.4G (4%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 3.49GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 40.0C mobo: N/A gpu: 39.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 186 Uptime: 56 min Memory: 255.6/3277.6MB Init: systemd runlevel: 5 Gcc sys: 5.3.1
           Client: Shell (bash 4.3.421) inxi: 2.2.35
The desktop connects with WiFi through the Realtek RTL8187 Wireless Adapter. I have a dual boot system with Windows 7 on it, also fresh. On Windows I still can't connect to the specific WiFi network and I get the "error", "Unidentified Network" for what it's worth. Actually through windows I succeeded to connect to that network twice, but I guess by pure luck. I 've tried uninstalling the driver of the adapter and reinstalling it and disabling the ethernet controller, but because it didn't solved the problem right away and also after a reboot the problem persists, I guess I didn't do that much. I am mentioning this info cause I've tried to solve the problem on Windows till now.

I haven't installed ANY updates neither in Windows nor in Linux Mint. With that said I probably haven't installed some needed drivers for the Wireless Adapter. With that adapter I can connect to another WiFi network, that is my Hotspot from my smartphone without problem (WPA and pass needed, not open). Also the WiFi network I am trying to connect to is also WPA.

The problem I get from Linux is that I click on the WiFi network to connect to, I am prompted to enter the password, I do so (which is correct), and after that the circle just turns around a couple of times till a message pops telling me "WiFi network disconnected". Btw, I can still connect to that specific WiFi network from my other devices, like my smartphone & my LAPTOP (that's why the pass is correct).

I guess is a driver problem and I have to download one or two of them... Any ideas?

Thanks a lot for any help!

User avatar
Level 4
Level 4
Posts: 409
Joined: Fri Oct 12, 2012 8:45 am

Re: Realtek RTL8187 Wireless Adapter on fresh Mint 18 cannot connect to WiFi

Post by EmpireITtech »

Maybe this video can assist you >

I'm not 100% sure, but going to the Realtek website was a complete waste for me - I don't see any wireless drivers on their site, but maybe I missed them. Never used Realtek on my Linux boxes, so not sure - let us know :mrgreen:
Linux: Mint 19 Tara Cinnamon 64-Bit

Box 1: Intel Core 2 Quad | 8gb RAM | 500gb WD 7200rpm | nVidia Geforce GTS250
Box 2: Intel Core i3-3240 | 4gb RAM | 1tb WD 7200rpm | AMD/ATI Radeon HD 4550

Pants: 32x30

Level 4
Level 4
Posts: 374
Joined: Sat Jan 23, 2016 5:58 pm

Re: Realtek RTL8187 Wireless Adapter on fresh Mint 18 cannot connect to WiFi

Post by supertuxkart »

It's better if you give the ID hardware with :

Code: Select all

to check about.

User avatar
Level 5
Level 5
Posts: 619
Joined: Thu Feb 02, 2012 8:33 pm

Re: Realtek RTL8187 Wireless Adapter on fresh Mint 18 cannot connect to WiFi

Post by I2k4 »

There may be help elsewhere if you provide more system details - note that your adapter is not listed for a replacement driver here: ... /reserve-7

But you can see that several other Realtek adapters need an open source replacement driver to work properly on Linux, and you may be able to locate one for your own. The procedure to replace the default driver is a routine part of every Mint or Ubuntu-based install on my two machines using RTL8192CU adapters. (The same machines running Windows do work fine using the proprietary Realtek driver and software module for Windows - that would let you test the adapter for any hardware problems it might have, that are separate from the Linux driver problem.)

Good luck.
TRUST BUT VERIFY any advice from anybody, including me. M19.1 XFCE (Dell 1520). Dual booting M19.1 XFCE / W7 (Acer netbook) and M19.1 XFCE / W7 (Lenovo desktop). All 32 bit Windows systems are running 64 bit Mint.

Post Reply

Return to “Newbie Questions”