Page 1 of 1

[SOLVED] Unable to Get Sound/Audio

Posted: Thu Dec 29, 2016 1:37 pm
by Heathclyff
I did a search & didn't find anything for my situation. I have the linux mint18 installed.
I believe it's the spice guy. (Cinnamon?) Anyway, the video is pretty decent; but I have
no sound/audio. I have an HT Omega STRIKER 7.1 sound card.

It worked beautifully in windows 7. I'm not even sure if I have the software installed correctly.
Anyway, I'm sure that I left out some important info. But I can surely use the help.
Thanks in advance!

Re: Unable to Get Sound/Audio

Posted: Thu Dec 29, 2016 2:20 pm
by Heathclyff
Solved!! I might be cross-eyed, or something! It seems as though I was looking at the terminals/connections in reverse!
What a schmuck I am! Anyway, I have the audio. Now I need to go somewhere & hide! :oops: :mrgreen:

Re: Unable to Get Sound/Audio

Posted: Thu Dec 29, 2016 3:56 pm
by phd21
Hi "Heathclyff",

Welcome to the wonderful world of Linux Mint and its excellent forum !

It would help to know more about your system setup. If you run "inxi -Fxzd" from the console terminal prompt, highlight the results, copy and paste them back here, that should provide enough information.

Do not be so hard on yourself, that is a common mistake.

FYI: Install Pulse Audio volume control, if it is not already installed. And, there are some really nice graphical (GUI) programs for sound that start with "Qas", like the fantastic "Qasmixer", in the Software Manager or Synaptic Package Manager (SPM) that you can install and use. Sound "Mixers" can be a little confusing if you are not familiar with them. If you bring up "Qasmixer" and make it fullscreen, on the right side you will have mixer devices where you can control your system sound. If you do not see the mixer devices, hit "F6". The mixer item "sysdefault" will show all installed sound card devices, and you will have various options to adjust various volume controls using "sliders" which you can turn off and on using the "dot" below the volume slider. There are also various other check boxes below that you can use, and depending upon your sound card(s) that sometimes includes headphone checkboxes and or sliders as well, like "Headphone Jack Sense".

The applications included are:
- qasconfig - browser for the alsa configuration tree
- qashctl - mixer for alsa's high level control interface
- qasmixer - desktop mixer with features similar to alsamixer

qasmixer is a desktop mixer application for alsa's "simple mixer interface" and offers features similar to alsamixer. it also features a sytem tray icon with basic mixer functionality.

Install "libasound2-plugin-equal" which is another system wide equalizer that's in the Software Manager or Synaptic Package Manager (SPM) that shows up in "QasMixer".

Hope this helps ...

Re: Unable to Get Sound/Audio

Posted: Sun Jan 01, 2017 1:42 am
by mintage
Similar situation, looking all over the place to see if I can't figure it out. Nope. Was about to download Gnome-alsamixer, but before I do, maybe I ask for input.

Installed Serena 18.1 MATE on new HP. Had GRUB bugs, shutdown bugs, wifi bugs and UEFI OS boot order issue all worked out. Sat back and got ready to use the computer and golly, no sound. The Sound Preference panel does not show hardware. Input and Output are both Dummy. I can run an mp3 file in Rythmbox but no sound. I checked alert sound, no sound.

The microphone and headphone were consolidated into one jack - maybe that's an issue if the driver is similarly consolidated. will try using the Qasmixer you mentioned if Gnome-alsamixer doesn't work.

Re: [SOLVED] Unable to Get Sound/Audio

Posted: Sun Jan 01, 2017 3:52 am
by jimallyn
mintage wrote:Similar situation, looking all over the place to see if I can't figure it out. Nope. Was about to download Gnome-alsamixer, but before I do, maybe I ask for input.
Did you try PulseAudio Volume Control?

Re:Unable to Get Sound/Audio

Posted: Sun Jan 01, 2017 2:02 pm
by mintage
No, but thank you for suggesting that. alsamixer didn't show up in software manager, so I got Gnome-alsamixer which opened to a blank screen with menu items that did nothing.
I removed that and looked for qasmixer - it did not show up in software manager or Synaptic Package Manager. So thanks, I have something I can try.

Should I create a new Unable to Get Sound/Audio thread instead of trying to use this one? This one is marked solved, but I have seen other cases where a thread is marked solved for no apparent reason. So I am trying to reduce a duplicate post because so far the help on here solved three problems in as many days. I'm optimistic that will be the case here.

Re: [SOLVED] Unable to Get Sound/Audio

Posted: Sun Jan 01, 2017 5:37 pm
by mintage
Synaptic Package Manager shows pulseaudio installed. I can't find the program listed and it doesn't come up in menu search. what I do have is a Sound app that shows Dummy Input and Output with no Hardware listed. So, I am assuming since I can't open a "pulseaudio" application that it must be something like Flash that doesn't open as an application, but is instead invoked to serve another application.

I am trying to figure out why speaker-test outputs nothing
or why I can get a screen for man amixer, but
amixer sset Master unmute outputs:
"amixer: Mixer attach default error: No such file or directory". I figure amixer man(ual) is installed, but the app is not or cannot negotiate anything at all with the card
inxi -v5
Audio: Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic

I understand that alternatively there is alsamixer, also with a help screen, but outputs
alsamixer -V all: "cannot open mixer: No such file or directory."

It looks to me that I have some new-fangled sound card that integrates the mic and headphone jack that is 100% invisible to pulseaudio.
:idea: try running pulseaudio in terminal!
pulseaudio
E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

aplay -l: "aplay: device list:268: no soundcards found. . ."

OK. I am out of ideas now. Help! My soundcard is invisible to linux!

Re: [SOLVED] Unable to Get Sound/Audio

Posted: Sun Jan 01, 2017 6:44 pm
by jimallyn
Mint comes with pulse audio, but it does not install the PulseAudio Volume Control by default. In Synaptic, Software Manager, or terminal, install pavucontrol. PulseAudio Volume Control should now appear in the menu under Sound & Video.

Please hang up and try your call, again.

Posted: Sun Jan 01, 2017 8:38 pm
by mintage
BLAST!
Configuration tab sez:
"No cards available for configuration"

:!: I'll try turning it off and on again.

I am getting a very weak audio out of youtube, no headphone audio. Still no hardware showing in the configuration tab. EDIT: two days later Hardware is showing Built-in Audio, 1Output/2Inputs, Digital Stereo (HDMI) Output. Can test the speakers in Sound Preferences, cannot set or trigger Alert sounds.

Re: [nearly SOLVED] Unable to Get Sound/Audio

Posted: Sun Jan 08, 2017 7:45 pm
by mintage
I found Qasmixer and turned everything on, except for the microphones. I could get sound out of Xplayer when it opened as a default for *.mp3 file. But no system sounds and no headphones, so I went to the help menu - then to ALSA Main Page and ran across a link there about How do i check my soundcard?

I suppose they said use a wave file for testing for a reason, but I don't have one, so I tried an mp3 file

Code: Select all

aplay -vv [i]somefile[/i].wav 
all I got was static for the duration of the *.mp3 file, but at least it thought it was playing the file. AND aplay ran this time. Then they had this

Code: Select all

speaker-test -c2 -twav
that demonstrated the PCM functions as the default stereo output. At least until I toggled the Master off/on for the hw Mixer device. It didn't come back on.
I did many pointless things, then found that default is a separate control that seems to control everything, and when anything toggles off, everything stays off until you turn it back on again at the default Mixer device Master volume toggle button in Qasmixer.

Thanks to the aforementioned website, I also learned of

Code: Select all

~$ cat /proc/asound/cards
0  [PCH          ]:HDA -Intel - HDA Intel PCH
                   HDA-Intel PCH at 0xb1328000 irq 129
and suddenly system sounds were working. This machine is turning things on and off whenever it feels like it it seems.

The headphones are still not working.
Sound Preferences show Built-in Audio - 1 Output/2 Inputs - Analog Stereo Duplex instead of Dummy now. If anyone could suggest anything, I would be grateful.

AMMENDMENT: Great. Tried to fix a shutdown issue by changing from "do not use" to intel-microcode version 3.20151106.1 Processor microcode firmware for Intel CPU's. Fixed the shutdown issue, but broke the sound. Lost the card, no sound at all. reverted to "Do not use the device", Rebooted. Sound is back for users with elevated privileges, but not desktop alert sounds for Desktop User.

Re: [SOLVED] Unable to Get Sound/Audio

Posted: Tue Jan 10, 2017 10:06 pm
by mintage
You can get System Sounds by navigating through
Sound & Video > Sound > Sound theme

and changing Sound theme from No sounds to anything else in the list.

great Scott! :oops: