18.1 disapearing desktop icons?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
thobin
Level 2
Level 2
Posts: 76
Joined: Thu Feb 12, 2015 8:34 pm

18.1 disapearing desktop icons?

Post by thobin » Fri Dec 30, 2016 11:56 am

So is there a fix for this bug in the works? Or should I go back to 18 for now? It also rearranges the icons to when I get them back up. As far as I can find out its a dual monitor and/or nemo thing I just cant find a fix for. This is kind of a deal breaker bug. Any help or suggestions?


TA
Image

Cosmo.
Level 23
Level 23
Posts: 17827
Joined: Sat Dec 06, 2014 7:34 am

Re: 18.1 disapearing desktop icons?

Post by Cosmo. » Fri Dec 30, 2016 5:02 pm

If the desktop icons vanish, the file manager Nemo has possibly crashed. Start it again (click the icon on the panel or on your desktop). Does this bring the icons back?
Note, this is not meant to be a solution, but for investigating.

thobin
Level 2
Level 2
Posts: 76
Joined: Thu Feb 12, 2015 8:34 pm

Re: 18.1 disapearing desktop icons?

Post by thobin » Sat Dec 31, 2016 7:09 pm

No amount of clicking on anything will bring them back, however I can right click and open the desktop setting and set the "show icons on primary monitor only" and back again and they will come back up.

TA
Image

benchrest
Level 3
Level 3
Posts: 100
Joined: Tue Jan 17, 2012 2:19 pm

Re: 18.1 disapearing desktop icons?

Post by benchrest » Tue Jan 03, 2017 3:29 pm

I have an open bug https://bugs.launchpad.net/linuxmint/+bug/1649623 that may be your problem. Stopping and restarting Nemo also brings back the icons for me. Failed occasionally with 18.0 but always with 18.1. Problem seemed to start with installing 18.0 on SSD. Previously 17.3 was on HDD. Almost like nemo is starting to quickly before desktop is finished starting. But that is a guess. Always restores and never fails if I stop and restart nemo. Anyone else using an SSD?

hpmc13
Level 3
Level 3
Posts: 148
Joined: Tue Jun 04, 2013 4:26 pm

Re: 18.1 disapearing desktop icons?

Post by hpmc13 » Wed Jan 04, 2017 1:15 am

I am on an SSD and having the same problems. 17 was also on SSD. The icons on my secondary monitor never appear on boot. If I click on that desktop (so that it has focus) then hit F5 they come back. I'm assuming that that refreshes the desktop. Much easier than restarting Nemo. Mine will disappear periodically throughout the day.

Also on every boot the icons on both monitors are moved around, which irritates me to no end. On the secondary monitor, I cannot move the icons the edges of the screen. When I attempt to do so, they snap out probably 150 pixels from the edge. On the main monitor I can put them right on the edges with only a little margin.

Afraid I'm not much help, but I do share your pain.
Running LM 19 Cinnamon

User avatar
d00med
Level 4
Level 4
Posts: 374
Joined: Fri Nov 26, 2010 9:55 am

Re: 18.1 disapearing desktop icons?

Post by d00med » Wed Jan 04, 2017 7:14 am

I have this issue too, after updating from 18 to 18.1. I don't use an SSD, I have dual monitors, but desktop icons only display on my secondary monitor. I can see the icons flash for a second on my primary monitor when booting, but then they disappear. I can make them reappear if I open the desktop settings and choose "show desktop icons on primary monitor only," and then switch it back to "show desktop icons on all monitors." They're gone again upon reboot.

Janni
Level 1
Level 1
Posts: 15
Joined: Fri Sep 11, 2015 4:36 pm
Location: Norway

Re: 18.1 disapearing desktop icons?

Post by Janni » Wed Jan 04, 2017 2:54 pm

I'm also having the same issue. It stopped working when I upgraded from 18 to 18.1 (Cinnamon)
I'm running dual monitors with Nvidia driver.
Workaround suggested by d00med also works for me, alternatively killing nemo with

Code: Select all

nemo -q
, then open file manager (to start nemo).

xonxor
Level 1
Level 1
Posts: 5
Joined: Tue Oct 13, 2015 4:23 pm

Re: 18.1 disapearing desktop icons?

Post by xonxor » Thu Jan 05, 2017 7:12 pm

Take a look at the following thread on Linux Mint's Launchpad.

https://bugs.launchpad.net/linuxmint/+bug/1650977

Once in Launchpad, please also make sure to login, at the top of the page click the yellow circle with an inscribed pencil next to the list of users this bug affects, and select 'Yes, it affects me'.
This way we can up the heat and hopefully attract the attention of the developers for a potential fix.

Any participation in testing out this issue, within that same thread would be appreciated. Thanks in advance.

Janni
Level 1
Level 1
Posts: 15
Joined: Fri Sep 11, 2015 4:36 pm
Location: Norway

Re: 18.1 disapearing desktop icons?

Post by Janni » Fri Jan 06, 2017 6:32 am

xonxor wrote:Take a look at the following thread on Linux Mint's Launchpad.

https://bugs.launchpad.net/linuxmint/+bug/1650977

Once in Launchpad, please also make sure to login, at the top of the page click the yellow circle with an inscribed pencil next to the list of users this bug affects, and select 'Yes, it affects me'.
This way we can up the heat and hopefully attract the attention of the developers for a potential fix.

Any participation in testing out this issue, within that same thread would be appreciated. Thanks in advance.
Will do xonxor, thanks. Good to address this at the correct place.

hpmc13
Level 3
Level 3
Posts: 148
Joined: Tue Jun 04, 2013 4:26 pm

Re: 18.1 disapearing desktop icons?

Post by hpmc13 » Sun Jan 08, 2017 12:17 pm

Found another problem:
If I right-click on the primary monitor and select Create New Document -> Empty Document I get an icon with the name selected so that I can rename it; the behavior I expect.

If I do the same on the my secondary monitor it appears as though nothing happens. If I hit F5 the icon appears with the name "untitled document" that I then have to rename.
Running LM 19 Cinnamon

User avatar
d00med
Level 4
Level 4
Posts: 374
Joined: Fri Nov 26, 2010 9:55 am

Re: 18.1 disapearing desktop icons?

Post by d00med » Sun Jan 08, 2017 3:21 pm

Janni wrote:I'm also having the same issue. It stopped working when I upgraded from 18 to 18.1 (Cinnamon)
I'm running dual monitors with Nvidia driver.
Workaround suggested by d00med also works for me, alternatively killing nemo with

Code: Select all

nemo -q
, then open file manager (to start nemo).
Can someone help me make a script for this, that I can launch on startup? I've tried this, but nemo doesn't restart.

Code: Select all

#!/bin/bash

nemo -q && nemo

mattlach
Level 3
Level 3
Posts: 131
Joined: Mon May 30, 2011 8:34 pm

Re: 18.1 disapearing desktop icons?

Post by mattlach » Thu Jan 12, 2017 12:55 am

benchrest wrote:I have an open bug https://bugs.launchpad.net/linuxmint/+bug/1649623 that may be your problem. Stopping and restarting Nemo also brings back the icons for me. Failed occasionally with 18.0 but always with 18.1. Problem seemed to start with installing 18.0 on SSD. Previously 17.3 was on HDD. Almost like nemo is starting to quickly before desktop is finished starting. But that is a guess. Always restores and never fails if I stop and restart nemo. Anyone else using an SSD?

My experience is identical to yours. Happened every now and then in 18, but happens on every boot in 18.1.
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Laptop: Dell E7470, Core i7-6600u, 8GB
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon L5640, 192GB RAM, 120TB ZFS

mattlach
Level 3
Level 3
Posts: 131
Joined: Mon May 30, 2011 8:34 pm

Re: 18.1 disapearing desktop icons?

Post by mattlach » Sun Jan 15, 2017 7:06 pm

d00med wrote:
Janni wrote:I'm also having the same issue. It stopped working when I upgraded from 18 to 18.1 (Cinnamon)
I'm running dual monitors with Nvidia driver.
Workaround suggested by d00med also works for me, alternatively killing nemo with

Code: Select all

nemo -q
, then open file manager (to start nemo).
Can someone help me make a script for this, that I can launch on startup? I've tried this, but nemo doesn't restart.

Code: Select all

#!/bin/bash

nemo -q && nemo
We shouldn't have to do this, but this is my workaround:

First, the script:

Code: Select all

#!/bin/sh
killall nemo
nemo -n
exit 0
The -n switch loads nemo without opening a window, so it behaves like we would expect it to do on login.

I called mine "iconfix.sh" and saved it in my home folder.

Next make it executable:

"chmod 755 iconfix.sh".

Now, add it to your cinnamon startup applications when you log in:

Preferences -> Startup Applications: (Click for larger)

Image


<moderator>impertinent insult removed</moderator>

I added a 2 second delay, just to make sure everything is done loading by the time the script runs. This may not be necessary, but it works well for me.

Hopefully they will fix this, so a hack like this is no longer needed.
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Laptop: Dell E7470, Core i7-6600u, 8GB
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon L5640, 192GB RAM, 120TB ZFS

Thatlhurt
Level 1
Level 1
Posts: 15
Joined: Mon Dec 19, 2016 2:44 am
Location: Virginia, USA

Re: 18.1 disapearing desktop icons?

Post by Thatlhurt » Sun Jan 15, 2017 7:14 pm

On the blog, Clem had requested that a bug report related to this be filed here:

https://github.com/linuxmint/nemo/issues/1385

User avatar
d00med
Level 4
Level 4
Posts: 374
Joined: Fri Nov 26, 2010 9:55 am

Re: 18.1 disapearing desktop icons?

Post by d00med » Sat Jan 21, 2017 5:32 am

mattlach wrote:Hopefully they will fix this, so a hack like this is no longer needed.
Thanks very much.

Edit: this only works here when I log off. On boot, it has no effect.

mattlach
Level 3
Level 3
Posts: 131
Joined: Mon May 30, 2011 8:34 pm

Re: 18.1 disapearing desktop icons?

Post by mattlach » Fri Feb 10, 2017 7:33 pm

d00med wrote:
mattlach wrote:Hopefully they will fix this, so a hack like this is no longer needed.
Thanks very much.

Edit: this only works here when I log off. On boot, it has no effect.
Hmm. Interesting. It works for me.

You might try increasing the startup delay value in the GUI to greater than 2 seconds. It might be too short for your configuration. We want it to kill the process after everything has completed loading. Maybe 2 seconds was not enough time.
Desktop: Intel i7-3930K@4.8Ghz, Asus P9X79 WS, 64GB DDR3-1866, 400GB Intel 750 SSD, Sound Blaster X-Fi Titanium HD, Nvidia Titan X (Pascal)
Laptop: Dell E7470, Core i7-6600u, 8GB
Proxmox (NAS, Mythbuntu, etc.): 2x Xeon L5640, 192GB RAM, 120TB ZFS

benchrest
Level 3
Level 3
Posts: 100
Joined: Tue Jan 17, 2012 2:19 pm

Re: 18.1 disapearing desktop icons?

Post by benchrest » Fri Feb 10, 2017 11:30 pm

I tried restart with up to 4 seconds without relief. But shutting down and then turning on computer it worked. I don't see what the difference would be between restart and complete shutdown and start.
LM Cinnamon 19, ASUS TUF B450M, Ryzen 5 2600x, 16gb memory, Samsung SSD 970 EVO-Plus, Samsung SSD 850 Pro 256gb, dual 27" monitors, MSI GEFORCE GTX 1050ti Areo ITX. Big user of Gramps, LibreOffice, Unison.

Post Reply

Return to “Newbie Questions”