permission to install .bin pakage

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Thu Apr 02, 2009 9:25 pm

permission to install .bin pakage

Postby djmeo » Thu Apr 02, 2009 10:06 pm


I would like to install one of vestion of java runtime (lastest at the moment)
my pakage is a .bin, so i type the name's directory in the terminal, and type "sudo su" with my user password (my user name turn red, am i in root user now?)... and i type " ./mysoft.bin " and Enter... it says that i dont have permission

i have the same probleme from .bz2 or .gz pakage when i type " make install " in terminal


Level 8
Level 8
Posts: 2158
Joined: Thu Feb 26, 2009 8:58 pm

Re: permission to install .bin pakage

Postby emorrp1 » Fri Apr 03, 2009 5:57 am

Hi djmeo, you can install the latest (sun) jre (6-13) from the package "sun-java6-jre" in the synaptic package manager, no need to download from their website. It's in the "Community" repository, which you can enable from synaptic at Settings --> Repositories, select the check-box next to both lines with "Community" in the "Section" column (yes, there should be an easier way to do this). The community repo is where packages get uploaded by those who want something that hasn't made it into ubuntu yet, in this case, the latest version of sun's jre, uploaded by merlwiz79 (he creates the XFCE CE among other things)

Oh, and regarding your permissions problem, even with root: This basically means that the partition ("drive" in windows) you're trying to install off (presumably not the same partition as your main install) has been mounted with a "noexec" option, which disables scripts entirely. You'd need to identify which partition it is, then edit the corresponding line in /etc/fstab to ensure the exec option.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term

David Valentine
Level 1
Level 1
Posts: 10
Joined: Wed Apr 22, 2009 4:35 am

Re: permission to install .bin pakage

Postby David Valentine » Wed Apr 22, 2009 4:42 am

What's in the community repo appears to be only the i386 version of sun-java6-bin. I am using the AMD64 version of Felicia, and now sun-java6 wants to uninstall itself during updates. Will the 64-bit version be made available in the repo sometime soon? Otherwise, I basically have to disable the community repo in order to keep the 6-10 version from ubuntu working.

Return to “Newbie Questions”

Who is online

Users browsing this forum: michael louwe and 23 guests