Unable to update

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
maxemoose
Level 1
Level 1
Posts: 4
Joined: Wed Jan 11, 2017 12:44 am
Location: Los Angeles, CA

Unable to update

Post by maxemoose » Tue Feb 28, 2017 1:03 am

Why is this marked as solved?? There does not seem to be a listed solution..... I am having similar issues.
One thing I discovered so far, is that I had a bad link...
" https://dl.google.com/linux/talkplugin/deb/ " = no good, page shows only "Error 404"
And then another bad link.....
" http://packages.domain.com/dists/xenial/InRelease " = no good, says "Unable to connect"

I've been trying some of the advised commands in this post, including switching mirrors.... Here's my recent result from running command "apt update" after removing the faulty google 'additional repository' via Software Source Manager....

Code: Select all

apt update
Get:1 http://download.mono-project.com/repo/debian wheezy InRelease [5,822 B]
Get:2 http://download.mono-project.com/repo/debian wheezy/main amd64 Packages [58.1 kB]
Get:3 http://download.mono-project.com/repo/debian wheezy/main i386 Packages [58.1 kB]
Ign:4 http://mirrors.seas.harvard.edu/linuxmint-packages sarah InRelease           
Get:5 http://archive.linux.duke.edu/ubuntu xenial InRelease [247 kB]               
Get:6 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB]         
Get:7 http://archive.canonical.com/ubuntu xenial InRelease [11.5 kB]               
Get:8 http://mirrors.seas.harvard.edu/linuxmint-packages sarah Release [24.1 kB]   
Get:9 http://archive.canonical.com/ubuntu xenial/partner amd64 Packages [2,664 B]  
Get:10 http://archive.canonical.com/ubuntu xenial/partner i386 Packages [2,964 B]  
Get:11 http://archive.canonical.com/ubuntu xenial/partner Translation-en [1,424 B] 
Get:12 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages [219 kB]
Get:13 http://archive.linux.duke.edu/ubuntu xenial-updates InRelease [102 kB]      
Get:14 http://archive.linux.duke.edu/ubuntu xenial-backports InRelease [102 kB]    
Get:15 http://security.ubuntu.com/ubuntu xenial-security/main i386 Packages [212 kB]
Get:16 http://security.ubuntu.com/ubuntu xenial-security/main Translation-en [92.0 kB]
Get:17 http://archive.linux.duke.edu/ubuntu xenial/main amd64 Packages [1,201 kB]  
Get:18 http://security.ubuntu.com/ubuntu xenial-security/restricted amd64 Packages [6,828 B]
Get:19 http://security.ubuntu.com/ubuntu xenial-security/restricted i386 Packages [6,804 B]
Get:20 http://security.ubuntu.com/ubuntu xenial-security/restricted Translation-en [2,272 B]
Get:21 http://security.ubuntu.com/ubuntu xenial-security/universe amd64 Packages [78.9 kB]
Get:22 http://security.ubuntu.com/ubuntu xenial-security/universe i386 Packages [73.8 kB]
Get:23 http://security.ubuntu.com/ubuntu xenial-security/universe Translation-en [43.5 kB]
Get:24 http://security.ubuntu.com/ubuntu xenial-security/multiverse amd64 Packages [2,748 B]
Get:25 http://security.ubuntu.com/ubuntu xenial-security/multiverse i386 Packages [2,908 B]
Get:26 http://security.ubuntu.com/ubuntu xenial-security/multiverse Translation-en [1,232 B]
Get:27 http://mirrors.seas.harvard.edu/linuxmint-packages sarah Release.gpg [819 B]
Get:28 http://archive.linux.duke.edu/ubuntu xenial/main i386 Packages [1,196 kB]
Get:29 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/main amd64 Packages [16.1 kB]
Get:30 http://archive.linux.duke.edu/ubuntu xenial/main Translation-en [568 kB]
Get:31 http://archive.linux.duke.edu/ubuntu xenial/restricted amd64 Packages [8,344 B]
Get:32 http://archive.linux.duke.edu/ubuntu xenial/restricted i386 Packages [8,684 B]
Get:33 http://archive.linux.duke.edu/ubuntu xenial/restricted Translation-en [2,908 B]
Get:34 http://archive.linux.duke.edu/ubuntu xenial/universe amd64 Packages [7,532 kB]
Get:35 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/main i386 Packages [15.4 kB]
Get:36 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/upstream amd64 Packages [34.2 kB]
Get:37 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/upstream i386 Packages [34.2 kB]
Get:38 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/import amd64 Packages [6,716 B]
Get:39 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/import i386 Packages [6,720 B]
Get:40 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/backport amd64 Packages [73.0 kB]
Get:41 http://archive.linux.duke.edu/ubuntu xenial/universe i386 Packages [7,512 kB]
Get:42 http://archive.linux.duke.edu/ubuntu xenial/universe Translation-en [4,354 kB]
Get:43 http://archive.linux.duke.edu/ubuntu xenial/multiverse amd64 Packages [144 kB]
Get:44 http://archive.linux.duke.edu/ubuntu xenial/multiverse i386 Packages [140 kB]
Get:45 http://archive.linux.duke.edu/ubuntu xenial/multiverse Translation-en [106 kB]
Get:46 http://archive.linux.duke.edu/ubuntu xenial-updates/main amd64 Packages [483 kB]
Get:47 http://archive.linux.duke.edu/ubuntu xenial-updates/main i386 Packages [474 kB]
Get:48 http://archive.linux.duke.edu/ubuntu xenial-updates/main Translation-en [192 kB]
Get:49 http://archive.linux.duke.edu/ubuntu xenial-updates/restricted amd64 Packages [7,176 B]
Get:50 http://archive.linux.duke.edu/ubuntu xenial-updates/restricted i386 Packages [7,164 B]
Get:51 http://archive.linux.duke.edu/ubuntu xenial-updates/restricted Translation-en [2,396 B]
Get:52 http://archive.linux.duke.edu/ubuntu xenial-updates/universe amd64 Packages [410 kB]
Get:53 http://archive.linux.duke.edu/ubuntu xenial-updates/universe i386 Packages [404 kB]
Get:54 http://archive.linux.duke.edu/ubuntu xenial-updates/universe Translation-en [155 kB]
Get:55 http://archive.linux.duke.edu/ubuntu xenial-updates/multiverse amd64 Packages [8,080 B]
Get:56 http://archive.linux.duke.edu/ubuntu xenial-updates/multiverse i386 Packages [6,872 B]
Get:57 http://archive.linux.duke.edu/ubuntu xenial-updates/multiverse Translation-en [3,580 B]
Get:58 http://archive.linux.duke.edu/ubuntu xenial-backports/main amd64 Packages [4,672 B]
Get:59 http://archive.linux.duke.edu/ubuntu xenial-backports/main i386 Packages [4,660 B]
Get:60 http://archive.linux.duke.edu/ubuntu xenial-backports/main Translation-en [3,200 B]
Get:61 http://archive.linux.duke.edu/ubuntu xenial-backports/universe amd64 Packages [2,512 B]
Get:62 http://archive.linux.duke.edu/ubuntu xenial-backports/universe i386 Packages [2,508 B]
Get:63 http://archive.linux.duke.edu/ubuntu xenial-backports/universe Translation-en [1,216 B]
Get:64 http://mirrors.seas.harvard.edu/linuxmint-packages sarah/backport i386 Packages [73.1 kB]
Fetched 26.7 MB in 1min 39s (269 kB/s)                                          
Reading package lists... Done
Building dependency tree       
Reading state information... Done
142 packages can be upgraded. Run 'apt list --upgradable' to see them.
Please help if you can. My APT Cache is currently corrupted, so my Update Manager isn't working and it's suggesting that I switch Linux mirrors again.

My current 'Additional repositories' listed by Software Sources (as superuser).... (I merely copied and pasted urls from the 'Edit URL' button under 'Additional repositories')
Disabled: CD-ROM (Installation Disc) -- deb cdrom:[Linux Mint 18 _Sarah_ - Release amd64 20160628]/ xenial contrib main non-free
Enabled: Domain -- deb http://packages.domain.com/ xenial main
Enabled: Mono-project -- deb http://download.mono-project.com/repo/debian wheezy main

Some info on my system from running command 'inxi -Fxz'...

Code: Select all

inxi -Fxz
System:    Host: maxemoose-Inspiron-7348 Kernel: 4.4.0-21-generic x86_64 (64 bit gcc: 5.3.1)
           Desktop: MATE 1.14.1 (Gtk 3.18.9-1ubuntu3.1) Distro: Linux Mint 18 Sarah
Machine:   System: Dell (portable) product: Inspiron 7348 v: A09
           Mobo: Dell model: 0WWNY6 v: A00 Bios: Dell v: A09 date: 05/13/2016
CPU:       Dual core Intel Core i3-5010U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8380
           clock speeds: max: 2100 MHz 1: 2100 MHz 2: 2098 MHz 3: 2100 MHz
           4: 2100 MHz
Graphics:  Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.3 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1280x720@60.00hz, 1280x720@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2)
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 Intel Wildcat Point-LP High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Intel Broadwell-U Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-21-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: up mac: <filter>
Drives:    HDD Total Size: 500.1GB (8.7% used)
           ID-1: /dev/sda model: WDC_WD5000LPVX size: 500.1GB temp: 27C
Partition: ID-1: / size: 454G used: 37G (9%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 473M used: 62M (14%) fs: ext2 dev: /dev/sda2
           ID-3: swap-1 size: 4.21GB used: 0.00GB (0%) fs: swap dev: /dev/dm-2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 52.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 228 Uptime: 1:49 Memory: 1251.5/3866.9MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.421) inxi: 2.2.35 
Last edited by xenopeek on Tue Feb 28, 2017 1:45 am, edited 3 times in total.

User avatar
maxemoose
Level 1
Level 1
Posts: 4
Joined: Wed Jan 11, 2017 12:44 am
Location: Los Angeles, CA

Re: [SOLVED] UPDATE MANAGER FAILURE Apt corrupted in Update

Post by maxemoose » Tue Feb 28, 2017 1:12 am

A couple more issues...

I can't open Software Manager or Synaptic Package Manager. Every time I try to open Synaptic Package Manager or 'Update the cache' using Software Sources, I get the following error message:
Another synaptic is running

There is another synaptic running in non-interactive mode. Please wait for it to finish first.
I keep getting this error/message:

Code: Select all

** (synaptic:5269): CRITICAL **: activeWindowToForeground(): no active window found
When I run command 'inxi -r', I get this...

Code: Select all

inxi -r
Repos:     Active apt sources in file: /etc/apt/sources.list.d/mono-xamarin.list
           deb http://download.mono-project.com/repo/debian wheezy main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mirrors.seas.harvard.edu/linuxmint-packages sarah main upstream import backport
           deb http://archive.linux.duke.edu/ubuntu xenial main restricted universe multiverse
           deb http://archive.linux.duke.edu/ubuntu xenial-updates main restricted universe multiverse
           deb http://archive.linux.duke.edu/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner

User avatar
killer de bug
Level 14
Level 14
Posts: 5415
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: [SOLVED] UPDATE MANAGER FAILURE Apt corrupted in Update

Post by killer de bug » Tue Feb 28, 2017 5:39 am

maxemoose wrote: I can't open Software Manager or Synaptic Package Manager. Every time I try to open Synaptic Package Manager or 'Update the cache' using Software Sources, I get the following error message:
Another synaptic is running
Most likely because the Update manager is refreshing the cache at the same time you try to update. Wait a few minutes and this error should go away.
If it ain't broke, fix it until it is.

User avatar
killer de bug
Level 14
Level 14
Posts: 5415
Joined: Tue Jul 08, 2008 1:49 pm
Location: Leuven, Belgium

Re: Unable to update

Post by killer de bug » Tue Feb 28, 2017 5:40 am

maxemoose wrote: Please help if you can. My APT Cache is currently corrupted, so my Update Manager isn't working and it's suggesting that I switch Linux mirrors again.
Apt update doesn't show any error. Your system is working correctly.
If it ain't broke, fix it until it is.

Post Reply

Return to “Newbie Questions”