Page 1 of 1

firefox 52

Posted: Thu Mar 16, 2017 2:42 am
by zipidachimp
Mint 17.3 : does anyone know why FF opens a dialog box whenever I click on some website, including google? it has become very annoying

Re: firefox 52

Posted: Thu Mar 16, 2017 2:59 am
by michael louwe
@ zipid...

What does the dialog box says.?

If the dialog box is about remembering password, to get rid of the dialog box, you need to go to Firefox>Menu(= the hamburger icon) >Preference >Security and uncheck the relevant box for password login.

If it's about setting the default browser, go to >Preference >General and uncheck the relevant box.

Re: firefox 52

Posted: Fri Mar 17, 2017 2:14 am
by TursonX
Hi.

Does "Uncheck the relevant box for password login" delete the logins/passwords database??

Re: firefox 52

Posted: Fri Mar 17, 2017 2:49 am
by michael louwe
TursonX wrote:Hi.

Does "Uncheck the relevant box for password login" delete the logins/passwords database??
.
Yes. IOW, Firefox is not remembering your login details for your registered websites, ie usernames and passwords. You will have to enter your usernames and passwords for every login to your registered websites.
....... This Firefox feature seems very convenient but problem is, if Mozilla Firefox got hacked, your login details will fall into the hands of hackers. Same goes for Password Manager programs.

Re: firefox 52

Posted: Fri Mar 17, 2017 4:59 am
by zipidachimp
these are the dialog boxes that open up far too frequently, very annoying:
1. 'this connection is not secure.... ' when logging with username and p'word in spite of the fact I've done it hundreds of times before
2. 'open link in new tab...
'open link in new private window..
'bookmark this link.....
all of the above are nonsense since if I wanted any of them, I would do it myself
These dialog boxes open all the time and are bloody annoying. I wish I could get them to stop! They started about 3 or so weeks ago.

Re: firefox 52

Posted: Fri Mar 17, 2017 5:30 am
by Moem
zipidachimp wrote: 2. 'open link in new tab...
'open link in new private window..
'bookmark this link.....
These sound like rightclick actions to me. Could your mouse be rightclicking by itself? If so, can you try a different mouse?

Re: firefox 52

Posted: Fri Mar 17, 2017 12:17 pm
by dclement
zipidachimp wrote:[...]
1. 'this connection is not secure.... ' when logging with username and p'word in spite of the fact I've done it hundreds of times before
[...]
This is "new" in Firefox 52. To disable it, go to the about:config page, then
- search for "insecure_field_warning.contextual.enabled"; set it to "false";
You might then want to...
- search for "signon.autofillForms.http" and set it to "true"
if you'd like FF to autofill you login+PW as before.
(source)

HTH, Daniel

Re: firefox 52

Posted: Sat Mar 18, 2017 2:51 am
by zipidachimp
Thanks for the help. I've suspected my mouse is worn out, I overuse it, very old, and I'll do the 'about config' thingy.
Meanwhile, I still believe 'not all updates are progress'! 8)
cheers!

Re: firefox 52

Posted: Sat Mar 18, 2017 3:32 am
by jimallyn
Moem wrote:These sound like rightclick actions to me. Could your mouse be rightclicking by itself? If so, can you try a different mouse?
I was having similar problems. I'd click the left mouse button, and the computer would respond as if I had clicked the right button, or as if I had clicked both buttons. New mouse fixed that problem.