Page 1 of 1

Headphones not working (solved)

Posted: Sat Mar 18, 2017 6:51 am
by Mysichvost
OK, hopefully my previous problem with sound is fixed now because I've restarted the computer a few times and it still works.
However, headphones still don't work. Alsamixer seems to recognize them- I can see volume set for them and they are not muted. However, in pavucontrol it says they are unplugged.
My laptop only has one jack that is both for headphones and microphone.

Re: Headphones not working

Posted: Sat Mar 18, 2017 7:20 am
by kc1di
Hi,
A lot of newer laptops come with only one jack. on mine the headphone will work if I plug it in and then just pull it out very slightly. It machine then recognizes them as plugged in. Not very good jack in this machine I Think. Never could get an external mike to work though. Good luck in finding the problem.

Re: Headphones not working

Posted: Sat Mar 18, 2017 8:00 am
by Mysichvost
kc1di wrote:Hi,
A lot of newer laptops come with only one jack. on mine the headphone will work if I plug it in and then just pull it out very slightly. It machine then recognizes them as plugged in. Not very good jack in this machine I Think. Never could get an external mike to work though. Good luck in finding the problem.
Thank you for the tip. I tried playing with it and it didn't help.
Another problem is that my sound goes totally off when the machine sleeps and I have to restart.

I don't know if this helps anyone but here is more info

Code: Select all

System:    Host: vesna-UX410UAK Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: KDE Plasma 5.8.5 (Qt 5.6.1) Distro: Linux Mint 18.1 Serena
Machine:   System: ASUSTeK (portable) product: UX410UAK v: 1.0
           Mobo: ASUSTeK model: UX410UAK v: 1.0 Bios: American Megatrends v: UX410UAK.301 date: 12/12/2016
CPU:       Dual core Intel Core i3-7100U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9599
           clock speeds: max: 2401 MHz 1: 400 MHz 2: 2400 MHz 3: 2400 MHz 4: 700 MHz
Graphics:  Card: Intel Device 5916 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1920x1080@60.01hz
           GLX Renderer: Mesa DRI Intel Kabylake GT2 GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: ALSA v: k4.4.0-53-generic
Network:   Card: Intel Wireless 8260 driver: iwlwifi bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: f4:8c:50:e4:cd:0c
Drives:    HDD Total Size: 128.0GB (12.2% used) ID-1: /dev/sda model: HFS128G39TND size: 128.0GB
Partition: ID-1: / size: 109G used: 7.1G (7%) fs: ext4 dev: /dev/dm-0
           ID-2: /boot size: 473M used: 61M (14%) fs: ext2 dev: /dev/sda2
           ID-3: swap-1 size: 8.46GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 33.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 192 Uptime: 16 min Memory: 1204.8/7864.6MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35

Re: Headphones not working

Posted: Sat Mar 18, 2017 9:03 am
by kc1di
Hello again Mysichvost,

There was a bug reported in the 4.4 kernel that affected some intel audio cards. It was fixed in the 4.8 kernel , so I would recomend trying the 4.8 kernel and see if that fixes the problem, you can do that by clicking on the update manager in the panel and selecting view then linux kernels. install the latest 4.8 version.

Re: Headphones not working

Posted: Sat Mar 18, 2017 10:23 am
by Mysichvost
Hello kc1di,
just installed new kernel with no change.
Do you think it can be solved in KDE or should I try Cinnamon? Or would there be the same problem? I had problems with install, having to try different options in BIOS, trying UEFI, disabling/enabling safe boot, CSM, install with and without 3rd party drivers... It was so much and to be honest, I don't even remember which combination is working right now because I tried so many different options. Could that be the reason for sound issues, too? This was the worst and most difficult Linux install that I've ever done. It's been almost a week I am solving various issues (including accidental deleting of Windows and I have no installation CD :twisted: ) and it still doesn't work properly. What's more, I have to press power button for a long time, otherwise it won't shut down and the fan keeps spinning until battery dies.
I regret buying a brand new computer. I should have bought the cheapest one and it would work great out of the box, just as my previous machines did...
I'm sorry for the rant, don't worry I'll stop now :mrgreen:

Re: Headphones not working

Posted: Sat Mar 18, 2017 10:46 am
by kc1di
since you had such a difficult install I think that may be the problem and with the other problems your facing I would do a fresh install. the problem with the UEFI maybe do to the internet connection believe it or not. so when you do the reinstall do it without the internet connected. you won't be able to download the third party software and but it should install grub ok. then you can install the other things after. There may be some differences in cinnamon and KDE they are based on different base libs. Not sure that would cause the problems you describe though. I use mate and have for a long time it works for me. If your boot from a live dvd I would also suggest that you use a usb stick instead.
I won't go into the reasons now. but it also has to do with uefi, if you are planing on dual booting with windows8 or 10 you'll have to install Mint in uefi mode not legacy.

If for some reason grub does not install correctly got to ubuntu boot-repair found here https://help.ubuntu.com/community/Boot-Repair and use option #2 with the Mint live media and it should correct it.
good luck.

Re: Headphones not working

Posted: Sat Mar 18, 2017 12:43 pm
by Mysichvost
Ok, after restart the machine recognized headphones. I tried pavucontrol. At first, it played through both headphones and speakers, it was impossible to mute speakers and have sound through headphones only. Then I opened alsamixer in terminal and I manually muted speakers and it only plays through headphones now. When I unplug, speakers activate but when I plug headphones back, the process needs to be repeated. It's annoying but at least it finally does what I need. I won't reinstall the whole thing now because I'm afraid it would just lead to new problems again.
So yeah, the issue is "partly solved".

PS: After updating kernel the machine is able to shut down and restart normally, no need to hold the power button. That's an improvement.

Thank you for your support, kc1di

Re: Headphones not working

Posted: Sun Mar 19, 2017 5:51 am
by kc1di
Your welcome,
Perhaps over time with updates it may get fixed.

Re: Headphones not working

Posted: Mon Mar 20, 2017 5:28 am
by Mysichvost
I was hesitant about posting again since I was almost certain there would be a new problem again. However, now that I booted a few times and it keeps working, I may say that I have a solution. I'll post it for people with the same problem.
In alsamixer, auto-mute has to be ENABLED. I disabled it because in other posts I read it has to be done. Since I enabled it, speakers turn off automatically when headphones are plugged in.