How do I disable hibernate? [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
otto9M9otto
Level 1
Level 1
Posts: 14
Joined: Mon Apr 17, 2017 7:35 pm

How do I disable hibernate? [SOLVED]

Post by otto9M9otto »

I am not concerned about battery life of my 64-bit Linux Mint 18.1 KDE desktop system. I do not like having to wake up my system every time I make a sandwich or take a phone call. I tried to disable hibernate by going to System Settings/Power Management and clearing the box for "suspend session". Does hibernate depend on additional settings? I googled this, trying various scripts for terminal, but no luck.
Last edited by otto9M9otto on Sat May 13, 2017 6:52 pm, edited 1 time in total.

Lemongrass38
Level 4
Level 4
Posts: 344
Joined: Mon Dec 12, 2016 11:29 pm
Location: Central Europe

Re: How do I disable hibernate?

Post by Lemongrass38 »

Edit: I don't know KDE.
If your issue is solved, please be so kind and indicate that by editing the topic title in the first post. :)

User avatar
EmpireITtech
Level 4
Level 4
Posts: 409
Joined: Fri Oct 12, 2012 8:45 am

Re: How do I disable hibernate?

Post by EmpireITtech »

While I do not use Mint's version of KDE, 5.8 I believe, on KDE Neon's version, 5.9, I accomplished this by:
  • 1) Going into System Settings > Desktop Behavior > Screen Locking > Updating the time in which the screen will turn off
    2) Going into System Settings > Power Management > Energy Saving > Unchecking all boxes that applied to power savings
Now, my KDE Neon box basically never turns off or goes to sleep or even screen locks. That's mainly bc I start it up at the beginning of work, and shut it off completely at the end of work. There are some custom scripts you can run for power settings, but I did not need those at all for KDE - are you saying those settings are not working for you?
Linux: Mint 19 Tara Cinnamon 64-Bit

Box 1: Intel Core 2 Quad | 8gb RAM | 500gb WD 7200rpm | nVidia Geforce GTS250
Box 2: Intel Core i3-3240 | 4gb RAM | 1tb WD 7200rpm | AMD/ATI Radeon HD 4550

Pants: 32x30

User avatar
Pjotr
Level 21
Level 21
Posts: 14412
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: How do I disable hibernate?

Post by Pjotr »

You can disable hibernation (suspend-to-disk) like this:
https://sites.google.com/site/easylinux ... inux-Mint-
(item 10.1, left column)

If you also wish to disable sleep (suspend-to-ram):
https://sites.google.com/site/easylinux ... nd-to-ram-
(item 10.2, left column)
Tip: 10 things to do after installing Linux Mint 19.3 Tricia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

otto9M9otto
Level 1
Level 1
Posts: 14
Joined: Mon Apr 17, 2017 7:35 pm

Re: How do I disable hibernate?

Post by otto9M9otto »

Thanks for your suggestion, EmpireITtech, but I did un-check the relevant Power Management box: Suspend session. I also un-checked the Screen Energy Saving box. Really, that should have been sufficient, hence my frustration.

I appreciate your suggestion, Pjotr, but it (like so many similar terminal scripts I tried) did not work. Here is the error message:

Code: Select all

mv: cannot stat '/etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla': No such file or directory

otto9M9otto
Level 1
Level 1
Posts: 14
Joined: Mon Apr 17, 2017 7:35 pm

Re: How do I disable hibernate?

Post by otto9M9otto »

Well, I finally posted a bug report about this here: https://github.com/linuxmint/Cinnamon/issues/6493. My system goes into hibernation in one hour. Most, even the most tolerant among us, would consider this unacceptable.

otto9M9otto
Level 1
Level 1
Posts: 14
Joined: Mon Apr 17, 2017 7:35 pm

Re: How do I disable hibernate?

Post by otto9M9otto »

Given that the experts here ran out of ideas, I finally re-installed the whole OS. Now hibernate can be disabled via the relevant menu. Problem solved.

Post Reply

Return to “Newbie Questions”