Page 1 of 1

Change folder view from icon to list [SOLVED]

Posted: Mon May 01, 2017 2:08 pm
by crgibson
I'm a newbie running Linux Mint 18.1 Serena. Would like to know how to change the default folder view from icon to list in all my folders at one time? I currently have about 4500 folders. Also would like to know if I can NOT have extensions show in file names?

Thanks for any help. :D

Re: Change folder view from icon to list

Posted: Mon May 01, 2017 2:23 pm
by austin.texas
Assuming that you are using Nemo, "View new folders using ..." is the first thing you see when you open Edit > Preferences at the top of the list.

Re: Change folder view from icon to list

Posted: Mon May 01, 2017 3:35 pm
by EmpireITtech
Also, what LM 18.1 version are you using - Cinnamon, Mate, KDE, or Xfce? Bc I believe the default file manager is different for all of them...
  • Cinnamon is Nemo
    Mate is Caja
    KDE is Dolphin
    Xfce is Thunar I believe
So it might be slightly different depending on which version of Mint you are running, but austin.texas is correct > go into Preferences > change the Default View to list/details. As for removing the file type - I know you can remove the column in the "List Columns" area, but I do not see the file extensions on the files when in list/details mode...

Re: Change folder view from icon to list

Posted: Mon May 01, 2017 3:41 pm
by DeMus
In KDE it is even simpler:
In the toolbar you find 3 buttons, one for icons, one for compact view and one for details view mode.
Just click the one you like to use and all folders show files and folders in that way.
Image
On this picture they are the third, fourth and fifth from the left.

Re: Change folder view from icon to list

Posted: Mon May 01, 2017 5:20 pm
by crgibson
Thanks for quick answer. I somehow missed the answer when trying find it.
Thanks again (how do I mark this as solved?)

Re: Change folder view from icon to list

Posted: Mon May 01, 2017 5:22 pm
by austin.texas
crgibson wrote:Thanks for quick answer. I somehow missed the answer when trying find it.
Thanks again (how do I mark this as solved?)
I am glad you got it worked out !
Go to your first post, click the EDIT (pencil) icon, and add [SOLVED] to the title.

Re: Change folder view from icon to list

Posted: Mon May 01, 2017 5:24 pm
by crgibson
EmpireI\TYech

Using Cinnamon. I saw the 'List Columns' but nothing anywhere about extensions as part of the Name.

Thanks again

Re: Change folder view from icon to list [SOLVED]

Posted: Mon May 01, 2017 5:40 pm
by crgibson
DeMus

Sorry to be so dumb, but how to I get to KDE?

Thanks

Re: Change folder view from icon to list [SOLVED]

Posted: Mon May 01, 2017 5:43 pm
by austin.texas
crgibson wrote:how to I get to KDE?
You would have to install the KDE version of Mint - (a new installation).

Re: Change folder view from icon to list [SOLVED]

Posted: Mon May 01, 2017 5:57 pm
by crgibson
austin.texas

I feel even more dumb now. I will do some checking and study up on how to get KDE installed.

Thanks for your help.

Re: Change folder view from icon to list [SOLVED]

Posted: Mon May 01, 2017 5:59 pm
by Cosmo.
As austin said: You have to do a new installation of Mint. Might be a side-by-side installation (= dual booting).

Re: Change folder view from icon to list [SOLVED]

Posted: Sun Aug 06, 2017 5:17 am
by graham-h
.. but I can't get this setting to stick when using Elevated Privileges. Where does nemo store its config for root?

Re: Change folder view from icon to list [SOLVED]

Posted: Sun Aug 06, 2017 6:48 am
by austin.texas
graham-h wrote:.. but I can't get this setting to stick when using Elevated Privileges. Where does nemo store its config for root?
It is the same as any user.
Open Nemo, as root, and then do Edit > Preferences > List View

Re: Change folder view from icon to list [SOLVED]

Posted: Sun Aug 06, 2017 9:54 am
by graham-h
austin.texas wrote:
graham-h wrote:.. but I can't get this setting to stick when using Elevated Privileges. Where does nemo store its config for root?
It is the same as any user.
Open Nemo, as root, and then do Edit > Preferences > List View
Thanks, but like I say, it doesn't stick. If I close the preferences dialogue then re-open it, the default goes back to icon view.

Edit: It's working now - don't know what's different - maybe it heard you! Thanks again.