Unable to get sound

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
yandaoyan
Level 1
Level 1
Posts: 7
Joined: Tue May 16, 2017 12:36 pm

Unable to get sound

Post by yandaoyan »

Hi all,

Running windows 10 pro x64, on VMware just installed Mint 18.1 cinnamon, getting ready for a long term switch of OS.

I have a PCIe Creative sound card installed on my motherboard, but most of the time, this card is disabled. I only enable the card for some singing & recording purposes. Hence, cannot plug the card out and I am always using the motherboard's on-board sounds with windows 10.

Currently, after some repeated fresh installations done, I reckon that there is no way I can change any of the sound settings in Mint. Because Mint is only able to detect the already-disabled-creative-sound-card.

a) VMware is not displaying creative sound card for selection.
b) Mint on VMware is configured to use the motherboard's on-board card.
c) run another windows 10 on VMware, there's no problem with the sound.

Anyone had previously solved this problem, kindly enlighten me please. Thanks!

yandaoyan
Level 1
Level 1
Posts: 7
Joined: Tue May 16, 2017 12:36 pm

Re: Unable to get sound

Post by yandaoyan »

Is there anyone kind to offer some assistance? been waiting online for a while now.

BigAngry
Level 1
Level 1
Posts: 20
Joined: Thu May 11, 2017 6:10 pm

Re: Unable to get sound

Post by BigAngry »

I had a similar problem recently. My asus audio dg had been plugged into my mobo when I was using windows, but due to all the problems with it I had switched back to my onboard sound. After I switched to linux my sound didnt work regardless of where I plugged in the cord. The solution for me was to remove the asus audio card. On first boot sound started working (check in sound manager, it showed up for me under built in audo line out)

yandaoyan
Level 1
Level 1
Posts: 7
Joined: Tue May 16, 2017 12:36 pm

Re: Unable to get sound

Post by yandaoyan »

Thanks for the reply, so I guess I will have no other choice than removing the sound card just to faciitate Linux Mint?

Free to use = no expectation, no problem.

yandaoyan
Level 1
Level 1
Posts: 7
Joined: Tue May 16, 2017 12:36 pm

Re: Unable to get sound

Post by yandaoyan »

Solution:

In sequence:

1. In windows 10 -> Device Manager -> Make sure both mobo's sound card & creative sound card installed properly with KX driver

2. On VMware -> Boot up Mint -> Play any song on youtube

3. Enable & Disable between High Definition Audio & KX device for personal liking of output from Mint linux.

Bye.

Post Reply

Return to “Newbie Questions”