Page 1 of 1

How to boot Mint in BIOS mode?

Posted: Fri May 26, 2017 2:00 pm
by Paladin193
I am a completely new Linux user attempting to dual boot it with Windows 10. I am running Mint for the first time (18.1, x64, cinnamon), and I cannot presently install it. Mint boots up just fine from my USB, and operates well there, but every time I go to install, I receive an error message telling me that my copy of Windows is booted through the BIOS legacy system, but Mint is trying to boot through UEFI, and that forcing the Mint installation through could make Windows unbootable.

I have looked up ways around this; the most common is to switch flash drives, which has had no effect. I have gone into the boot settings on my BIOS, and I can find no way to set the drive to boot in any way but UEFI (I have a Gigabyte H110m micro ATX board, if that helps). Does anyone know any other workarounds I can try?

Thanks!

Re: How to boot Mint in BIOS mode?

Posted: Fri May 26, 2017 2:57 pm
by kukamuumuka
You do not need to boot in BIOS mode. Just install and select grub location to MBR (master-boot-record), which usually is /dev/sda

Of course your installation option is "Something else" .

Re: How to boot Mint in BIOS mode?

Posted: Fri May 26, 2017 3:52 pm
by Paladin193
I never make it that far though. I only check the box to install third party software and I get a message basically saying that going any further in the installation may make Windows unusable. Are you saying that I'd be fine to continue?

Re: How to boot Mint in BIOS mode?

Posted: Fri May 26, 2017 4:20 pm
by WharfRat
Paladin193 wrote:I never make it that far though. I only check the box to install third party software and I get a message basically saying that going any further in the installation may make Windows unusable. Are you saying that I'd be fine to continue?
Don't do anything until you're absolutely sure.

It seems like you're booting in EFI mode and windows is installed in legacy mode.

Try to verify this with [ -d /sys/firmware/efi ] && echo "Currently in EFI mode" || echo "Currently in Legacy mode" in the terminal.

I'm not an expert with these BIOS setups, but see if there's an option to boot USB in legacy mode if you're in EFI.

Also there are other members here that know far more than I do about this so just be patient.

Windows is not easy to reinstall so you certainly do not want to break it.

Re: How to boot Mint in BIOS mode?

Posted: Fri May 26, 2017 11:10 pm
by gold_finger
Like WharfRat said, sounds like Windows was installed in Legacy/Bios mode and your Mint USB stick is being booted in UEFI mode. DO NOT attempt installing if that is the situation!

So we can be absolutely certain what the situation is, boot with Mint USB again, open a terminal (Menu -> Accessories -> Terminal) and enter the following commands one-at-a-time. First one will let us know what mode the USB has been booted in. Second will show us what current partitions on hard drive(s) look like -- from that we can tell how Windows was installed. Third will list the hardware specs of your computer.

Code: Select all

ls /sys/firmware
sudo parted --list
inxi -Fxz
Follow directions on this post to copy/paste the full results of all commands back here for us to see. We can advise how to proceed after seeing them.

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 8:47 am
by Paladin193
Here goes:

Code: Select all

mint@mint ~ $ ls/sys/firmware
bash: ls/sys/firmware: No such file or directory
mint@mint ~ $ ls /sys/firmware
acpi  dmi  efi  memmap
mint@mint ~ $ sudo parted --list
Model: ATA WDC WD10EZEX-60W (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  525MB   524MB   primary  ntfs         boot
 2      525MB   1000GB  1000GB  primary  ntfs


Warning: The driver descriptor says the physical block size is 2048 bytes, but
Linux says it is 512 bytes.
Ignore/Cancel? ignore                                                     
Model: Generic Flash Disk (scsi)
Disk /dev/sdb: 7969MB
Sector size (logical/physical): 2048B/512B
Partition Table: mac
Disk Flags: 

Number  Start   End     Size    File system  Name   Flags
 1      2048B   6143B   4096B                Apple
 2      1804MB  1806MB  2425kB               EFI


mint@mint ~ $ inxi -Fxz
System:    Host: mint Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.2.6 (Gtk 3.18.9-1ubuntu3.1)
           Distro: Linux Mint 18.1 Serena
Machine:   System: Gigabyte product: N/A
           Mobo: Gigabyte model: H110M-A-CF v: x.x
           Bios: American Megatrends v: F5 date: 03/07/2016
CPU:       Dual core Intel Core i3-6100 (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 14783
           clock speeds: max: 3700 MHz 1: 799 MHz 2: 799 MHz 3: 1229 MHz
           4: 799 MHz
Graphics:  Card: NVIDIA GM107 [GeForce GTX 750 Ti] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) FAILED: nouveau
           Resolution: 1440x900@59.89hz
           GLX Renderer: Gallium 0.4 on NV117
           GLX Version: 3.0 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card-1 NVIDIA Device 0fbc driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Intel Sunrise Point-H HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Card-3 Microsoft LifeCam VX-5000 driver: USB Audio usb-ID: 001-004
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB temp: 24C
           ID-2: USB /dev/sdb model: Flash_Disk size: 2.0GB temp: 0C
Partition: ID-1: / size: 3.9G used: 38M (1%) fs: overlay dev: N/A
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 33.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 190 Uptime: 1 min Memory: 425.9/7936.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35 
mint@mint ~ $ 
Another thing that might be of note is that I just discovered that both the boot and the grub files on my flash drive have ".efi" extensions in Windows. Does that mean that reimaging the disk in a format other than FAT32 might help?

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 9:54 am
by deepakdeshp

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 10:50 am
by Paladin193
@deepakdeshp Interesting, but I have the opposite issue and my bios doesn't give me an obvious way to boot the USB in legacy mode.

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 11:20 am
by austin.texas
When you press F8 during boot, you should get a boot menu which lists 2 different ways to boot a USB:
ADATA USB
UEFI ADATA USB

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 11:25 am
by kukamuumuka
Paladin193 wrote:@deepakdeshp Interesting, but I have the opposite issue and my bios doesn't give me an obvious way to boot the USB in legacy mode.
You have made mint-usb in Mac OS, which has created efi-bootable usb. :wink:

Make an installation-usb using Unetbootin.

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 11:48 am
by michael louwe
@ Paladin193

Is there an option for CSM or Legacy Boot in your UEFI BIOS settings.?

CSM enabled = to install Linux or Windows in Legacy/BIOS/ms-dos/MBR mode, and not in UEFI/GPT mode.
Secure Boot and Fast Boot should be disabled.

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 3:59 pm
by Paladin193
@micheal louwe

That's part of the issue. Even if I set my bios to boot from external storage in legacy only, it still boots in uefi

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 4:04 pm
by Paladin193
@administrollaatori

Not that I'm aware of. I made the image on Windows 10, using the win32 disk imager software. Also, the service you suggested only supports up to mint 17.2.

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 4:08 pm
by austin.texas

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 4:11 pm
by Neil Edmond
Paladin193 wrote:the service you suggested only supports up to mint 17.2.
Unetbootin can be used with any ISO you have downloaded, not just the ones on their website. I've found Rufus and even easier to use tool for making bootable USB drives on Windows. Give one a try, you might surprised by the results.

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 4:49 pm
by Paladin193
When using Rufus, I get the same warning as before, but said warning disappears and allows me to continue if I don't choose to force it. Would this just mean an installation without Debian elements, and is this a safe option to choose?

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 5:09 pm
by Neil Edmond
As far as I can tell, it is always best to install Linux in the same way as Windows is installed. Not going on my own experience here as all my hardware is legacy BIOS. I have never had new enough hardware to be concerned with UEFI.

And, again, as far as I know, the method of USB creation doesn't have much, if anything, to do with whether the installation will be UEFI or BIOS. That choice is made in the system board settings...is it not? If I'm wrong about this, just wait a few minutes, and several others will set me/us straight.

Re: How to boot Mint in BIOS mode?

Posted: Sat May 27, 2017 8:44 pm
by gold_finger
Sorry took so long to get back on this.

Output posted shows Windows was installed in Legacy mode, but USB is being booted in UEFI mode. You need to boot USB in same mode as Windows to do a proper dual-boot install. Don't worry about getting into UEFI/Bios Settings, it's already booting in the proper mode (Legacy/CSM/Bios) -- if it weren't Windows wouldn't be working. However, that setting applies to booting from internal hard drive. To pick proper boot option for the USB stick you have to access the per session boot menu and select the non-UEFI option for the USB stick (have it plugged in while booting). Looks like austin.texas looked up how to do that for you -- did you try what he posted here?
austin.texas wrote:When you press F8 during boot, you should get a boot menu which lists 2 different ways to boot a USB:
ADATA USB
UEFI ADATA USB
Re: making USB -- Rufus (I think) will give option to make it UEFI bootable or not. If you're using Rufus, choose non-UEFI option. As for UNetBootin, the interface lets you pick two ways to make USB -- you want the second way (selecting "Disk Image") described in this post.

Right now Windows partitions are taking up whole disk. The installer will automatically shrink Windows "C: drive" and make Mint partitions when you pick to install "Alongside Windows". You can do that, or you can shrink Windows partition ahead of time using something like MiniTool Partition Wizard. Mint installer will then see and use the free space you created with MiniTool. Either way, it would be a good idea to defrag the "C: drive" in Windows before shrinking.

When ready to install, boot USB stick again using per session boot menu, open terminal and enter ls /sys/firmware command. If you don't see "efi" in the output, then you are booted properly in Legacy mode. If you do see it, reboot and try again.

Re: How to boot Mint in BIOS mode?

Posted: Sun May 28, 2017 2:50 am
by kukamuumuka
Paladin193 wrote:When using Rufus, I get the same warning as before, but said warning disappears and allows me to continue if I don't choose to force it. Would this just mean an installation without Debian elements, and is this a safe option to choose?
If you use Rufus in UEFI-windows, it makes an UEFI-bootable USB. Use Unetbootin. :wink: