Linux Mint 18.2 BETA -- Wifi issues with Intel 8265

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
romanpete
Level 1
Level 1
Posts: 1
Joined: Sun Jun 18, 2017 11:15 pm

Linux Mint 18.2 BETA -- Wifi issues with Intel 8265

Postby romanpete » Mon Jun 19, 2017 2:39 am

Thanks for the opportunity to review the beta version of Mint 18.2 “Sonya” Cinnamon.

I have been struggling with a hardware problem in my DELL XPS13 9365 which relates to the Intel 8265 (802.11ac 2x2 WiFi and Bluetooth) adapter. Both Fedora 25 and Ubuntu 16 recognize and work with this hardware but it seems that Mint 18 can only make use of either the WiFi or the Bluetooth, but not both. This depends on which kernel I am running.

4.4.0-53-generic Bluetooth works WiFi does not
4.8.0-54-generic No Bluetooth WiFi OK
4.10.0-22-generic No Bluetooth WiFi OK

When running the later kernels, the Bluetooth adapter is either not detectable or not manageable by the "Blueman-Applet” v2.04 ,or the native Mint 18.1 Bluetooth tool, which curiously sees my XPS13 as being “Bastien’s computer”.

UNFORTUNATELY, when I tried running a live version of the 18.2 beta, the new “Blueberry” bluetooth manager simply refused to run and I had no bluetooth connectivity. The WiFi seems to run perfectly well.

So I must add the following info to the table above:

4.8.0-53-generic No Bluetooth WiFi OK

Hopefully your team will be able to sort this out for the final release of of what looks to be a very neat version of Mint!
A fuller description of my system follows, and I would be happy to try out any suggestions you might have. I really DO want to run Mint ...

Cheers!

mint@mint ~ $ inxi -Fxz
System: Host: mint Kernel: 4.8.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.4.1 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya
Machine: System: Dell (portable) product: XPS 13 9365
Mobo: Dell model: 0M9R82 v: X00
Bios: Dell v: 01.00.03 date: 12/10/2016
CPU: Dual core Intel Core i5-7Y54 (-HT-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
clock speeds: max: 3200 MHz 1: 589 MHz 2: 507 MHz 3: 588 MHz
4: 594 MHz
Graphics: Card: Intel Device 591e bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 3200x1800@59.98hz
GLX Renderer: Mesa DRI Intel Kabylake GT2
GLX Version: 3.0 Mesa 12.0.6 Direct Rendering: Yes
Audio: Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.8.0-53-generic
Network: Card: Intel Device 24fd driver: iwlwifi bus-ID: 3c:00.0
IF: wlp60s0 state: up speed: N/A duplex: N/A mac: <filter>
Drives: HDD Total Size: 24.0GB (59.7% used)
ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
ID-2: USB /dev/sda model: USB_Flash_Drive size: 16.0GB temp: 0C
ID-3: USB /dev/sdb model: Cruzer_Blade size: 8.0GB temp: 0C
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 42.5C mobo: 29.8C
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 215 Uptime: 8 min Memory: 880.1/7878.6MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

JeremyB
Level 16
Level 16
Posts: 6963
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint 18.2 BETA -- Wifi issues with Intel 8265

Postby JeremyB » Mon Jun 19, 2017 5:09 pm

With the 4.8 kernel, in terminal try

Code: Select all

bluetoothctl

Code: Select all

power on

Code: Select all

scan on

use CTRL + d to exit

We can get your wifi to work in the 4.4 kernel using kernel backports from Intel
You must have been using Ubuntu 16.04.2 as Ubuntu 16.04 and Ubuntu 16.04.1 use the same 4.4 kernels as Linux Mint. I am not exactly sure why LM has issues with the bluetooth in the 4.8 and 4.10 kernels UNLESS it is firmware related and a simple

Code: Select all

sudo apt-get update && sudo apt-get install linux-firmware

along with a reboot may fix


Return to “Newbie Questions”

Who is online

Users browsing this forum: aylien119, z31fanatic and 8 guests