"gnome-keyring-daemon not responding"

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
triva
Level 1
Level 1
Posts: 2
Joined: Mon Jul 17, 2017 8:04 pm

"gnome-keyring-daemon not responding"

Post by triva » Mon Jul 17, 2017 9:09 pm

Hi all, glad to be a member. My problems is that after going from Linux Mint Cinnamon 18.1 to 18.2 which I upgraded using the Update Manager I started getting "gnome-keyring-daemon not responding" at restart or shutdown. I couldn't find a solution anywhere aside of a reinstall. It seems to be an old problem that's back which was never resolved. I just uninstalled gnome-keyring and seahorse and no more problem. Do I really need them and will I have problems later?

rbsudo
Level 2
Level 2
Posts: 57
Joined: Sat Jul 15, 2017 10:59 am

Re: "gnome-keyring-daemon not responding"

Post by rbsudo » Tue Jul 18, 2017 9:51 am

Hi triva, I fresh installed LM Cinnamon 18.2 this past weekend..... my first time ever using LM.
I only started seeing this issue during shutdown....never during a restart btw.... that surprised me.
I read this about Gnome keyring and decided I didn't want to run LM with that function being disabled.
https://en.wikipedia.org/wiki/GNOME_Keyring
So I did the reinstall.
I did do some tweeks to LM after having read things like, "Twenty things you should do to LM after install," etc.
I thought that maybe one of those tweeks had upset something and created the problem for me.
Linux Mint 18.3 Sylvia.. Cinnamon.. 32-bit and 64-bit
"I learn by going where I have to go," Roethke

triva
Level 1
Level 1
Posts: 2
Joined: Mon Jul 17, 2017 8:04 pm

Re: "gnome-keyring-daemon not responding"

Post by triva » Wed Jul 19, 2017 12:12 am

Thank you for your response and info rbsudo. I am seriously considering reinstalling because I'm a little leery running without it. It's that I had Mint so nice and it's a dual boot with ArchLabs which is also nicely customized and running very well which I would not like to mess up too. But if so be it, practice makes perfect. I've learned so much from my mistakes that I'm always looking forward to making a few more.

rbsudo
Level 2
Level 2
Posts: 57
Joined: Sat Jul 15, 2017 10:59 am

Re: "gnome-keyring-daemon not responding"

Post by rbsudo » Wed Jul 19, 2017 12:25 pm

That's the way I approached this also....regarding "practice makes perfect." I also have a dual boot on this pc with Windows 7.
I would suggest that you approach the re-install slowly, and if you have any questions, back out of the process and post them here on the forum.
Btw, my re-install of Mint has been working great so far. Good luck!
Linux Mint 18.3 Sylvia.. Cinnamon.. 32-bit and 64-bit
"I learn by going where I have to go," Roethke

Drumsal
Level 1
Level 1
Posts: 1
Joined: Wed Aug 09, 2017 5:32 am

Re: "gnome-keyring-daemon not responding"

Post by Drumsal » Wed Aug 09, 2017 6:31 am

Hello everyone. I'm experiencing the same issue of triva and, following the idea of rbsudo, tried to solve it with a fresh reinstall. Unfortunately, after few days the problem is here again, without making any strange settings' modification. Initially the problem appeared randomly, but in the last week it occurs anytime I stop the system. I could try with another fresh installation, but I'm pretty sure that the problem will appear again. I suppose a bug, but I have no idea on how to approach it. Tnx in advance for the attention.

tsaari88
Level 1
Level 1
Posts: 1
Joined: Wed Sep 06, 2017 9:51 am

Re: "gnome-keyring-daemon not responding"

Post by tsaari88 » Wed Sep 06, 2017 11:13 am

Hi all, I think I found a solution that has worked for me. I installed Linux Mint 18.2 Sonya (64 bit, Cinnamon) onto a relative's older Inspiron 1525 laptop and received this error message when attempting to logout or shutdown, as noted by others. I found a couple of complaints about a missing .desktop file in /var/log/syslog when I typed:

Code: Select all

grep "gnome-keyring-daemon" /var/log/syslog
So then I created a gnome-keyring-daemon.desktop file inside ~/.config/autostart/

Here is what I have in that file:

Code: Select all

[Desktop Entry]
Type=Application
Exec=/usr/bin/gnome-keyring-daemon
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name=Gnome Keyring Daemon
Comment=Load gnome keyring daemon
Upon reboot, the problem seems to have gone away. I also noticed in my testing that running the code from this Archlinux wiki seemed to prevent the error as well, until the next reboot (or maybe even log off/on, didn't test it)

Code: Select all

gnome-keyring-daemon -r -d
Initializing an already started daemon with the -s flag may also work, but I never tested it. If this works then that gives more clues about what's really going wrong.

Code: Select all

gnome-keyring-daemon -s -d
Hope this info helps others.

catplace
Level 1
Level 1
Posts: 10
Joined: Sat Jun 17, 2017 5:10 pm

Re: "gnome-keyring-daemon not responding"

Post by catplace » Tue Oct 10, 2017 4:36 pm

tsaari88 wrote:...So then I created a gnome-keyring-daemon.desktop file inside ~/.config/autostart/...
Even though I didn't see any errors in syslog, this solution seems to have worked for me. Thanks!

Now I need to find out why! :)

User avatar
MikeLieberman
Level 1
Level 1
Posts: 39
Joined: Thu Apr 28, 2016 8:41 am
Location: Philippines
Contact:

Re: "gnome-keyring-daemon not responding"

Post by MikeLieberman » Sat Oct 28, 2017 5:09 am

I am not using autostart. But I am for the first time, on two machines upgraded to 18.2, getting this message. In on machines A desktop and a laptop, there are multiple accounts and login is manual. What's the deal? How do I fix this?

User avatar
Prsman
Level 4
Level 4
Posts: 258
Joined: Tue Nov 17, 2015 3:15 pm

Re: "gnome-keyring-daemon not responding"

Post by Prsman » Sat Oct 28, 2017 2:57 pm

This problem raises two questions. What is starting gnome-keyring-deamon and what is keeping it running on shutdown? I dont have an answer, but I am looking.
Found this site.

Code: Select all

https://denilson.sa.nom.br/blog/2015-05-14/gnome-keyring-on-lubuntu-15-04

I dont think this is the solution. May help you to dig into this problem. You could try:

Code: Select all

 pstree
On my computer, gnome-keyring-daemon comes from systemd. Wish I could be of more help. Warning: If you dont know - dont.

(EDIT)

Code: Select all

prs-player@prsplayer-Mint-18 /etc/xdg/autostart $ dpkg -L gnome-keyring
/.
/usr
/usr/share
/usr/share/dbus-1
/usr/share/dbus-1/services
/usr/share/dbus-1/services/org.gnome.keyring.service
/usr/share/dbus-1/services/org.freedesktop.secrets.service
/usr/share/GConf
/usr/share/GConf/gsettings
/usr/share/GConf/gsettings/org.gnome.crypto.cache.convert
/usr/share/upstart
/usr/share/upstart/sessions
/usr/share/upstart/sessions/gnome-keyring-ssh.conf
/usr/share/upstart/sessions/gnome-keyring.conf
/usr/share/doc
/usr/share/doc/gnome-keyring
/usr/share/doc/gnome-keyring/README.Debian
/usr/share/doc/gnome-keyring/AUTHORS
/usr/share/doc/gnome-keyring/README
/usr/share/doc/gnome-keyring/copyright
/usr/share/doc/gnome-keyring/NEWS.gz
/usr/share/doc/gnome-keyring/changelog.Debian.gz
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/gnome-keyring.1.gz
/usr/share/man/man1/gnome-keyring-daemon.1.gz
/usr/share/glib-2.0
/usr/share/glib-2.0/schemas
/usr/share/glib-2.0/schemas/org.gnome.crypto.cache.gschema.xml
/usr/bin
/usr/bin/gnome-keyring-daemon
/usr/bin/gnome-keyring-3
/usr/lib
/usr/lib/ubiquity
/usr/lib/ubiquity/target-config
/usr/lib/ubiquity/target-config/50gkd-caps
/usr/lib/gnome-keyring
/usr/lib/gnome-keyring/devel
/usr/lib/gnome-keyring/devel/gkm-gnome2-store-standalone.so
/usr/lib/gnome-keyring/devel/gkm-ssh-store-standalone.so
/usr/lib/gnome-keyring/devel/gkm-xdg-store-standalone.so
/usr/lib/gnome-keyring/devel/gkm-secret-store-standalone.so
/etc
/etc/xdg
/etc/xdg/autostart
/etc/xdg/autostart/gnome-keyring-secrets.desktop
/etc/xdg/autostart/gnome-keyring-pkcs11.desktop
/etc/xdg/autostart/gnome-keyring-ssh.desktop
/usr/bin/gnome-keyring
I seem to be missing this file: gnome-keyring-gpg.desktop Dont know if it is needed. From:

Code: Select all

 https://github.com/linuxmint/gnome-keyring/tree/master/daemon
Thats all I know.

User avatar
Prsman
Level 4
Level 4
Posts: 258
Joined: Tue Nov 17, 2015 3:15 pm

Re: "gnome-keyring-daemon not responding" (SOLVED)

Post by Prsman » Sun Oct 29, 2017 8:48 pm

Forget my previous posts. The fix is to select auto login from the systems settings. Select your user name and power down your computer, Pull the plug out of the wall and count to thirty. Reboot, you may have to do this twice. Then you can un-select auto login, reboot again and this bug should be gone. It is for me. Just to note I was missing the desktop file like an earlier poster, so I created it. But that did not fix this bug. Good luck.

MikeS
Level 1
Level 1
Posts: 11
Joined: Sat Aug 12, 2017 10:29 am

Re: "gnome-keyring-daemon not responding"

Post by MikeS » Sun Dec 03, 2017 3:08 pm

Thanks for the tip. Re-installing gnome-keyring worked on two PCs,but this was the only way that worked on a third PC.

allanr
Level 1
Level 1
Posts: 32
Joined: Tue Feb 07, 2017 1:02 pm
Location: Scotland

Re: "gnome-keyring-daemon not responding"

Post by allanr » Sat Feb 10, 2018 1:08 pm

This issue started for me directly after upgrading from Cinnamon 18.2 to 18.3 in mid-December, after which every switch-off hung for 60s or longer. I only have the one logon account, and tried all the fixes suggested here, but only two helped:

1) After running

Code: Select all

gnome-keyring-daemon -s -d
shut-down was ok, however the issue re-appeared at subsequent shut-downs.

2) The only successful (almost) solution for me was to obtain the "missing file" gnome-keyring-daemon.desktop from https://github.com/linuxmint/gnome-keyr ... ter/daemon as suggested by prsman. I say almost, because now 19 out of 20 shutdowns are ok, there's just the occasional 'gnome-keyring-daemon not responding' hang now. Although a big improvement, it would be good to get a permanent fix.

EDIT TO ADD: and place the gnome-keyring-daemon.desktop in folder /etc/xdg/autostart/
Image

allanr
Level 1
Level 1
Posts: 32
Joined: Tue Feb 07, 2017 1:02 pm
Location: Scotland

Re: "gnome-keyring-daemon not responding"

Post by allanr » Fri Mar 23, 2018 5:11 pm

I've inadvertently found a reliable workaround (at least for me) for the "gnome-keyring-daemon not responding" issue.
My wife wanted a simpler / more direct way to shut down her laptop and I found the Session Manager applet fitted the bill nicely.

Trying out the applet on my PC first, I realised I never saw the "gnome-keyring-daemon not responding" error. In fact even after the normal Menu > Shut Down action displayed the error, canceling then using the Session Manager applet always gave a clean, quick, shut down.
Image

Zhirrie
Level 1
Level 1
Posts: 1
Joined: Tue Mar 27, 2018 12:02 am

Re: "gnome-keyring-daemon not responding"

Post by Zhirrie » Tue Mar 27, 2018 12:19 am

I was having this issue as well with fresh installs of Linux Mint. I found the post below to be effective... I used the GUI - clicked on Administration > Login Window > Users > Turned on 'Allow manual login' and Typed my user name in Automatic login text box below. I then powered the machine down twice as the first did not make the error pop up go away.

I have done this on two different machines in the same day. It worked each time. After I was no longer getting the error pop-up I turned off the auto login and removed my user name from the text box. Thank you, Thank you, Thank you! Prsman
Re: "gnome-keyring-daemon not responding" (SOLVED)
Post by Prsman » Sun Oct 29, 2017 8:48 pm

Forget my previous posts. The fix is to select auto login from the systems settings. Select your user name and power down your computer, Pull the plug out of the wall and count to thirty. Reboot, you may have to do this twice. Then you can un-select auto login, reboot again and this bug should be gone. It is for me. Just to note I was missing the desktop file like an earlier poster, so I created it. But that did not fix this bug. Good luck.

Quetzal
Level 2
Level 2
Posts: 66
Joined: Wed Sep 09, 2015 8:24 am

Re: "gnome-keyring-daemon not responding"

Post by Quetzal » Thu Dec 20, 2018 3:49 pm

@allanr
I've inadvertently found a reliable workaround (at least for me) for the "gnome-keyring-daemon not responding" issue.
My wife wanted a simpler / more direct way to shut down her laptop and I found the Session Manager applet fitted the bill nicely.

Trying out the applet on my PC first, I realised I never saw the "gnome-keyring-daemon not responding" error. In fact even after the normal Menu > Shut Down action displayed the error, canceling then using the Session Manager applet always gave a clean, quick, shut down.
This worked for me too. Thanks for that.

Post Reply

Return to “Newbie Questions”