Page 1 of 1

MINT 18.2 Cinnamon : something wrong with my laptop touchpad

Posted: Fri Jul 28, 2017 10:33 pm
by wooden
I have just installed a dual system in my laptop. And the version of operating system is Linux Mint 18.2 Cinnamon 64-bit. After installing it successfully, I found that my touchpad wasn't working at all. I tried my wireless mouse with USB connector and it did worked. In my win10 system in the same computer, nothing is wrong about my touchpad. I checked my setting in Linux and everything about my touchpad is normal. I want to know what's the matter with my system. Thus, I come here to ask for help sincerely. Thank you very much.

Here are some information about my computer: (inxi -x command)
CPU~Dual core Intel Core m7-6Y75 (-HT-MCP-) speed/max~499/3100 MHz Kernel~4.8.0-53-generic x86_64 Up~5 min Mem~943.1/7841.8MB HDD~256.1GB(2.9% used) Procs~218 Client~Shell inxi~2.2.35

2017.7.29

Re: MINT 18.2 Cinnamon : something wrong with my laptop touchpad

Posted: Sat Jul 29, 2017 12:00 am
by prestonR
Can you first open a terminal and run:

Code: Select all

sudo apt-get install xserver-xorg-input-synaptics
Also, can you tell us what laptop it is and please post the results of:

Code: Select all

xinput --list
and

Code: Select all

cat /proc/bus/input/devices
so we can check if xorg and the kernel detect it.

Re: MINT 18.2 Cinnamon : something wrong with my laptop touchpad

Posted: Tue Aug 01, 2017 3:54 am
by dawgdoc
Some of the Dell laptops use Synaptics touchpads and have given some people problems for a while when running linux. I am using a Dell Inspiron 15-5555. Under LM 18.1 the toucpad worked except that there were no "button" zones at the bottom left and right of the touchpad. When I upgraded to LM 18.2, I found the touchpad would work for a minute or two and then stop responding. A wireless mouse worked well at all times. I found a solution that has solved my issues completely.

Running the command prestonR suggested will tell you if you have a Synaptics touchpad. On my system xserver-xorg-input-synaptics was installed by default, so I did not run this command.

Code: Select all

dawgdoc@dawgdoc-Inspiron-5555 ~ $ xinput
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ MOSART Semi. 2.4G RF Keyboard & Mouse   	id=11	[slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad              	id=13	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=8	[slave  keyboard (3)]
    ↳ Integrated_Webcam_HD                    	id=9	[slave  keyboard (3)]
    ↳ MOSART Semi. 2.4G RF Keyboard & Mouse   	id=10	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=12	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=14	[slave  keyboard (3)]
The edited output for the last command follows:

Code: Select all

dawgdoc@dawgdoc-Inspiron-5555 ~ $ cat /proc/bus/input/devices

I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse1 event7 
B: PROP=5
B: EV=b
B: KEY=e520 10000 0 0 0 0
B: ABS=660800011000003

The solution I found references Dell laptops, but the commands seem to indicate it should work for any laptop with a Synpatics touchpad. Check here for instructions.

Re: MINT 18.2 Cinnamon : something wrong with my laptop touchpad

Posted: Fri Sep 01, 2017 10:55 am
by pmwright
I have just installed 18.2 Sonya on a Dell Inspiron N5010 with a working Synaptic touch pad. The touchpad cannot be seen. I followed the steps in this post and still cannot even see the Touchpad listed in the xinput command.

I have searched several post and tried many things, but so far I cannot get the touchpad to work:
  • There isn't a BIOS setting for touchpad
    The Dell Touchpad disable key near the Function Keys has been toggled
    Edit of /etc/defaut/grub file (GRUB_CMDLINE_LINUX="i8042.noloop")
    I can enable/disable via the Mouse and Touchpad Hardware Settings applet
What else can I try?

Code: Select all

faculty@IST-Laptop / $ sudo apt-get install xserver-xorg-input-synaptics
Reading package lists... Done
Building dependency tree       
Reading state information... Done
xserver-xorg-input-synaptics is already the newest version (1.8.2-1ubuntu3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Code: Select all

faculty@IST-Laptop / $ xinput
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse              	id=10	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_1.3M           	id=11	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=14	[slave  keyboard (3)]

Code: Select all

faculty@IST-Laptop /etc/default $ cat grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic"
GRUB_CMDLINE_LINUX="i8042.noloop"

Re: MINT 18.2 Cinnamon : something wrong with my laptop touchpad

Posted: Mon Nov 27, 2017 3:56 pm
by sbroccolo
Try installing the libinput driver. It seems to work better on Synaptics Touchpad than the Synaptics driver. Go figure.

Code: Select all

sudo apt-get install xserver-xorg-input-libinput
It is the default driver for Ubuntu and Linux Mint 18.3.

You'll be able ot see the change with this. Where id is the the number listed in the xinput output.

Code: Select all

xinput list-props id
Good luck!