Unable to Create Xorg.conf to permanently set resolution

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
dwipkumar
Level 1
Level 1
Posts: 2
Joined: Sun Jul 30, 2017 10:18 am

Unable to Create Xorg.conf to permanently set resolution

Post by dwipkumar » Sun Jul 30, 2017 10:42 am

Hi, I am a newbie and it's my day 2 on linux platform. I"m on Linux Mint 18.2 "Sonya" Cinnamon 64-bit.
I've been reading online guides to setup undetected screen resolution (1368x768).

Code: Select all

sudo cvt 1368 768 60

Code: Select all

sudo xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync

Code: Select all

sudo xrandr --addmode VGA-0 1368x768_60.00
The above mentioned commands did get me my resolution but it's not permanent, so I tried to create the Xorg.conf file.

Code: Select all

sudo service lightdm stop

Code: Select all

sudo Xorg -configure
The last command gave an error "No devices to configure. Configuration failed (EE) Server terminated with error (2). Closing log file"
The guide said this would create a file name Xorg.conf.new in the home directory, but I couldn't find it anywhere.

Code: Select all

lspci -vnn | grep VGA
gave me this :
00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8370D] [1002:9998] (prog-if 00 [VGA controller])
Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64

User avatar
Spearmint2
Level 15
Level 15
Posts: 5768
Joined: Sat May 04, 2013 1:41 pm
Location: Maryland, USA

Re: Unable to Create Xorg.conf to permanently set resolution

Post by Spearmint2 » Tue Aug 01, 2017 12:24 am

use .xprofile instead in your home folder.

create a file called .xprofile and paste the following into it.

Code: Select all

xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode VGA-0 1368x768_60.00
Log out, then back in. It should then be available to make default in your monitor settings.
All things go better with Mint. Mint julep, mint jelly, mint gum, candy mints, pillow mints, peppermint, chocolate mints, spearmint,....

dwipkumar
Level 1
Level 1
Posts: 2
Joined: Sun Jul 30, 2017 10:18 am

Re: Unable to Create Xorg.conf to permanently set resolution

Post by dwipkumar » Tue Aug 01, 2017 12:22 pm

Spearmint2 wrote:use .xprofile instead in your home folder.

create a file called .xprofile and paste the following into it.

Code: Select all

xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
xrandr --addmode VGA-0 1368x768_60.00
Log out, then back in. It should then be available to make default in your monitor settings.
That worked! Thank you so much for your help.

DrM
Level 2
Level 2
Posts: 87
Joined: Sun Feb 23, 2014 4:03 pm

Re: Unable to Create Xorg.conf to permanently set resolution

Post by DrM » Sun Oct 29, 2017 9:23 am

Doesn't use Linux Mint 18.x use the /etc/X11/xorg.conf file anymore? Rather stupid that the Xorg -configure command sais that there is no device to configure.

Post Reply

Return to “Newbie Questions”