shutdown: gnome-keyring-daemon still running

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Teksonik
Level 3
Level 3
Posts: 137
Joined: Mon Apr 10, 2017 10:18 pm

Re: shutdown: gnome-keyring-daemon still running

Post by Teksonik » Thu Dec 14, 2017 11:45 pm

Same problem here with the gnome-keyring-daemon not closing on shut down. Seems like a fairly common issue. It only happens periodically here but on two different systems.

18.3 64 bit Cinnamon

Yontrop1
Level 1
Level 1
Posts: 1
Joined: Tue Oct 17, 2017 10:33 am

Re: shutdown: gnome-keyring-daemon still running

Post by Yontrop1 » Sun Dec 17, 2017 5:51 pm

I had the same problem (I''m running Mint 18,2 with Cinnamon). I followed the below advice but then also made sure I ran all the updates suggested. After doing this the error message does not come up. It's been about a week now, and still no problem. I'm new to Linux and started using it because I don't like Win 10 making the updates without asking me, Now I'll have to get used to remembering to check this, but I can live with that.

1
jeaserve wrote:I am not an experience user of the Linux world, however I think I figured out why this annoying issue is presented. When you upgrade to a newer version of Mint and you have more than one user, you need to log in all of the accounts at least once.
On the reminder on the far fight of the screen, you are notified if you want to install any updates.
When you first log in, the update link requires the you answer if you want to just keep my computer safe, you want to view the offered changes or just update.
This process has to be answered by all of the users you have created.
Just log out and log in to the other user and select the update icon and answer how to apply the updates.
All should be okay...Rafael (at least it works for me)
The "reminder on the far fight of the screen" is the little shield in the group of icons in the bottom right corner of the screen.

pvbrandes
Level 1
Level 1
Posts: 7
Joined: Sun Sep 18, 2011 9:44 pm
Location: Washington State

Re: shutdown: gnome-keyring-daemon still running

Post by pvbrandes » Sat Dec 30, 2017 2:29 am

LM 18.3 Cinnamon: Started getting “gnome-keyring-daemon not responding” error at shutdown after installing Chromium and turning off the “Let Chromium run in the background” option. Right click the system tray icon to change the option, or find in settings-advanced-system. Tried other solutions I found posted in this forum, but nothing worked. Saw one post about gnome-keyring and Chromium, which got me thinking. PC shuts down immediately now. Hope this helps.

Update: This only worked once, and then the error came back. Uninstalled LM and went with Ubuntu-Gnome 16.04.3 LTS version. Working fine and no more errors.
Last edited by pvbrandes on Sun Jan 07, 2018 7:33 pm, edited 1 time in total.

schm0
Level 1
Level 1
Posts: 39
Joined: Mon Dec 08, 2014 12:27 pm

Re: shutdown: gnome-keyring-daemon still running

Post by schm0 » Sat Dec 30, 2017 9:16 pm

I've had this problem as well, simply logging in to all the accounts on the system and logging out solved the problem.

Rhinox
Level 1
Level 1
Posts: 17
Joined: Wed Aug 16, 2017 12:26 pm

Re: shutdown: gnome-keyring-daemon still running

Post by Rhinox » Tue Jan 09, 2018 3:32 pm

I tried everything, but the problem persists. Finally I switched to Mint/Xfce, and everything works as expected (no more "gnome-keyring-daemon still running" annoying messages)...

carum carvi
Level 4
Level 4
Posts: 285
Joined: Sun Apr 16, 2017 11:44 pm

Re: shutdown: gnome-keyring-daemon still running

Post by carum carvi » Wed Jan 10, 2018 5:32 am

schmO said it right. Simply log in and out with every user. And also press the update manager button in every user you create. That solved the problem for me too. Really irritating to see that gnome keyring message but it can be gotten rid off.

Rhinox
Level 1
Level 1
Posts: 17
Joined: Wed Aug 16, 2017 12:26 pm

Re: shutdown: gnome-keyring-daemon still running

Post by Rhinox » Wed Jan 10, 2018 1:28 pm

I tried log-in/log-out with all users, and it worked. Well, kind of. After next restart, it was back again "gnome-keyring-daemon running..."

Log in/out with all users every time I want just shutdown is not solution. This is simply stupid bug, and should be fixed...

User avatar
pbear
Level 5
Level 5
Posts: 596
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: shutdown: gnome-keyring-daemon still running

Post by pbear » Wed Jan 10, 2018 2:18 pm

FWIW, MATE doesn't have this problem either.
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

MenthaSuaveolens
Level 2
Level 2
Posts: 59
Joined: Wed Apr 25, 2012 3:43 pm
Location: Belgium

Re: shutdown: gnome-keyring-daemon still running

Post by MenthaSuaveolens » Fri Jan 26, 2018 4:34 am

I encounter the same problem.

User avatar
Faust
Level 4
Level 4
Posts: 431
Joined: Thu Jul 14, 2016 3:40 am

Re: shutdown: gnome-keyring-daemon still running

Post by Faust » Fri Jan 26, 2018 6:38 am

schm0 wrote:I've had this problem as well, simply logging in to all the accounts on the system and logging out solved the problem.
Same here , with 18.3 Cinnamon

Settings => Login Window => Users
I tried toggling all the default settings the other way , and then back again ..... BAD mistake !
Guest login was the only available option after that , and I can see what trouble people have had sorting that one out -

viewtopic.php?f=90&t=261853&p=1416354&h ... r#p1416354
viewtopic.php?f=57&t=261704&p=1414741&h ... r#p1414741

And another thing ..... is anyone seeing the "reverse scrolling " option set to ON by default ?
What's that all about ?
" And so it goes " - Kurt Vonnegut
The modern reality and the satirical parody are rapidly converging .

mesoderm
Level 1
Level 1
Posts: 5
Joined: Mon Jan 22, 2018 4:08 pm

Re: shutdown: gnome-keyring-daemon still running

Post by mesoderm » Tue Jan 30, 2018 1:02 am

I have Linux Mint 18.3 running on two laptops and both do this. The only way to stop it, I've found, is to open a new terminal and enter:

gnome-keyring-daemon -r -d

It's a pain to remember to do this before shutting down, but it does work.

bobs
Level 1
Level 1
Posts: 1
Joined: Thu Feb 08, 2018 8:53 pm

Re: shutdown: gnome-keyring-daemon still running

Post by bobs » Thu Feb 08, 2018 8:56 pm

I am running Linux Mint 18.3 and had the same issue until I switched from the NVIDIA device driver to the open source driver. That cleared up the issue for me.

User avatar
Executioner
Level 3
Level 3
Posts: 102
Joined: Sat Feb 06, 2016 1:49 pm

Re: shutdown: gnome-keyring-daemon still running

Post by Executioner » Sun Feb 11, 2018 2:34 am

I have this problem on a fresh install under VMware using Mint x64 Cinnamon. On the other laptop which has the same version, but not in a VM, I have no issues and never seen the problem. I've tried every suggestion with no luck. Hope it's fixed son.

UPDATE: [SOLVED]
When I was installing Mint, it asked if I wanted to log in automatically which I selected yes. I believe this is the issue, because I changed to where I have to log in and the issue has gone away. This is the prompt window:

https://www.tecmint.com/wp-content/uplo ... ccount.png
Last edited by Executioner on Thu Feb 15, 2018 12:25 am, edited 2 times in total.

mf-linux
Level 1
Level 1
Posts: 43
Joined: Wed Sep 16, 2009 12:36 pm

Re: shutdown: gnome-keyring-daemon still running

Post by mf-linux » Wed Feb 14, 2018 2:23 pm

Same problem here with LM 18.3 and Cinnamon. I think it's related with Cinnamon, as Ubuntu+Cinnamon gave me the same problem (I've dual boot for LM and Ubuntu). However, when starting Ubuntu+MATE/Gnome/Xfce, no problem at all.
What is the meaning of "gnome-keyring-daemon -r -d"? I would like to know what this command does.
Thanks

oralover2006
Level 1
Level 1
Posts: 6
Joined: Mon Feb 05, 2018 11:35 am

Re: shutdown: gnome-keyring-daemon still running

Post by oralover2006 » Thu Feb 15, 2018 2:01 am

I am facing this on LM 18.3 Cinnamon, read various replies and it concluded that not a particular solution for this problem, mix solutions here ... means i have to hit & try till it solved.
regards

polish sausage
Level 1
Level 1
Posts: 1
Joined: Sat Feb 24, 2018 7:02 am

Re: shutdown: gnome-keyring-daemon still running

Post by polish sausage » Sat Feb 24, 2018 7:18 am

mint 18.3 cinnamon 64-bit:
google chrome browser (64-bit)- menu- settings- advanced- system- untick the box next to “Continue running background apps when Google Chrome is closed”
close browser and all apps
then restart system
it helps me :)

carum carvi
Level 4
Level 4
Posts: 285
Joined: Sun Apr 16, 2017 11:44 pm

Re: shutdown: gnome-keyring-daemon still running

Post by carum carvi » Sun Feb 25, 2018 1:03 am

Logging in and out with all users AND simultaneously check for updates with each user and restart. This has helped many others including myself.



I have installed and re installed various LinuxMint versions and sometimes I do encounter it again, but the very first advice keeps working for me:

Log in and out with all users AND simultaneously check for updates with each user. And then RESTART with each user.

Also when you have just 1 user you will get this gnome keyring message sometimes. But the same advice helps to erase it: check updates and RESTART. The second time around the message must have disappeared. Good luck.

Findbhair
Level 1
Level 1
Posts: 2
Joined: Sat Apr 14, 2018 7:48 am

Re: shutdown: gnome-keyring-daemon still running

Post by Findbhair » Sat Apr 14, 2018 8:07 am

Disable the keyring daemon
If you want to deactivate the gnome-keyring-daemon so that it does not start automatically with every system start, you have to remove the following two lines from the file /etc/pam.d/gdm or /etc/pam.d/mdm respectively /etc/pam.d/lightdm

Code: Select all

auth optional pam_gnome_keyring.so
session optional pam_gnome_keyring.so auto_start
Last edited by Findbhair on Sat Apr 14, 2018 1:20 pm, edited 1 time in total.

User avatar
AZgl1500
Level 9
Level 9
Posts: 2748
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: shutdown: gnome-keyring-daemon still running

Post by AZgl1500 » Sat Apr 14, 2018 10:28 am

Kernel: 4.13.0-38-generic x86_64 (64 bit)
Desktop: Cinnamon 3.6.7 Distro: Linux Mint 18.3 Sylvia


This file does not exist for me
/etc/pam.d/gdm

I did what you said for the other one, will wait and see if that keyring daemin comes up again, very aggravating.

Findbhair
Level 1
Level 1
Posts: 2
Joined: Sat Apr 14, 2018 7:48 am

Re: shutdown: gnome-keyring-daemon still running

Post by Findbhair » Sat Apr 14, 2018 11:05 am

if gdm file not exist, then find the /lightdm or /mdm file (it is either or)
take a look here -> http://i.prntscr.com/BnJZfck1QNiMq_hzjp1rxA.png

Post Reply

Return to “Newbie Questions”