Cannot connect to wifi on new install

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Cannot connect to wifi on new install

Postby msmith » Thu Sep 07, 2017 7:57 pm

I have a Lenovo Ideapad 110-15ISK that I've just put mint 18.2 Cinnamon on. The install went smoothly except that I can only connect using ethernet. My home network ID is listed in connections but when I enter the pass key it doesn't connect. The pass key has been accurately put in and I tried editing connections and saving the key that way to no avail. I've tried several things I've seen from searching the web but nothing has worked yet. I'm guessing my wireless card is an obscure make. Interestingly, I had no issues when I tried out Peppermint OS. Wireless worked out of the box so I'm not sure what's different. Thing is I had mint 17 on my other laptop before it finally died and would prefer to stay with mint versus peppermint.

That said, I'd appreciate any help y'all can give in getting this set up and working properly.

jglen490
Level 1
Level 1
Posts: 43
Joined: Sat Jul 15, 2017 9:57 pm

Re: Cannot connect to wifi on new install

Postby jglen490 » Thu Sep 07, 2017 8:22 pm

It's possible the wifi card is disabled, either hardware or software.

Open a terminal and enter

Code: Select all

rfkill list


Post what you find here using the Code tags.
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Fri Sep 08, 2017 2:54 am

Here ya go

Code: Select all

0: ideapad_wlan: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: ideapad_bluetooth: Bluetooth
   Soft blocked: no
   Hard blocked: no
2: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
3: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

Mattyboy
Level 4
Level 4
Posts: 454
Joined: Thu Mar 26, 2015 2:17 pm

Re: Cannot connect to wifi on new install

Postby Mattyboy » Fri Sep 08, 2017 4:45 am

Update your Kernel and system all levels 1 - 5 with the Ethernet plugged in. Then run

Code: Select all

sudo update-grub
remove the Ethernet and re-boot see if that helps.

Post the results of

Code: Select all

inxi -Fxz


and

Code: Select all

ifconfig

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Fri Sep 08, 2017 9:20 pm

Update your Kernel and system all levels 1 - 5 with the Ethernet plugged in. Then run



Code: Select all

sudo update-grub
remove the Ethernet and re-boot see if that helps.


I went through these steps earlier today before I left for work without success. I'll post the results of the terminal commands you listed when I get home from work tonight.

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Sat Sep 09, 2017 3:37 am

Code: Select all

mike@Lenovo-ideapad-110-15ISK ~ $ inxi -Fxz
System:    Host: Lenovo-ideapad-110-15ISK Kernel: 4.10.0-33-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.2 Sonya
Machine:   System: LENOVO product: 80UD v: Lenovo ideapad 110-15ISK
           Mobo: LENOVO model: Lenovo ideapad 1 v: SDK0J40700 WIN
           Bios: LENOVO v: 1TCN18WW(V1.01) date: 07/19/2016
CPU:       Dual core Intel Core i3-6100U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9216
           clock speeds: max: 2300 MHz 1: 499 MHz 2: 498 MHz 3: 499 MHz
           4: 500 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.97hz
           GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-33-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 4000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros Device 0042
           driver: ath10k_pci bus-ID: 02:00.0
           IF: wlp2s0 state: down mac: <filter>
           Card-3: Atheros usb-ID: 001-004
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1000.2GB (1.0% used)
           ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB
Partition: ID-1: / size: 913G used: 5.8G (1%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.16GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 34.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 198 Uptime: 8 min Memory: 756.2/3824.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Sat Sep 09, 2017 3:39 am

Code: Select all

mike@Lenovo-ideapad-110-15ISK ~ $ ifconfig
enp1s0    Link encap:Ethernet  HWaddr 1c:39:47:df:bc:27 
          inet addr:192.168.0.107  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::27d3:fcc0:7e1a:174e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3003 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2050 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2988908 (2.9 MB)  TX bytes:244917 (244.9 KB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:190 errors:0 dropped:0 overruns:0 frame:0
          TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:19998 (19.9 KB)  TX bytes:19998 (19.9 KB)

wlp2s0    Link encap:Ethernet  HWaddr 74:df:bf:66:cb:cf 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Mon Sep 11, 2017 12:30 am

Ideas? Anyone?

cflusflwfl
Level 1
Level 1
Posts: 4
Joined: Sun Jun 23, 2013 8:35 pm

Re: Cannot connect to wifi on new install

Postby cflusflwfl » Mon Sep 11, 2017 3:29 pm

I know it should not matter, but have you power cycled the router and rebooted your laptop? I had this problem once and that fixed it for me. If that doesn't work, can you temporarily remove the wireless password to see if it connects? Mind you, this is only temporary to troubleshoot. Also, what type of encryption is your wireless?

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Mon Sep 11, 2017 3:47 pm

I haven't tried cycling the router but can give it a shot.

I don't have access to the router as one normally might as its provided by the ISP. I'm not sure what the encryption protocol is off hand. I'm quite puzzled as Peppermint OS had no issues with the wifi at all. Down side for me is I really didn't care for the distro. On my last laptop I never had any connection issues with Linux Mint at all.

In the searches I have run it looks like there may be an issue with this wireless adapter but wouldn't that be true regardless of what distro you use? Also if the driver for the adapter is at fault wouldn't that affect the wired connection as well?

Networking has never been a strength for me and this has me stumped.

cflusflwfl
Level 1
Level 1
Posts: 4
Joined: Sun Jun 23, 2013 8:35 pm

Re: Cannot connect to wifi on new install

Postby cflusflwfl » Mon Sep 11, 2017 4:10 pm

If this is a laptop, have you tried taking it to a coffee shop or friend's house to see if it connects to a different wi-fi?

JeremyB
Level 17
Level 17
Posts: 7539
Joined: Fri Feb 21, 2014 8:17 am

Re: Cannot connect to wifi on new install

Postby JeremyB » Mon Sep 11, 2017 5:02 pm

Please see the wireless-script link in my signature and post results

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Mon Sep 11, 2017 6:14 pm

Here is the output Jeremy

Code: Select all

########## wireless info START ##########

Report from: 11 Sep 2017 17:12 CDT -0500

Booted last: 11 Sep 2017 00:00 CDT -0500

Script from: 25 Mar 2017 07:04 UTC +0000

##### release ###########################

Distributor ID:   LinuxMint
Description:   Linux Mint 18.2 Sonya
Release:   18.2
Codename:   sonya

##### kernel ############################

Linux 4.10.0-33-generic #37~16.04.1-Ubuntu SMP Fri Aug 11 14:07:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Parameters: ro, quiet, splash, vt.handoff=7

##### desktop ###########################

Cinnamon

##### lspci #############################

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [10ec:8136] (rev 07)
   Subsystem: Lenovo RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller [17aa:383b]
   Kernel driver in use: r8169

02:00.0 Network controller [0280]: Qualcomm Atheros Device [168c:0042] (rev 30)
   Subsystem: Lenovo Device [17aa:4035]
   Kernel driver in use: ath10k_pci

##### lsusb #############################

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0cf3:e360 Atheros Communications, Inc.
Bus 001 Device 003: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 002: ID 04f2:b581 Chicony Electronics Co., Ltd
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

##### PCMCIA card info ##################

##### rfkill ############################

0: ideapad_wlan: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: ideapad_bluetooth: Bluetooth
   Soft blocked: no
   Hard blocked: no
2: hci0: Bluetooth
   Soft blocked: no
   Hard blocked: no
3: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no

##### lsmod #############################

ath10k_pci             45056  0
ath10k_core           344064  1 ath10k_pci
ath                    28672  1 ath10k_core
mac80211              782336  1 ath10k_core
cfg80211              602112  3 mac80211,ath,ath10k_core
ideapad_laptop         28672  0
sparse_keymap          16384  1 ideapad_laptop
wmi                    16384  1 ideapad_laptop
video                  40960  2 i915,ideapad_laptop

##### interfaces ########################

auto lo
iface lo inet loopback

##### ifconfig ##########################

enp1s0    Link encap:Ethernet  HWaddr <MAC 'enp1s0' [IF1]> 
          inet addr:192.168.0.107  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::27d3:fcc0:7e1a:174e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4959486 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3880458 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6612734483 (6.6 GB)  TX bytes:644489599 (644.4 MB)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:6549 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6549 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:629455 (629.4 KB)  TX bytes:629455 (629.4 KB)

wlp2s0    Link encap:Ethernet  HWaddr <MAC 'wlp2s0' [IF2]> 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

##### iwconfig ##########################

enp1s0    no wireless extensions.

lo        no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
         

##### route #############################

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    100    0        0 enp1s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 enp1s0
192.168.0.0     0.0.0.0         255.255.255.0   U     100    0        0 enp1s0

##### resolv.conf #######################

nameserver 127.0.1.1
search engeniusrouter

##### network managers ##################

Installed:

   NetworkManager

Running:

root       926     1  0 14:37 ?        00:00:03 /usr/sbin/NetworkManager --no-daemon

##### NetworkManager info ###############

GENERAL.DEVICE:                         enp1s0
GENERAL.TYPE:                           ethernet
GENERAL.NM-TYPE:                        NMDeviceEthernet
GENERAL.VENDOR:                         Realtek Semiconductor Co., Ltd.
GENERAL.PRODUCT:                        RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
GENERAL.DRIVER:                         r8169
GENERAL.DRIVER-VERSION:                 2.3LK-NAPI
GENERAL.FIRMWARE-VERSION:               
GENERAL.HWADDR:                         <MAC 'enp1s0' [IF1]>
GENERAL.MTU:                            1500
GENERAL.STATE:                          100 (connected)
GENERAL.REASON:                         0 (No reason given)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.0/0000:01:00.0/net/enp1s0
GENERAL.IP-IFACE:                       enp1s0
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     Wired connection 1
GENERAL.CON-UUID:                       b5ba9c48-58f7-3d30-9a63-5316c7e6f0dc
GENERAL.CON-PATH:                       /org/freedesktop/NetworkManager/ActiveConnection/0
GENERAL.METERED:                        no (guessed)
CAPABILITIES.CARRIER-DETECT:            yes
CAPABILITIES.SPEED:                     100 Mb/s
CAPABILITIES.IS-SOFTWARE:               no
WIRED-PROPERTIES.CARRIER:               on
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{1}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   b5ba9c48-58f7-3d30-9a63-5316c7e6f0dc | Wired connection 1
IP4.ADDRESS[1]:                         192.168.0.107/24
IP4.GATEWAY:                            192.168.0.1
IP4.ROUTE[1]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000
IP4.DNS[1]:                             192.168.0.1
IP4.DOMAIN[1]:                          engeniusrouter
IP4.WINS[1]:                            192.168.0.1
DHCP4.OPTION[1]:                        requested_ms_classless_static_routes = 1
DHCP4.OPTION[2]:                        requested_domain_search = 1
DHCP4.OPTION[3]:                        requested_host_name = 1
DHCP4.OPTION[4]:                        requested_time_offset = 1
DHCP4.OPTION[5]:                        requested_domain_name = 1
DHCP4.OPTION[6]:                        requested_rfc3442_classless_static_routes = 1
DHCP4.OPTION[7]:                        requested_broadcast_address = 1
DHCP4.OPTION[8]:                        requested_wpad = 1
DHCP4.OPTION[9]:                        requested_netbios_scope = 1
DHCP4.OPTION[10]:                       next_server = 0.0.0.0
DHCP4.OPTION[11]:                       expiry = 1505245053
DHCP4.OPTION[12]:                       requested_interface_mtu = 1
DHCP4.OPTION[13]:                       requested_subnet_mask = 1
DHCP4.OPTION[14]:                       routers = 192.168.0.1
DHCP4.OPTION[15]:                       dhcp_message_type = 5
DHCP4.OPTION[16]:                       ip_address = 192.168.0.107
DHCP4.OPTION[17]:                       requested_static_routes = 1
DHCP4.OPTION[18]:                       domain_name = engeniusrouter
DHCP4.OPTION[19]:                       requested_domain_name_servers = 1
DHCP4.OPTION[20]:                       broadcast_address = 192.168.0.255
DHCP4.OPTION[21]:                       domain_name_servers = 192.168.0.1
DHCP4.OPTION[22]:                       requested_ntp_servers = 1
DHCP4.OPTION[23]:                       dhcp_lease_time = 86400
DHCP4.OPTION[24]:                       netbios_name_servers = 192.168.0.1
DHCP4.OPTION[25]:                       requested_netbios_name_servers = 1
DHCP4.OPTION[26]:                       subnet_mask = 255.255.255.0
DHCP4.OPTION[27]:                       network_number = 192.168.0.0
DHCP4.OPTION[28]:                       requested_routers = 1
DHCP4.OPTION[29]:                       dhcp_server_identifier = 192.168.0.1
IP6.ADDRESS[1]:                         fe80::27d3:fcc0:7e1a:174e/64
IP6.GATEWAY:                           

GENERAL.DEVICE:                         wlp2s0
GENERAL.TYPE:                           wifi
GENERAL.NM-TYPE:                        NMDeviceWifi
GENERAL.VENDOR:                         Qualcomm Atheros
GENERAL.PRODUCT:                        Sunrise Point-LP PCI Express Root Port
GENERAL.DRIVER:                         ath10k_pci
GENERAL.DRIVER-VERSION:                 4.10.0-33-generic
GENERAL.FIRMWARE-VERSION:               WLAN.TF.1.0-00267-1
GENERAL.HWADDR:                         <MAC 'wlp2s0' [IF2]>
GENERAL.MTU:                            0
GENERAL.STATE:                          30 (disconnected)
GENERAL.REASON:                         42 (The supplicant is now available)
GENERAL.UDI:                            /sys/devices/pci0000:00/0000:00:1c.5/0000:02:00.0/net/wlp2s0
GENERAL.IP-IFACE:                       
GENERAL.IS-SOFTWARE:                    no
GENERAL.NM-MANAGED:                     yes
GENERAL.AUTOCONNECT:                    yes
GENERAL.FIRMWARE-MISSING:               no
GENERAL.NM-PLUGIN-MISSING:              no
GENERAL.PHYS-PORT-ID:                   --
GENERAL.CONNECTION:                     --
GENERAL.CON-UUID:                       --
GENERAL.CON-PATH:                       --
GENERAL.METERED:                        unknown
CAPABILITIES.CARRIER-DETECT:            no
CAPABILITIES.SPEED:                     unknown
CAPABILITIES.IS-SOFTWARE:               no
WIFI-PROPERTIES.WEP:                    yes
WIFI-PROPERTIES.WPA:                    yes
WIFI-PROPERTIES.WPA2:                   yes
WIFI-PROPERTIES.TKIP:                   yes
WIFI-PROPERTIES.CCMP:                   yes
WIFI-PROPERTIES.AP:                     yes
WIFI-PROPERTIES.ADHOC:                  yes
WIFI-PROPERTIES.2GHZ:                   yes
WIFI-PROPERTIES.5GHZ:                   yes
CONNECTIONS.AVAILABLE-CONNECTION-PATHS: /org/freedesktop/NetworkManager/Settings/{0}
CONNECTIONS.AVAILABLE-CONNECTIONS[1]:   f233d9d8-447a-4f16-a537-91e0363078fa | Auto EnGenius43C1A3

SSID            BSSID              MODE   CHAN  FREQ      RATE       SIGNAL  BARS  SECURITY  ACTIVE  *
EnGenius43C1A3  <MAC 'EnGenius43C1A3' [AC1]>  Infra  6     2437 MHz  54 Mbit/s  74      ▂▄▆_  WPA2      no       

##### NetworkManager.state ##############

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true

##### NetworkManager.conf ###############

[main]
plugins=ifupdown,keyfile,ofono
dns=dnsmasq

[ifupdown]
managed=false

##### NetworkManager profiles ###########

[[/etc/NetworkManager/system-connections/Auto EnGenius43C1A3]] (600 root)
[connection] id=Auto EnGenius43C1A3 | type=wifi | permissions=
[wifi] mac-address=<MAC 'wlp2s0' [IF2]> | mac-address-blacklist= | ssid=EnGenius43C1A3
[ipv4] method=auto
[ipv6] method=auto

##### iw reg get ########################

Region: America/Chicago (based on set time zone)

country 00: DFS-UNSET
   (2402 - 2472 @ 40), (N/A, 20), (N/A)
   (2457 - 2482 @ 40), (N/A, 20), (N/A), NO-IR
   (2474 - 2494 @ 20), (N/A, 20), (N/A), NO-OFDM, NO-IR
   (5170 - 5250 @ 80), (N/A, 20), (N/A), NO-IR
   (5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS, NO-IR
   (5490 - 5730 @ 160), (N/A, 20), (0 ms), DFS, NO-IR
   (5735 - 5835 @ 80), (N/A, 20), (N/A), NO-IR
   (57240 - 63720 @ 2160), (N/A, 0), (N/A)

##### iwlist channels ###################

enp1s0    no frequency information.

lo        no frequency information.

wlp2s0    32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz

##### iwlist scan #######################

enp1s0    Interface doesn't support scanning.

lo        Interface doesn't support scanning.

Channel occupancy:

      1   APs on   Frequency:2.437 GHz (Channel 6)

wlp2s0    Scan completed :
          Cell 01 - Address: <MAC 'EnGenius43C1A3' [AC1]>
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=61/70  Signal level=-49 dBm 
                    Encryption key:on
                    ESSID:"EnGenius43C1A3"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
                              18 Mb/s; 36 Mb/s; 54 Mb/s
                    Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
                    Mode:Master
                    Extra:tsf=00000028debe64a7
                    Extra: Last beacon: 4384ms ago
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                        Authentication Suites (1) : PSK

##### module infos ######################

[ath10k_pci]
filename:       /lib/modules/4.10.0-33-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_pci.ko
firmware:       ath10k/QCA9377/hw1.0/board.bin
firmware:       ath10k/QCA9377/hw1.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/board-2.bin
firmware:       ath10k/QCA6174/hw3.0/board.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-5.bin
firmware:       ath10k/QCA6174/hw3.0/firmware-4.bin
firmware:       ath10k/QCA6174/hw2.1/board-2.bin
firmware:       ath10k/QCA6174/hw2.1/board.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-5.bin
firmware:       ath10k/QCA6174/hw2.1/firmware-4.bin
firmware:       ath10k/QCA9887/hw1.0/board-2.bin
firmware:       ath10k/QCA9887/hw1.0/board.bin
firmware:       ath10k/QCA9887/hw1.0/firmware-5.bin
firmware:       ath10k/QCA988X/hw2.0/board-2.bin
firmware:       ath10k/QCA988X/hw2.0/board.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-5.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-4.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-3.bin
firmware:       ath10k/QCA988X/hw2.0/firmware-2.bin
license:        Dual BSD/GPL
description:    Driver support for Qualcomm Atheros 802.11ac WLAN PCIe/AHB devices
author:         Qualcomm Atheros
srcversion:     55269025DC0881FB8B580CD
depends:        ath10k_core
intree:         Y
vermagic:       4.10.0-33-generic SMP mod_unload
parm:           irq_mode:0: auto, 1: legacy, 2: msi (default: 0) (uint)
parm:           reset_mode:0: auto, 1: warm only (default: 0) (uint)

[ath10k_core]
filename:       /lib/modules/4.10.0-33-generic/kernel/drivers/net/wireless/ath/ath10k/ath10k_core.ko
license:        Dual BSD/GPL
description:    Core module for Qualcomm Atheros 802.11ac wireless LAN cards.
author:         Qualcomm Atheros
srcversion:     5C9FBF8E26C59F023BC8558
depends:        mac80211,cfg80211,ath
intree:         Y
vermagic:       4.10.0-33-generic SMP mod_unload
parm:           debug_mask:Debugging mask (uint)
parm:           uart_print:Uart target debugging (bool)
parm:           skip_otp:Skip otp failure for calibration in testmode (bool)
parm:           cryptmode:Crypto mode: 0-hardware, 1-software (uint)
parm:           rawmode:Use raw 802.11 frame datapath (bool)

[ath]
filename:       /lib/modules/4.10.0-33-generic/kernel/drivers/net/wireless/ath/ath.ko
license:        Dual BSD/GPL
description:    Shared library for Atheros wireless LAN cards.
author:         Atheros Communications
srcversion:     4B8612B6FF71DD27AE8CE67
depends:        cfg80211
intree:         Y
vermagic:       4.10.0-33-generic SMP mod_unload

[mac80211]
filename:       /lib/modules/4.10.0-33-generic/kernel/net/mac80211/mac80211.ko
license:        GPL
description:    IEEE 802.11 subsystem
srcversion:     309C9ACED540FCAA1DE7422
depends:        cfg80211
intree:         Y
vermagic:       4.10.0-33-generic SMP mod_unload
parm:           minstrel_vht_only:Use only VHT rates when VHT is supported by sta. (bool)
parm:           max_nullfunc_tries:Maximum nullfunc tx tries before disconnecting (reason 4). (int)
parm:           max_probe_tries:Maximum probe tries before disconnecting (reason 4). (int)
parm:           beacon_loss_count:Number of beacon intervals before we decide beacon was lost. (int)
parm:           probe_wait_ms:Maximum time(ms) to wait for probe response before disconnecting (reason 4). (int)
parm:           ieee80211_default_rc_algo:Default rate control algorithm for mac80211 to use (charp)

[cfg80211]
filename:       /lib/modules/4.10.0-33-generic/kernel/net/wireless/cfg80211.ko
description:    wireless configuration support
license:        GPL
author:         Johannes Berg
srcversion:     D77C8F93375950F3BA95B16
depends:       
intree:         Y
vermagic:       4.10.0-33-generic SMP mod_unload
parm:           bss_entries_limit:limit to number of scan BSS entries (per wiphy, default 1000) (int)
parm:           ieee80211_regdom:IEEE 802.11 regulatory domain code (charp)
parm:           cfg80211_disable_40mhz_24ghz:Disable 40MHz support in the 2.4GHz band (bool)

##### module parameters #################

[ath10k_pci]
irq_mode: 0
reset_mode: 0

[ath10k_core]
cryptmode: 0
debug_mask: 0
rawmode: N
skip_otp: N
uart_print: N

[mac80211]
beacon_loss_count: 7
ieee80211_default_rc_algo: minstrel_ht
max_nullfunc_tries: 2
max_probe_tries: 5
minstrel_vht_only: Y
probe_wait_ms: 500

[cfg80211]
bss_entries_limit: 1000
cfg80211_disable_40mhz_24ghz: N
ieee80211_regdom: 00

##### /etc/modules ######################

##### modprobe options ##################

[/etc/modprobe.d/blacklist-ath_pci.conf]
blacklist ath_pci

[/etc/modprobe.d/blacklist.conf]
blacklist evbug
blacklist usbmouse
blacklist usbkbd
blacklist eepro100
blacklist de4x5
blacklist eth1394
blacklist snd_intel8x0m
blacklist snd_aw2
blacklist i2c_i801
blacklist prism54
blacklist bcm43xx
blacklist garmin_gps
blacklist asus_acpi
blacklist snd_pcsp
blacklist pcspkr
blacklist amd76x_edac

[/etc/modprobe.d/blacklist-rare-network.conf]
alias net-pf-3 off
alias net-pf-6 off
alias net-pf-9 off
alias net-pf-11 off
alias net-pf-12 off
alias net-pf-19 off
alias net-pf-21 off
alias net-pf-36 off

[/etc/modprobe.d/intel-microcode-blacklist.conf]
blacklist microcode

[/etc/modprobe.d/iwlwifi.conf]
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

[/etc/modprobe.d/mlx4.conf]
softdep mlx4_core post: mlx4_en

##### rc.local ##########################

exit 0

##### pm-utils ##########################

##### udev rules ########################

##### dmesg #############################

[   14.922878] Bluetooth: hci0: QCA: patch rome 0x300 build 0x3e8, firmware rome 0x300 build 0x111
[   15.096545] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
[   15.096564] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2
[   15.128464] ath10k_pci 0000:02:00.0: qca9377 hw1.0 target 0x05020000 chip_id 0x003820ff sub 17aa:4035
[   15.128468] ath10k_pci 0000:02:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0
[   15.128971] ath10k_pci 0000:02:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7
[   15.461918] ath10k_pci 0000:02:00.0: board_file api 2 bmi_id N/A crc32 93da0176
[   17.269549] ath10k_pci 0000:02:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1
[   17.275088] ath: EEPROM regdomain: 0x6c
[   17.275089] ath: EEPROM indicates we should expect a direct regpair map
[   17.275091] ath: Country alpha2 being used: 00
[   17.275091] ath: Regpair used: 0x6c
[   17.279281] ath10k_pci 0000:02:00.0 wlp2s0: renamed from wlan0
[   18.709172] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready (repeated 2 times)
[   20.701476] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[   20.919400] r8169 0000:01:00.0 enp1s0: link down (repeated 2 times)
[   20.919456] IPv6: ADDRCONF(NETDEV_UP): enp1s0: link is not ready
[   21.012127] IPv6: ADDRCONF(NETDEV_UP): wlp2s0: link is not ready
[   22.430330] r8169 0000:01:00.0 enp1s0: link up
[   22.430337] IPv6: ADDRCONF(NETDEV_CHANGE): enp1s0: link becomes ready
[  102.569365] ath10k_pci 0000:02:00.0: no channel configured; ignoring frame(s)! (repeated 20 times)

########## wireless info END ############

JeremyB
Level 17
Level 17
Posts: 7539
Joined: Fri Feb 21, 2014 8:17 am

Re: Cannot connect to wifi on new install

Postby JeremyB » Tue Sep 12, 2017 6:30 am

Looks like a power management issue

Code: Select all

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Reboot

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Wed Sep 13, 2017 2:48 am

Ok, pasted the command into the terminal. I was prompted for my password which I provided. If anything was updated or changed was difficult to tell as the command prompt reappeared.

That said, I rebooted and unfortunately still no wifi connection. Just to make sure I went through the process again with the same result.

Just so y'all know I do appreciate the help and sticking with me in working through this issue.

JeremyB
Level 17
Level 17
Posts: 7539
Joined: Fri Feb 21, 2014 8:17 am

Re: Cannot connect to wifi on new install

Postby JeremyB » Wed Sep 13, 2017 6:26 am

Post results for

Code: Select all

dpkg -l | grep linux-firmware

msmith
Level 1
Level 1
Posts: 10
Joined: Thu Sep 07, 2017 7:44 pm

Re: Cannot connect to wifi on new install

Postby msmith » Thu Sep 14, 2017 2:47 am

Code: Select all

mike@Lenovo-ideapad-110-15ISK ~ $ dpkg -l | grep linux-firmware
ii  linux-firmware                              1.157.12                                     all          Firmware for Linux kernel drivers

JeremyB
Level 17
Level 17
Posts: 7539
Joined: Fri Feb 21, 2014 8:17 am

Re: Cannot connect to wifi on new install

Postby JeremyB » Fri Sep 15, 2017 4:57 pm

Try this and reboot as there was an update to one of the firmware files

Code: Select all

cd /lib/firmware/ath10k/QCA9377/hw1.0

Code: Select all

sudo mv board-2.bin board-2.bin.bak

Code: Select all

sudo wget https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/plain/ath10k/QCA9377/hw1.0/board-2.bin

crandal
Level 1
Level 1
Posts: 1
Joined: Sat Sep 16, 2017 5:28 pm

Re: Cannot connect to wifi on new install

Postby crandal » Sun Sep 17, 2017 9:19 am

Don't know if this issue has been resolved but: same problem installing Mint 18.1 over Ubuntu on a new sys76 galago pro. Found this galago review article on updating the kernel - http://tomstechnicalblog.blogspot.com/2 ... eview.html. Then found the kernel update info at: http://linuxbsdos.com/2016/12/19/how-to ... -4-to-4-8/. Fixed my wireless problem - hope it helps, Charlie


Return to “Newbie Questions”