Wrong audio output at boot

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Charkel
Level 1
Level 1
Posts: 4
Joined: Mon Sep 18, 2017 11:13 am

Wrong audio output at boot

Postby Charkel » Tue Sep 19, 2017 12:26 pm

When I boot my computer the output is always "Built-In Audio" regarding of what output I used before rebooting. I am using a USB connected headset and I always have to switch it manually after boot.
THis really is a 'first world problem' but I would really love it if it would remember my last settings or always start on USB audio.

User avatar
administrollaattori
Level 12
Level 12
Posts: 4185
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Wrong audio output at boot

Postby administrollaattori » Tue Sep 19, 2017 1:25 pm

Install alsa-tools-gui

Code: Select all

apt install alsa-tools-gui

Code: Select all

hdajackretask

http://puolanka.info/goto/how-to-deacti ... es-output/

User avatar
Flemur
Level 12
Level 12
Posts: 4457
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Wrong audio output at boot

Postby Flemur » Tue Sep 19, 2017 1:48 pm

administrollaattori wrote:Install alsa-tools-gui

Could OP's problem be a pulseaudio issue?

I run an audio script at login that sets everything to "normal" - mostly so that if I've left it muted or turned way up for a quiet video or whatever, it'll be in some workable, non-blasting state.

The script mostly looks like:

Code: Select all

amixer set 'Master',0        25%  unmute
amixer set 'Headphone',0    100%  unmute
...

Here's how to change the output device with "amixer":
https://unix.stackexchange.com/question ... vice#88151

Disclaimer: I don't use pulseaudio, so "amixer" stuff not tested with it.
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?


Return to “Newbie Questions”

Who is online

Users browsing this forum: cecilieaux, fshsweden and 9 guests