[SOLVED] Getting an Asus usb ac53-nano wireless adapter to work

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

[SOLVED] Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 9:56 am

okay, so here we go.... used dell optiplex750, 3G processor, 4G ram, but no onboard wireless. I decided to try mint again, since I enjoyed it on ver.12 but since I live in the boonies, all I could try was gnomeppp for *gasp* dial-up! Needless to say, I had little success. At my age and level of knowledge, I basically need 2 things. pictures and videos for the wife and me, and internet. I had to backpedal to mint17 to get the codecs preinstalled. (remember...offline machine) 18.2 worked fine, but..... if we can't watch cartoons or movies while I figure out the wireless problem....well dang! :)

My question is this...I purchased an asus usb ac53-nano wireless adapter to try to get this machine online so I can get/use the few programs we need. I read some reviews and tutorials sites that recommended this dongle. plug and it works, they say. For me? not so much. It sure is hard to install anything without the darn thing being online, huh? btw, the mini-cd that came with the asus does NOT include any linux drivers, install files, etc. The next possibility involves my asking my son to pick up the dongle from BB and finding out it had been previously opened and the extension cable and cradle were missing.... I hate stores that do that, put opened returns back on the shelf. Knowing MY luck, the product WOULD work just fine, if I didn't have one that was returned after the house got hit by a lightning strike.... should I maybe try a tested and true PCI card? I have 2 slots open.
Last edited by Moem on Tue Oct 17, 2017 10:11 am, edited 1 time in total.

minitux
Level 5
Level 5
Posts: 860
Joined: Tue Sep 12, 2017 10:05 am

Re: .....and, they're off!

Post by minitux » Tue Oct 17, 2017 10:06 am

viewtopic.php?f=17&t=83314
4] Use Informative Titles
Use a title that is specific. Do not use titles such as, "HELP ME!!!" or "linuxmint fails". Instead, make titles that define the problem in a clear and concise manner such as, "Kernel Panic: Wifi Intel 3945AGN". A clear title will attract more views to the topic

User avatar
JerryF
Level 10
Level 10
Posts: 3069
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: .....and, they're off!

Post by JerryF » Tue Oct 17, 2017 10:10 am

I have a Belkin N300 Wireless USB Adapter (Model: F9L1002v1) that has never failed me---from Mint 17.1 to 18.2. It installs without being online.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: .....and, they're off!

Post by ImNotGivingUp » Tue Oct 17, 2017 10:18 am

good point, thank you. Perhaps some kind moderator could change the title to: asus usb ac53-nano wireless adapter question or something?
->Jerry Thanks, that too is another model ppl said would p&p. I plugged this in, and....*nothing* happens. I rebooted with the dongle inserted, and....*nothing* happens. Maybe I need to trade it for a pci card that Rebecca likes? lol I use my phone for a hotspot, so I'm not that concerned about signal strength, etc. I just need it to be online.

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 10:48 am

Many thanks to the moderator for changing the title.

Is anyone actually using one of these? If so, does it hurt when the obvious answer smacks you in the face?

User avatar
prestonR
Level 5
Level 5
Posts: 844
Joined: Wed Jan 07, 2015 12:24 pm
Location: Harare

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by prestonR » Tue Oct 17, 2017 10:52 am

I plugged this in, and....*nothing* happens. I rebooted with the dongle inserted, and....*nothing* happens
Might be a long shot and you're possibly aware of this already but usb ports often share a common power supply. That means that if an individual device uses a lot, and wifi adapters do, while eg there is a wireless mouse or an external drive plugged into another port it may cause one of the devices to malfunction. To check unplug all other usb devices apart from the wifi adapter.

JeremyB
Level 19
Level 19
Posts: 9182
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by JeremyB » Tue Oct 17, 2017 10:53 am

Open terminal and enter

Code: Select all

lsusb
Post results

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 11:05 am

did not know about the usb voltage problem. moved keys and mouse to the front 2 ports, plugged in usb on back ports....nothing. leave it there and reboot perhaps? or is it dead?

-> Jeremy, thanks. when I do that I get command not found or syntax error. not sure what to type EXACTLY, evidently. lol

Hoser Rob
Level 12
Level 12
Posts: 4218
Joined: Sat Dec 15, 2012 8:57 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by Hoser Rob » Tue Oct 17, 2017 11:23 am

ImNotGivingUp wrote:.... I read some reviews and tutorials sites that recommended this dongle. plug and it works, they say. For me? not so much. ....
Which reviews? There's a lot of info on the web that's out of date.

There's very little backwards compatibility in Linux. Solutions for older point releases (or newer) aren't reliable so you need to be sure that what you do is for yours. For Mint 18.x it's ubuntu 16.04, for mint 17.x it's ubuntu 14.04.

Much info/blogs/tutorials are crap as well. easylinuxtipsproject by one of the more common posters here is good. I've actually got the vast majority of my support info from askubuntu.com and ubuntuforums.org. Askubuntu is user ranked which makes it possibly the most useful.

If you read something that doesn't say which release it's for that's a good reason to avoid that site in the future IMO.

User avatar
JerryF
Level 10
Level 10
Posts: 3069
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by JerryF » Tue Oct 17, 2017 11:30 am

ImNotGivingUp wrote:did not know about the usb voltage problem. moved keys and mouse to the front 2 ports, plugged in usb on back ports....nothing. leave it there and reboot perhaps? or is it dead?

-> Jeremy, thanks. when I do that I get command not found or syntax error. not sure what to type EXACTLY, evidently. lol
Copy the command and paste it into Terminal.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 11:48 am

Kinda confused... I'm not on that machine. This is a windows machine next to the mint I want to use. Copy/paste may not work.

User avatar
JerryF
Level 10
Level 10
Posts: 3069
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by JerryF » Tue Oct 17, 2017 11:54 am

ImNotGivingUp wrote:Kinda confused... I'm not on that machine. This is a windows machine next to the mint I want to use. Copy/paste may not work.
I thought you might have been on the Mint machine.

The command is LSUSB but in small letters. Try again in Terminal.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 12:05 pm

*sigh* I hate being a newbie again. I haven't typed this much since DOS...lol Okay, that worked, and the ASUS seems to be seen, bus 002, device 004. eight empty, 2 with the mouse and keys. this is good, yes? Now... how do I turn the darn thing ON!? :)

User avatar
JerryF
Level 10
Level 10
Posts: 3069
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by JerryF » Tue Oct 17, 2017 12:18 pm

Wait for JeremyB's response because he's the one who asked for the command to be run and he's excellent at wireless problems.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 12:29 pm

Darn glasses. Sorry Jerry, I guess I just saw the J and thought it was the same person. but hey, any and all help is always appreciated! :) I'm guessing the good news is the machine SEES it, so it's not "dead". *yay!*

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 2:19 pm

Hmm, perhaps he got called away? Anyone else know how to turn it on?

JeremyB
Level 19
Level 19
Posts: 9182
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by JeremyB » Tue Oct 17, 2017 4:45 pm

Post results from terminal for LSUSB in small letters, I imagine you entered 1susb rather than lsusb and got the command not found

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 4:59 pm

Bus 002 device 004: ID 0b05:184c ASUStek computer Inc.

JeremyB
Level 19
Level 19
Posts: 9182
Joined: Fri Feb 21, 2014 8:17 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by JeremyB » Tue Oct 17, 2017 5:09 pm

Download https://github.com/jeremyb31/rtl8822bu/ ... master.zip and copy it to the Linux Mint desktop. Then right click the file and choose extract here
Then in terminal

Code: Select all

cd Desktop/rtl8822bu-master

Code: Select all

make

Code: Select all

sudo make install
Reboot

ImNotGivingUp
Level 1
Level 1
Posts: 37
Joined: Tue Oct 17, 2017 7:23 am

Re: Getting an Asus usb ac53-nano wireless adapter to work

Post by ImNotGivingUp » Tue Oct 17, 2017 5:53 pm

Do I type ALL this in?

Code: Select all
cd Desktop/rtl8822bu-master

or just
cd Desktop/rtl8822bu-master

No such file or directory is response. Or bash: syntax error near unexpected token 'cd'

I don't think it likes me.

Post Reply

Return to “Newbie Questions”