Cannot watch Netflix

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
wallaroo
Level 3
Level 3
Posts: 122
Joined: Thu Feb 09, 2012 3:42 am

Re: Cannot watch Netflix

Post by wallaroo » Tue Oct 31, 2017 1:03 am

Ever since Firefox announced that they now support Netflix I have been trying to get it to work - unsuccessfully.
I do have Firefox screwed down fairly tightly with Firejail, NoScript, Adblocking and so on, so I was not surprised it didn't work right away. But I tried all the usual, like ensuring DRM was on, disabled add-ons and run it outside Firejail with no luck.

However, I finally got it working (in Mint) using Firefox 'profiles' without compromising my more secure browser.

I created a new profile and called it 'Netflix'. In this profile I left everything as default (except sending data back to Mozilla) and added no 'add-ons', so when I run with this profile I am running a 'pristine' instance of Firefox. I set the home page as Netflix and only use this to access Netflix - nothing else.

I also created separate menu launchers so I can easily use my 'secure' browser instance for general access and the more 'open' browser instance for Netflix.
The default profile is launched as 'firejail firefox -P "default"'
The Netflix profile is launched as just 'firefox -P "Netflix"'.

To create a new profile just run 'about:profiles' in the browser and click on 'Create a New Profile'

Worth a try!

User avatar
sig
Level 1
Level 1
Posts: 10
Joined: Wed Dec 13, 2017 1:24 pm

Re: Cannot watch Netflix

Post by sig » Mon Dec 25, 2017 12:22 am

run google-chrome, much better browser and it supports Mint fine.

Post Reply

Return to “Newbie Questions”