Page 1 of 1

Re-install having partition trouble

Posted: Wed Nov 22, 2017 7:33 pm
by white stone
Hello,
Have a 500 Gig Hard Drive. I messed up my installation of Mint 17 and thought it would be simple to just reinstall. I decided to go ahead and upgrade to 18.2. It has been about 4 years since I installed 17 and my brain seems to have formatted over my ability to do this. The problem is I want at least 4 partitions. Boot, Home, Fat32 and a Storage partition for misc. files (some for Windows in case I ever want to go there again). I can get Boot and Home but the other two do not display in file manager. I can see the Fat32 in Gparted but I can not access it in File Manager. I have run installation 3-4's today and tried different settings in the 'something else' install section with no success. Any idea what I may be omitting or doing wrong?

Thanks,

Re: Re-install having partition trouble

Posted: Wed Nov 22, 2017 8:33 pm
by WharfRat
Sounds like a very strange problem.

From the live session can you paste back sudo blkid and sudo gdisk -l /dev/sda|egrep 'MBR|GPT'

Re: Re-install having partition trouble

Posted: Fri Nov 24, 2017 12:42 pm
by white stone
WharfRat

Sorry, I finally understood what you posted. I will try to get the info asap.

Thanks,

Re: Re-install having partition trouble

Posted: Fri Nov 24, 2017 1:51 pm
by white stone

Code: Select all

mint@mint ~ $ sudo blkid
/dev/sda1: UUID="e1a17fde-f71f-4776-b425-aecb1366c50a" TYPE="ext4" PARTUUID="00079a7b-01"
/dev/sda5: UUID="4dd502c6-0cb8-4148-b220-67b33613f8f3" TYPE="ext4" PARTUUID="00079a7b-05"
/dev/sda6: UUID="DEB4-0C8A" TYPE="vfat" PARTUUID="00079a7b-06"
/dev/sda7: UUID="DEC8-253C" TYPE="vfat" PARTUUID="00079a7b-07"
/dev/sda8: UUID="8d4e8044-6ab8-4284-9a9d-955242e70e0d" TYPE="ext4" PARTUUID="00079a7b-08"
/dev/sr0: UUID="2017-06-28-12-31-06-00" LABEL="Linux Mint 18.2 MATE 64-bit" TYPE="iso9660" PTUUID="550714ba" PTTYPE="dos"
/dev/loop0: TYPE="squashfs"
/dev/sda9: UUID="5fc8fd38-c045-4d42-bdaf-253a018cecc1" TYPE="swap" PARTUUID="00079a7b-09"
mint@mint ~ $ 

sudo gdisk -l /dev/sda|egrep 'MBR|GPT'

sudo gdisk -l /dev/sda|egrep 'MBR|GPT'

Hope this is what you wanted. j

Re: Re-install having partition trouble

Posted: Fri Nov 24, 2017 2:53 pm
by WharfRat
Well I see three linux partitions sda1,5,and 8. They're not labeled so I can't identify them.

The sudo gdisk -l /dev/sda|egrep 'MBR|GPT' should have returned something like

Code: Select all

bill@XPS] ~ $ sudo gdisk -l /dev/sda|egrep 'MBR|GPT'
GPT fdisk (gdisk) version 1.0.1
  MBR: protective
  GPT: present
Found valid GPT with protective MBR; using GPT.
[bill@XPS] ~ $ 
but since you have a gap between sda1 and sda5 I'm guessing that you have an MBR partition.

If you're mint system is booting and running enter mount|grep sda to see what partitions are mounted where.

Also provide a gparted screenshot.

Re: Re-install having partition trouble

Posted: Fri Nov 24, 2017 11:33 pm
by white stone
WarfRat,
but since you have a gap between sda1 and sda5 I'm guessing that you have an MBR partition.

If you're mint system is booting and running enter mount|grep sda to see what partitions are mounted where.

Also provide a gparted screenshot.
Since I posed that data I reloaded the PC. Running Mint 18.2 now.

sudo blkid
__________
/dev/sda1: LABEL="Boot" UUID="2ca9267e-4774-468f-bb6e-0d20edc003d5" TYPE="ext4" PARTUUID="00079a7b-01"
/dev/sda5: LABEL="Home" UUID="4ef7f34c-ded2-476f-a925-781cc54c45c6" TYPE="ext4" PARTUUID="00079a7b-05"
/dev/sda6: LABEL="FAT32" UUID="00A8-D777" TYPE="vfat" PARTUUID="00079a7b-06"
/dev/sda7: LABEL="Storage" UUID="109241FE4A927BFF" TYPE="ntfs" PARTUUID="00079a7b-07"
/dev/sda8: LABEL="Linux-storage" UUID="9e28e1b8-4f73-4abb-b3c5-3d394cce5f34" TYPE="ext4" PARTUUID="00079a7b-08"
/dev/sda9: UUID="4c0b3bca-eab0-43a0-a405-afdc8e3b510e" TYPE="swap" PARTUUID="00079a7b-09"
/dev/sdb1: LABEL="DYLAN" UUID="F2DD-C907" TYPE="vfat" PARTUUID="529f704f-01"
/dev/sdb2: UUID="AA1ED6A51ED66A39" TYPE="ntfs" PARTUUID="529f704f-02"
the sbd 1&2 are on an external hard drive that I forgot to remove.
sudo gdisk -l /dev/sda|egrep 'MBR|GPT'
__________
GPT fdisk (gdisk) version 1.0.1
Usage: gdisk [-l] device_file
janice@wifes-HP-xw ~ $

When I installed, I typed this new name in at least 4 times. It kept refusing to accept it. Gave me a description saying No Hyphens allowed. So I typed wifes_HP-xw and it accepted that. Go figure!!


I will go make an image of the drive, be right back.
Image

Here it is, thanks in advance for any comment/advice.

Re: Re-install having partition trouble

Posted: Fri Nov 24, 2017 11:59 pm
by WharfRat
white stone wrote: I will go make an image of the drive, be right back.
[img]403500[/img]

Here it is, thanks in advance for any comment/advice.
Whatever you did with the image is not any help :?

But, from the new partition UUID's, it appears that you have 18.2 installed.

Is there still some sort of problem :?:

Re: Re-install having partition trouble

Posted: Sat Nov 25, 2017 12:20 am
by white stone
WharfRat wrote: Whatever you did with the image is not any help :?

But, from the new partition UUID's, it appears that you have 18.2 installed.

Is there still some sort of problem :?:
Using a FREE Photobucket account. Had to allow ads to run and it took forever to get the file loaded, then I had to resize it and go through the loading all over. Then it would refresh the image but not the name in the link. I just ended up taking a chance and putting the new name in place of what they showed. Seems to have worked.

Only problem is that my FAT32 folder does not display in the Mint Desktop file manager. Clicking on Accessories/Disks is not bringing up my drive information. I think I am too tired to mess with this any longer. Let me live with it this way for a little while and see if I figure it out.

Thank you, very much for trying.
Janice

Re: Re-install having partition trouble

Posted: Sat Nov 25, 2017 12:31 am
by WharfRat
Try mounting the partition to /mnt with sudo mount -v -t vfat /dev/sda6 /mnt then check ls /mnt for your files.

And just an FYI you do have the old msdos partitioning scheme as per the extended /dev/sda2 partition.

SOLVED - Re-install having partition trouble

Posted: Sat Nov 25, 2017 2:29 pm
by white stone
Good news to relay this morning, I closed down with my FAT32 partition not displaying in the Mint File Manager. This morning it is there and the HTML files work just as I am accustomed to having them work. I could not be much happier. Perhaps things just needed to 'sit and cure' overnight.

Very glad to post this thread as SOLVED.

Hats off to all who contributed to this thread,
Janice