Fresh Install of Mint Cinnamon 18.3 on laptop no wifi [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
jland504
Level 1
Level 1
Posts: 6
Joined: Tue Dec 19, 2017 4:21 pm
Location: New Orleans, LA

Fresh Install of Mint Cinnamon 18.3 on laptop no wifi [SOLVED]

Post by jland504 » Fri Dec 22, 2017 5:30 pm

I just installed a fresh copy of Linux Mint 18.3 Cinnamon to my HP-2000 laptop. It has a realtec rtl8188ee wireless card onboard. my current only way to connect to the internet is through the ethernet cable. I know i have had this issue in the past with another similar laptop and i cannot remember what the fix was. Could someone direct me to the correct path of resolving this issue?

Code: Select all

System:    Host: jland-HP Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Hewlett-Packard (portable) product: HP 2000 Notebook PC v: 097A130002405E00000620100
           Mobo: Hewlett-Packard model: 2128 v: KBC Version 11.13
           Bios: Insyde v: F.44 date: 12/23/2013
CPU:       Quad core AMD A6-5200 APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 15970
           clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1600 MHz 3: 800 MHz
           4: 800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Kabini [Radeon HD 8400 / R3 Series]
           bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.07hz
           GLX Renderer: Gallium 0.4 on AMD KABINI (DRM 2.49.0 / 4.10.0-38-generic, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 01:00.0
           IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8188EE Wireless Network Adapter
           driver: rtl8188ee port: 2000 bus-ID: 05:00.0
           IF: wlo1 state: down mac: <filter>
Drives:    HDD Total Size: 275.1GB (5.1% used)
           ID-1: /dev/sda model: Crucial_CT275MX3 size: 275.1GB
Partition: ID-1: / size: 245G used: 6.0G (3%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 8.02GB used: 0.00GB (0%) fs: swap dev: /dev/sda3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 56.0C mobo: N/A gpu: 60.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 186 Uptime: 54 min Memory: 1333.7/7448.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35
Last edited by jland504 on Sat Dec 30, 2017 11:28 pm, edited 2 times in total.
Image

jwrober
Level 1
Level 1
Posts: 16
Joined: Thu Dec 21, 2017 12:17 pm

Re: Fresh Install of Mint Cinnamon 18.3 on laptop no wifi

Post by jwrober » Fri Dec 22, 2017 6:10 pm

You are more than likely to be missing firmware for the device. Run

dmesg | grep Wire

and see if there are messages in the boot up and systemd log to help you figure out what is missing. On my computer it looks like this

Code: Select all

$ dmesg | grep Wire
[   16.851921] input: HP Wireless hotkeys as /devices/virtual/input/input7
[   17.487529] Intel(R) Wireless WiFi driver for Linux
[   17.730372] iwlwifi 0000:05:00.0: Detected Intel(R) Dual Band Wireless AC 3168, REV=0x220
and shows a good loaded card. You will notice something missing.

puddleglum
Level 1
Level 1
Posts: 37
Joined: Fri Dec 22, 2017 12:03 pm

Re: Fresh Install of Mint Cinnamon 18.3 on laptop no wifi

Post by puddleglum » Fri Dec 22, 2017 6:20 pm

Looks like you do have the rtl8188ee driver installed. I'm wondering if you're having the problem described in this Ubuntu thread:
https://askubuntu.com/questions/763508/ ... -in-xenial

Anyway, from the answer there it looks like there is a better 3rd party driver available at GitHub.

User avatar
jland504
Level 1
Level 1
Posts: 6
Joined: Tue Dec 19, 2017 4:21 pm
Location: New Orleans, LA

Re: Fresh Install of Mint Cinnamon 18.3 on laptop no wifi

Post by jland504 » Fri Dec 22, 2017 6:52 pm

Thanks puddleglum that worked perfectly.
Image

Post Reply

Return to “Newbie Questions”