Page 6 of 11

Re: How to update your kernel for Meltdown

Posted: Thu Jan 18, 2018 2:01 pm
by michael louwe
@ ravenise, .......
ravenise wrote:...
.
You uninstall an unwanted kernel by going to >Update Manager >View >Linux kernels >Remove.

With Synaptic Package Manager, you may be mistakenly uninstalling both the 3.13 kernels. Hence, LM prompting you that it will auto-install kernel 4.4.

Re: How to update your kernel for Meltdown

Posted: Thu Jan 18, 2018 3:52 pm
by pjc123
Did anyone get a kernel panic at shutdown after applying the new Intel microcode? I can't say absolutely that is the cause because I applied several updates today. I already applied the new meltdown kernel fix a few days ago.

intel-microcode (3.20170707.1~ubuntu16.04.0) to 3.20180108.0~ubuntu16.04.2

It only happened once, but it has me a bit worried. I do have an image backup in case, however. This is on a Lenovo T470.

Re: How to update your kernel for Meltdown

Posted: Thu Jan 18, 2018 3:58 pm
by thx-1138
Did anyone get a kernel panic at shutdown after applying the new Intel microcode? I can't say absolutely that is the cause because I applied several updates today.
Define 'after applying'. Microcode doesn't get loaded unless a re-boot has taken place. Simply installing it can't cause kernel panics, loading it only.

Re: How to update your kernel for Meltdown

Posted: Thu Jan 18, 2018 4:24 pm
by pjc123
thx-1138 wrote:
Did anyone get a kernel panic at shutdown after applying the new Intel microcode? I can't say absolutely that is the cause because I applied several updates today.
Define 'after applying'. Microcode doesn't get loaded unless a re-boot has taken place. Simply installing it can't cause kernel panics, loading it only.
Yes, that is what happened.

1) I updated the microcode.
2) I then shut down (worked OK, like you said, because the microcode wasn't applied yet).
3) I then restarted, but this time when shutting down I got the kernel panic.

These were the last few log messages (yes, with the @ signs as well):

Code: Select all

Jan 18 13:09:04 pjcT470Mint cinnamon-session[2639]: WARNING: t+172.55775s: Playing logout sound '/usr/share/mint-artwork-cinnamon/sounds/logout.ogg'
Jan 18 13:09:04 pjcT470Mint cinnamon-session[2639]: WARNING: t+172.67168s: Finished playing logout sound
Jan 18 13:09:04 pjcT470Mint cinnamon-session[2639]: WARNING: t+172.67183s: Resuming logout sequence...
Jan 18 13:09:05 pjcT470Mint cinnamon-session[2639]: GLib-GIO-CRITICAL: t+173.61876s: g_dbus_connection_call_sync_internal: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
Jan 18 13:09:05 pjcT470Mint cinnamon-session[2639]: WARNING: t+173.61947s: Requesting system shutdown...
Jan 18 13:09:05 pjcT470Mint cinnamon-session[2639]: WARNING: t+173.61967s: Attempting to shutdown using systemd...
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@

Re: How to update your kernel for Meltdown

Posted: Thu Jan 18, 2018 4:27 pm
by thx-1138
Disable it on Device Manager, reboot twice. The 2nd reboot (where it will be unloaded), will reveal if that was the culprit or the rest of updates...

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 7:37 am
by ZakGordon
With all the various threads about confusion over upgrading the kernal, i'm kind of surprised this thread has not be 'stickied', if only for a few months while people get to grips with migrating their systems?

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 8:39 am
by xenopeek
I've unstickied it as it's been 2 weeks and everybody has gotten the kernel update in Update Manager.

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 9:26 am
by brancalessio
I just want to report some issues about the kernel update.

My laptop: Intel Core i5, Intel Corporation 3rd Gen Core processor Graphics Controller, Linux Mint 17.2 Rafaela 64bit.

With the suggested kernel 3.13.0-139-generic everything seems working fine, but I cannot change the screen brightness.

With the suggested kernel 4.4.0-109-generic everything seems working fine, it is also possible to change the screen brightness, but, even though the tty terminals work after boot, after some time they stop working. That is to say, you press CTRL+ALT+F<1,2,3,4,5,6> and you just get the usual greeting

Code: Select all

Linux Mint 17.2 Rafaela <hostname> tty1
<hostname> login:
but, if you type, nothing happens. Notice that there is always written tty1 (even when CTRL+ALT+F2 was pressed).

I will try to fix it, even though I understand there may be further changes and maybe this is not still worth doing. In case you know some solution, please reply to this post.

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 9:28 am
by Pjotr
@brancalessio: there's a new kernel update available. What does 4.4.0-112 do for you?

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 9:54 am
by brancalessio
Pjotr wrote:@brancalessio: there's a new kernel update available. What does 4.4.0-112 do for you?
Is this kernel patched against Meltdown and Spectre?

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 1:41 pm
by Sir Charles
brancalessio wrote: Is this kernel patched against Meltdown and Spectre?
Just for Meltdown as far as I know.

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 2:41 pm
by Termy
According to this website, if you have 4.4.0-110 then you're patched for both, so I assume anything later will still contain that patch, otherwise I wouldn't see much point in an update. lol I dunno who's patch the site is referring to, though. I assume the patch numbers will be different depending on who's patched it.

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 3:16 pm
by Sir Charles
Termy wrote:According to this website, if you have 4.4.0-110 then you're patched for both
That's good to know! I thought that all the kernel patches so far were addressing Meltdown only. Thanks Termy :)

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 3:24 pm
by Termy
No problem. :) I also follow RSS feeds for security for Ubuntu and Mint; if I'm understanding the feeds correctly, upgrades have been made available for the 4.4, 4.8, and 4.13 kernel versions, Firefox, and the Intel microcode packages to combat Spectre and Meltdown. A news feed popped up recently (I think today) for Ubuntu, titled "USN-3540-1: Linux kernel vulnerabilities", which seems to indicate that more "security issues" have been patched, or "addressed", in the new -112 patch for the 4.4 kernel version. Which explains a lot, because I recently went up to that version in my Ubuntu system, however, Linux Mint, at least the last I checked, hadn't yet got this upgrade available; should be soon, though.

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 3:44 pm
by buffest_overflow
I just installed Xfce from an 18.2 DVD installer on sdb, went right from the fresh install to "update to 18.3" in Update Manager, it worked just fine. Very smooth, very nice. Still using MATE though. We'll see who wins in the end!

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 5:20 pm
by dave8671
So confusing I am on my t520 with a sandy bridge CPU. I do not really understand kernel to use my update manager has

4.13.0-31.34-1604.1
and
4.40-112.135


0_o why are there two? I am going to install them. I read to use timeshift before changing kernels never used it.

If the kernel does not boot how would I fix it? Which kernel is for this hardware right now I am using the 4.10 would it be 413.x

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 5:39 pm
by Termy
A kernel is the middle-man between your software and your hardware, put simpy.

4.4 is a version of the Linux kernel (what "Linux" actually is; the kernel), where the first 4 is the major release version number, and the 2nd 4 is the minor release, I believe. There's surely more to it, but I'm not all that well versed in version schemes.

There's a patch number, as well. Typically, the big distros (Debian, Arch, Ubuntu, etc) will patch the kernel, to keep it up to date as far as security goes, and likely also patching any stability and performance issues. However, the 4.4, for example, indicates that the drivers -- modules allowing your hardware to function -- or versions thereof, within the kernel, were upgraded over versions lower than 4.4, such as, for example, 3.8, or 2.4.

Typically, the newer (bigger the number) the major/minor release version of a kernel, the newer the hardware it'll support, which is an important factor to keep in mind when choosing a kernel version to install and run. Sometimes newer kernels drop support for certain hardware, leaving some people to need an older kernel to continue running their toaster, thus those too are maintained (patched).
dave8671 wrote:If the kernel does not boot how would I fix it? Which kernel is for this hardware right now I am using the 4.10 would it be 413.x
If, after loading up a different kernel, the system doesn't boot or operate correctly, your best bet is to reboot the machine, spam the Shift key (or Esc as some have reported) to get to the GRUB menu, then, when there, select the menu option begginning with "Advanced options for", then select the kernel you were using before, when things worked. Once that's done, you should be booting into your machine like normal, then just remove the kernel which didn't work for you.

I have no idea which kernel is for your hardware -- I don't even know what your hardware is. :?

Re: How to update your kernel for Meltdown

Posted: Tue Jan 23, 2018 7:58 pm
by gld59
With a Sandy Bridge processor, you could probably use either 4.4 or 4.13.

Even 4.4 is recent enough that it should support your hardware - certainly any built-in components. 4.13 is the current HWE series kernel, which may introduce support for newer hardware. (The HWE series for each Mint release is a rolling thing - for Mint 18.x it will move in a few months from 4.13 to 4.15, and then stay there. 4.15, the final HWE series for Mint 18.x, will also be the LTS series for Mint 19.)

During this current scramble to get Meltdown & Spectre mitigations released, quality control is a lower priority, and it is likely that more people than usual will have problems with new kernels. The (relatively) bleeding-edge nature of HWE kernels makes them slightly more prone to this happening. If 4.13 doesn't work for you, try 4.4 instead.

Re: How to update your kernel for Meltdown

Posted: Wed Jan 24, 2018 12:47 pm
by rodneyck
If you are running Cinnamon, then I suggest you do NOT delete your old/previous linux kernel versions as the OP suggests at the start of this thread. Every 4.13 kernel I have tried, including the latest in the update manager, has caused Cinnamon to crash upon startup (and Cinnamon will not restart with a command.) I am not the only one experiencing this issue, there are countless posts and I believe a number of bug reports.

4.10 kernels for newer systems seem to work fine and are stable, but do not have the meltdown patch as of this writing.

The 4.4.0-112 as mentioned above does have the meltdown patch, but may not be suitable for newer systems.

I am not sure why Linux Mint devs decided it was a good idea to release the 4.13 update without thoroughly testing it on all their versions for major bugs. Clearly, someone dropped the ball.

Re: How to update your kernel for Meltdown

Posted: Wed Jan 24, 2018 1:00 pm
by Termy
Clearly, someone dropped the ball.
I doubt that. Remember, people are in a mad rush to get Meltdown and Spectre patched up as quickly as possible for our safety online.