Firefox and Waterfox Chokes Mint

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
wwfwng
Level 2
Level 2
Posts: 76
Joined: Tue Jul 24, 2012 9:19 pm

Firefox and Waterfox Chokes Mint

Post by wwfwng » Mon Jan 15, 2018 3:27 pm

Both Firefox and Waterfox seem to slow down Mint at times. This happens with both Mint 17 and Mint 18. I also suspect that certain web pages are more prone to do it than others (although I am not sure on this point). I am not always actively using the browser when it happens. I can be working on something unrelated to the browser and then I hear (what I assume is my hard drive ?) my computer working louder. At this point, my computer slows to a crawl. I usually restart. Something that has helped but not completely solved the problem is installing the "stop all button" addon and then stopping all tabs when I'm not actively using the browser. Any ideas? TIA

Chemical_Ali
Level 2
Level 2
Posts: 51
Joined: Wed Jun 05, 2013 9:27 am

Re: Firefox and Waterfox Chokes Mint

Post by Chemical_Ali » Tue Jan 16, 2018 12:44 am

I have this problem whenever Firefox and Waterfox are running for a few hours. Websites usually load fine. But, it crawls when using the scrollbar/mouse wheel. It is also very slow to type text in webpages as well the address bar; it usually lags for a couple of seconds. It appears to be a common problem. I don't know if this issue exist for Firefox Quantum though.

You could try Palemoon. I never had any slowdown issues with Palemoon.

User avatar
ArtGirl
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

Re: Firefox and Waterfox Chokes Mint

Post by ArtGirl » Tue Jan 16, 2018 1:37 am

Can I ask if you're on Waterfox 56.0.3? I'm lucky to have quite a high spec machine, and am not having any slow down, but there were issues with 56.0.2 (patched for meltdown/spectre) and I needed to clean out the install and do a clean 56.0.3, but this time via the ppa. That works a treat (fast, LM integration's fine, able to set browser easily within Waterfox). I believe 56.0.3 is tweaked to minimise any slowdowns 56.0.2 gained through the patching.

PPA ... nb just copy/paste per line

Code: Select all

echo 'deb https://dl.bintray.com/hawkeye116477/waterfox-deb release main' | sudo tee /etc/apt/sources.list.d/waterfox.list

curl https://bintray.com/user/downloadSubjectPublicKey?username=hawkeye116477 | sudo apt-key add -

sudo apt-get update
sudo apt-get install waterfox
ABOUT:CONFIG TWEAKS ...

On the reddit page, I had learnt some tweaks for 56.0.2 that may be relevant still for 56.0.3 ... I see if those lines are there and, if so, make sure the settings are as below ... Im not tech enough to get into the exact changelogs etc, but just had seen someone posting these tweaks for 56.0.2, and they worked very well.

To make sure multi-process is on [nb search e10s in the top bar turns out to be an easier way to find particularly the first one needing to be false]
... about:config
... extensions.e10sBlockedByAddon =false
... extensions.e10sMultiBlockedByAddons = false, too
Right click on bar in 'about:config' ... new ... boolean ... browser.tabs.remote.force-enable (set to true) [MrAlex94 had advised it's safe regarding 56.0.2] ... force enables e10s.

I'd recommend the reddit page ... https://www.reddit.com/r/waterfox/new/ ... if these tweaks don't help.
Last edited by Moem on Tue Jan 16, 2018 4:06 am, edited 1 time in total.
Reason: [code] tags are for code :-)
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150


For any advice I've been able to add, eg re graphics tablets, please search forum.

Image

wwfwng
Level 2
Level 2
Posts: 76
Joined: Tue Jul 24, 2012 9:19 pm

Re: Firefox and Waterfox Chokes Mint

Post by wwfwng » Tue Jan 16, 2018 10:19 am

Thanks everyone.

I'm running Waterfox 56.0.2 at the moment. But I have had the same issue with several versions of Firefox for a while.

I also use Palemoon but not exclusively.

User avatar
ArtGirl
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

Re: Firefox and Waterfox Chokes Mint

Post by ArtGirl » Tue Jan 16, 2018 10:24 am

Thanks for editing the post, Moem. :)
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150


For any advice I've been able to add, eg re graphics tablets, please search forum.

Image

SBurr
Level 1
Level 1
Posts: 26
Joined: Sat Jan 04, 2014 2:01 pm

Re: Firefox and Waterfox Chokes Mint

Post by SBurr » Wed Jan 17, 2018 4:42 am

I have found that pages which are running javascript files will slow any browser down. The Firefox NoScript is a partial solution to that.

User avatar
BG405
Level 6
Level 6
Posts: 1068
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Firefox and Waterfox Chokes Mint

Post by BG405 » Tue Jan 23, 2018 1:47 pm

The command free -m will show if you are running short on RAM. You can check how much memory the browser is hogging using top - "htop" is better but you'll need to install it if you haven't already.

The biggest culprit in my experience is YouTube. Facebook is also a resource hog but I rarely go on that site these days.
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - LM17.3 KDE 32
Toshiba NB305 - LM17.3 Xfce 32---------------------K7S5A Athlon 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

User avatar
Flemur
Level 15
Level 15
Posts: 5507
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Firefox and Waterfox Chokes Mint

Post by Flemur » Tue Jan 23, 2018 2:45 pm

BG405 wrote:The command free -m will show if you are running short on RAM. You can check how much memory the browser is hogging using top - "htop" is better but you'll need to install it if you haven't already.
Good ideas. To keep it updating, do:

Code: Select all

watch free -m 
I had FF 56 and lower versions often "choke" the system by using too much CPU on some script - sometimes it'd come up with "do you want to stop the crazy script?" but often not. Haven't had that happen so far with ff 57 - but I have different addons, too.

Try running FF (etc) w/o addons and see if it still chokes.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
BG405
Level 6
Level 6
Posts: 1068
Joined: Fri Mar 11, 2016 3:09 pm
Location: England

Re: Firefox and Waterfox Chokes Mint

Post by BG405 » Tue Jan 23, 2018 4:32 pm

Flemur wrote:I had FF 56 and lower versions often "choke" the system by using too much CPU on some script - sometimes it'd come up with "do you want to stop the crazy script?" but often not.
Mine always seems to.

NoScript seems to help but I've read that there are better alternatives. Bain of browsing life. try to close the browser and OFTEN get delayed by "unresponsive script" messages. In my case it doesn't seem to hog the CPU; usual cause of freezing is memory hogging. Mind I currently only have 3GB RAM and 4GB swap on the most affectred system. My netbook with 2GB RAM copes OK with a more restricted footprint (about half the number of tabs) and behaves much better with YouTube etc..
Dell Inspiron 1525 - LM17.3 CE 64-------------------Acer D255E 2GB - LM17.3 KDE 32
Toshiba NB305 - LM17.3 Xfce 32---------------------K7S5A Athlon 1.2GHz - LM17.3 Xfce 32 & WinXP-Pro
Acer Aspire E11 ES1-111M - LM18.2 KDE 64 ----Dell PII 350 64MB - Puppy 4.3 & Win98-SE

Post Reply

Return to “Newbie Questions”