Trying to update kernel on LM 17.3 get warning it can't be authenticated

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Mon Jan 15, 2018 4:10 pm

I'm on LM 17.3 and currently on kernel 3.19.0-32.
before i try to install 4.4.0-109 I get warning that it's not authenticated and to confirm that I want to do this. Is this normal?

edit:
I've seen this just now on other thread: "Kernel 4.13 breaks the long outdated VB version 5.0.x. This is known and documented. VB 5.1.x and 5.2.x work,"

I'm in trouble then, cos I use VB 5.0.16 for a long time cos when I tried newer version I had some problems with it.

Is there a 3.x kernel version for my LM 17.3 that is patched for latest intel bugs that I could/should use?

Cosmo.
Level 22
Level 22
Posts: 16662
Joined: Sat Dec 06, 2014 7:34 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Cosmo. » Mon Jan 15, 2018 4:57 pm

kitaubila wrote:I'm in trouble then, cos I use VB 5.0.16 for a long time cos when I tried newer version I had some problems with it.
Which problems?
kitaubila wrote:Is there a 3.x kernel version for my LM 17.3 that is patched for latest intel bugs that I could/should use?
You can try the latest variant of kernel 3.13. This will get support as long as LM 17.3 is supported.
If you install kernel 3.13.x you have to select this kernel at least at the first time in the grub menu manually, as Linux chooses always the highest kernel (3.19.x > 3.13.x, regardless of x and the time it got released). If this works for you you can remove 3.19 to make Linux use 3.13 by default.

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Mon Jan 15, 2018 6:17 pm

what about this warning. is that normal because I don't remember seeing that before. might forgot :( .
aaaaaaa.jpg

User avatar
Termy
Level 5
Level 5
Posts: 637
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Termy » Mon Jan 15, 2018 10:25 pm

Can't be authenticated? 'o.O That's suitably vague. I wonder if that could be a GPG issue.

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Tue Jan 16, 2018 4:19 am

could this be connected or depend on the source I'm taking update list/packages. because I just pick the fastest one.

User avatar
catweazel
Level 12
Level 12
Posts: 4179
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by catweazel » Tue Jan 16, 2018 4:30 am

kitaubila wrote:could this be connected or depend on the source I'm taking update list/packages. because I just pick the fastest one.
In a word, yes. Select the next fastest and refresh, then try again.
There is no spoon.

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Tue Jan 16, 2018 5:14 am

I checked. That was the reason and now I'm worried cos I was connected to that serves for a long time. It was sweden.
Now picked 2 servers in Holland and no warning.

Is it possible something "bad" was slipped in my system using those "unsafe" servers :( ? Are they really unsafe, I mean is that possible?

installed kernel 4.4.0-109 and got error on boot :-(. doesn't work for me. maybe cos of VB v5.0.16 .
bb.jpg
booted with SHIFT, picked kernel 3.19.0-32 and booted normally.

Any advice?

Cosmo.
Level 22
Level 22
Posts: 16662
Joined: Sat Dec 06, 2014 7:34 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Cosmo. » Tue Jan 16, 2018 6:26 am

VB 5.0.16 is 2 years old; nobody cares about it. In case you should follow the advice (as given in the screenshot) they will tell you there the same. And if you do not answer the question, why you think, that you have to use this old piece - as you did here not answer my question -, support will quickly come to an end.

User avatar
Arch_Enemy
Level 5
Level 5
Posts: 666
Joined: Tue Apr 26, 2016 3:28 pm

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Arch_Enemy » Tue Jan 16, 2018 8:05 pm

kitaubila wrote:I checked. That was the reason and now I'm worried cos I was connected to that serves for a long time. It was sweden.
Now picked 2 servers in Holland and no warning.

Is it possible something "bad" was slipped in my system using those "unsafe" servers :( ? Are they really unsafe, I mean is that possible?

installed kernel 4.4.0-109 and got error on boot :-(. doesn't work for me. maybe cos of VB v5.0.16 .

bb.jpg

booted with SHIFT, picked kernel 3.19.0-32 and booted normally.

Any advice?
Nah. All that warning means is you hit a repository that hadn't been included in your settings. Happens all the time, esp when selecting a new repository, or if some of the repositories are out of date or removed.

I upgraded to the 4.4.0-109 and so far suffering no ill effects; but I don't use VB very much at all.

I wonder why you got the error; I'm running a 2007 XEON CPU and had no issues after installing the new kernel.
$0.02+a grain of salt...

One thing I would impress on noobs to Linux, partition a ~20G partition as /. Partition the rest as /Home.
When the system fails, reinstall and use the exact same username and all your 'stuff' comes back to you.

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Wed Jan 17, 2018 5:22 am

I upgraded VB on other 2 machines and it works no probs, so today I'll be updating this main machine that has an old VB and then trying upgrading LM kernel.

BTW what is the option to upgrade to LM 18.3 on the bottom of view tab in LM 18.1/18.2 (not sure if I have it in LM 17.3)?
Any benefits or potential probs if I try this?

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Thu Jan 18, 2018 6:00 am

Cosmo. wrote:VB 5.0.16 is 2 years old; nobody cares about it. In case you should follow the advice (as given in the screenshot) they will tell you there the same. And if you do not answer the question, why you think, that you have to use this old piece - as you did here not answer my question -, support will quickly come to an end.
I upgraded to latest VB 5.2.6 and all my machines boot properly (LM 17.3 upto 18.3) but when I pick kernel 4.4.0-109 in LM 17.3 I get same error as above :-(. what can I try now?

thanks.

Cosmo.
Level 22
Level 22
Posts: 16662
Joined: Sat Dec 06, 2014 7:34 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Cosmo. » Thu Jan 18, 2018 6:26 am

Go to kernel 3.13.x (x = latest). This kernel series gets supported until the end of life of Mint 17.x.

Note that you have to select this kernel at boot time at least one time manually. Press and hold the shift key immediately after powering on until you see the grub menu. Go to the sub-menu to select the kernel 3.13.x.

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Thu Jan 18, 2018 6:47 am

I understand that part, and I do it like that but kernel 3.13.x doesn't have spectre/meltdown patch AFAIK?
that was my goal, otherwise I wouldn't change kernel.

Cosmo.
Level 22
Level 22
Posts: 16662
Joined: Sat Dec 06, 2014 7:34 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Cosmo. » Thu Jan 18, 2018 6:53 am

AS said, 3.13 is a LTS kernel and it gets patches, inclusive Meltdown and Spectre; patches for the latter one are still in development and not available.

In other words: Regarding those leaks it does not make a difference if you use 4.4. or 3.13.

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Thu Jan 18, 2018 7:13 am

sorry I messed up the numbers :( .

I have in my LM 17.3 kernel 3.19.0-32 and that one works regardless the VB version. I'm currently on v5.2.6, the latest one that was out yesterday.

If I try 3.13.0-139 I get this:
3.13.0-139.jpg
If I try 4.4.0-109 I get this:
4.4.0-109.jpg

Cosmo.
Level 22
Level 22
Posts: 16662
Joined: Sat Dec 06, 2014 7:34 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Cosmo. » Thu Jan 18, 2018 9:27 am

Is the picture with 3.13 from the host or from the guest? Has 3.13 been installed in the host or in the guest?

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Thu Jan 18, 2018 9:53 am

I don't understand what you mean.
I have Win7 64bit in which I have installed oracle VirtualBox and run a few LMs. one of them is this 17.3 (the most important one to me) and that one is giving me these problems with kernel. both pics are taken while booting LM machine.

Cosmo.
Level 22
Level 22
Posts: 16662
Joined: Sat Dec 06, 2014 7:34 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by Cosmo. » Thu Jan 18, 2018 4:10 pm

kitaubila wrote:I have Win7 64bit in which I have installed oracle VirtualBox
Don't you think, that you should have said this at the beginning. Actually you wrote in the starting post:
kitaubila wrote:I'm on LM 17.3 and currently on kernel 3.19.0-32.
Of course this did lead us to a completely wrong track.

Create for testing a fresh new VM with the same Mint version. Install kernel 4.4.latest; with VB 5.2.X this should not be a problem. Any issues?

kitaubila
Level 1
Level 1
Posts: 18
Joined: Tue Jan 03, 2017 7:03 am

Re: Trying to update kernel on LM 17.3 get warning it can't be authenticated

Post by kitaubila » Thu Jan 18, 2018 4:17 pm

I apologize. I'm in a hurry so I didn't realize I didn't write these details as in other thread I was writing.
I was trying to save time, that's why I wanted to keep this 17.3 system cos I have a ton of stuff inside I didn't want to waste time installing and setting up on a new system. I guess I'll have to set-up new one (18.3) and be done with it.
thank you for your help.

Post Reply

Return to “Newbie Questions”