[solved] how to know if vpn has switched off/reconnect

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Level 4
Level 4
Posts: 392
Joined: Sat Apr 15, 2017 1:16 pm
Location: UK

[solved] how to know if vpn has switched off/reconnect

Post by ArtGirl » Thu Jan 18, 2018 7:26 am

Hi, I'd done a format/reinstall and set up ExpressVPN, plus read how to manually set things up, in order to have an on/off switch. For some reason, this time ExpressVPN and that switch didn't connect, so it looked as if the vpn was running but it wasn't. Did some more reading and found that ExpressVPN's directory is usr/bin/expressvpn. I was able to add to startup

Code: Select all

usr/bin/expressvpn connect
and a 10-second timeout, which actually worked, lol. But then I realised I'd not know if the vpn has disconnected.

Found the VPN-Look-Out applet, installed (there was a warning message, but decided it's worth a try). The applet says it's connected via tun0, and a tun0 connection (labelled 'unknown') shows up in network settings (showing local secure IP), but am very new to vpn, so not 100% sure if the link was established that I need. (I'd removed the OpenVPN connection I'd set up, before doing all this.)

EDIT: a reboot answered whether the applet is seeing the connection. 10 seconds in the applet changed from red to green. Checked in terminal, and the vpn is active. As this is now an info post, rather than a question, just incase anybody else is wondering about the applet, there's the option to attempt to reconnect if it shuts down. Rarely happens with ExpressVPN, but it seems a good applet, and it will be interesting to see the reconnect.
18.3 Mate 64bit
Radeon R9 255, Mesa 17.2.8, 4.15.0-13,
Lenovo x310, intel i7-4790, 16 ram,
Ugee 2150

For any advice I've been able to add, eg re graphics tablets, please search forum.


Post Reply

Return to “Newbie Questions”