Update Manager: Ignore updates for this package (not working)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Mon Jan 22, 2018 12:06 pm

This is regarding:

Mint Mate 18.3
Update Manager v5.3.2


There are a few packages which I don't want or need, so I uncheck the box, right click, and select "Ignore updates for this package". It works only until I either refresh or reboot, then the update hits me in the forehead like a boomerang.

First it happened with the bluetooth package (bluez? something like that) This desktop computer does not have bluetooth, so I "ignored" the update. Finally after a few weeks of nagging I relented and updated.

Today the update manager wants to rollback the intel-microcode from 3.20180108.0~ubuntu16.04.2 to 3.20180108.0+really20170707ubuntu16.04.1. Since everything is working fine on this computer I tried to ignore the update. Whap! got smacked in the forehead by another boomerang. (aside: I am so sick of this meltdown/spectre nonsense).

This happens on three different Mint installs. How can I make the update manager actually ignore the updates?
Have you backed up your computer recently?

georap
Level 1
Level 1
Posts: 8
Joined: Wed Aug 14, 2013 3:57 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by georap » Mon Jan 22, 2018 3:48 pm

If you want to ignore an update, just right click on the package and select "ignore updates for this package." However, you won't be able to receive newer updates for this package, in this case the intel-microcodes.

In case you want to allow again updates, then go to the Preferences of the Update Manager, then to Blacklist, and remove the package you want from the blacklist.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Mon Jan 22, 2018 4:14 pm

That gives the suspicion for an ownership problem. Check this:

Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Tue Jan 23, 2018 11:48 am

Cosmo. wrote:That gives the suspicion for an ownership problem. Check this:

Mark the following command and press ctrl-c

Code: Select all

find $HOME ! -user $USER -type f
open a terminal and press ctrl-shift-V
Mark the complete result inclusive the command with the mouse and press ctrl-shift-C
In the forum click the Code-button above the text box, than press ctrl-v.

Report in case, that there is no output.

Code: Select all

john@Desktop ~ $ find $HOME ! -user $USER -type f
find: ‘/home/john/.gvfs’: Permission denied
/home/john/.viminfo
find: ‘/home/john/.linuxmint/mintinstall’: Permission denied
/home/john/.rnd
/home/john/.net_cf
/home/john/\
/home/john/.local/share/applications/mimeapps.list
find: ‘/home/john/.vim’: Permission denied
find: ‘/home/john/.cache/I’: Permission denied
find: ‘/home/john/.cache/dconf’: Permission denied
find: ‘/home/john/.cache/Z’: Permission denied
Thank you for your help. This was not always a problem, I must have hosed something a while back.
(My description of this issue was terrible, I should have said "ignore this update is not persistent between refreshes")
Have you backed up your computer recently?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Tue Jan 23, 2018 5:35 pm

As expected. At first correct the wrong ownership:

Mark the following command completely and make sure, that you do not miss any sign, than press ctrl-c

Code: Select all

find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;
Open a terminal and enter

Code: Select all

sudo -i
and press the Enter-key; you get prompted for your password, enter it.
Now still in the same terminal press ctrl-shift-V
Run this command and wait until it has finished. It does not produce a readable output.
Press twice ctrl-d
Immediately log off and back into your account.

There is one entry (/home/john/\) which attracts my attention. Although the backslash (\) is in principle allowed as a filename in Linux, this is one of the most uncommon folder names and it can easily lead to confusion, because the backslash has also a special meaning on the command line.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Tue Jan 23, 2018 6:06 pm

Cosmo. wrote:As expected. At first correct the wrong ownership
OK, thank you for the help. This symptom may be related to the same problem:
viewtopic.php?f=90&t=258624

Would it be safer to try this from a command line after boot - before the graphical i/f even starts? (if so, please remind me how to boot into the console from grub!). In the meantime I will be backing this computer up before attempting this command.
Have you backed up your computer recently?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Tue Jan 23, 2018 6:13 pm

JohnFrumm wrote:Would it be safer to try this from a command line after boot - before the graphical i/f even starts?
No, not safer and most importantly - it would not work.

You should backup your user data regularly, not only if you run into a problem. I expressively encourage you to do this. But besides that: My command will not lead to any data loss (otherwise I would added a massive warning) and it has been executed (in the forum) about hundred times.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Wed Jan 24, 2018 9:16 am

Cosmo. wrote:As expected. At first correct the wrong ownership:

Mark the following command completely and make sure, that you do not miss any sign, than press ctrl-c

Code: Select all

john@Desktop ~ $ find /home/$SUDO_USER ! -user $SUDO_USER -exec chown $SUDO_USER:$SUDO_USER '{}' \;
[i]find: ‘-exec’ is not the name of a known user[/i]
So next I tried breaking the command into pieces:

Code: Select all

john@Desktop ~ $ find /home/$SUDO_USER ! -user $SUDO_USER
find: missing argument to `-user'
If I delete the space between the "not" command and "-user" it executes a different command:

Code: Select all

john@Desktop ~ $ find /home/$SUDO_USER !-user $SUDO_USER
  *** oodles of output deleted ***
john@Desktop ~ $ history !!
history find /home/$SUDO_USER users $SUDO_USER
Then I said to myself, "you don't know what you are doing, stop before you brick your computer and ask for help."

So what am I doing wrong? I have used that same exec command before, never had a problem. I don't understand the $SUDO_USER variable, that is new to me.
Have you backed up your computer recently?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Wed Jan 24, 2018 9:42 am

JohnFrumm wrote:So what am I doing wrong?
Want a short answer? You did not read or follow my advice correctly and completely.

I told you that - after copying the command into the clipboard - you have to:
Cosmo. wrote:Open a terminal and enter

Code: Select all

sudo -i
and press the Enter-key; you get prompted for your password, enter it.
Now still in the same terminal press ctrl-shift-V
In other words: You did paste the command in a terminal with your own user context. You missed to enter in the terminal the command sudo -i and you consequently missed, that the given command has to be run in a so called rootshell.

To be fair: You did one thing right: You stopped ... and asked for help.

P.S. $SUDO_USER gives the name of the user, who invoked the sudo command; in other words your current account name.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Wed Jan 24, 2018 12:48 pm

@Cosmo,
you are right, I didn't.

Code: Select all

john@Desktop ~ $ find $HOME ! -user $USER -type f
john@Desktop ~ $ 
This time it came up blank. Thereafter I installed all of the latest patches, sans the Intel microcode (ignored this patch). After reboot the update manager is happy (green check) but if I "refresh", the Intel update pops up again. (Perhaps this is by design?) In the update manager/preferences/blacklist intel-microcode is listed seven times, once for each ignore request.

BTW, that file named "\" was not intentional. It was dated from May of last year - the month Mint was first installed, and was a copy of the "fstab" file. I must have accidentally created it when I was editing fstab with the vim editor (don't ask me how). I deleted that rogue file yesterday.
Have you backed up your computer recently?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Wed Jan 24, 2018 4:08 pm

Delete all entries for the microcode from the blacklist. Then quit the update manager (UM) completely via the quit command in the right click menu of the tray icon (just to be sure). Launch UM again and check at first, that the old entries are really gone. Now add it again via the context menu of the update list in the main window to the ignore list. Watch, if this gets obeyed now.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Wed Jan 24, 2018 5:27 pm

Cosmo. wrote:Delete all entries for the microcode from the blacklist. Then quit the update manager (UM) completely via the quit command in the right click menu of the tray icon (just to be sure). Launch UM again and check at first, that the old entries are really gone. Now add it again via the context menu of the update list in the main window to the ignore list. Watch, if this gets obeyed now.
OK, I blew away everything on the blacklist and quit the manager. Then I restarted mintupdate in the menu, refreshed, and the Intel-microcode was there (as expected). Then I "ignored" the update and all was ok. When I refreshed it came back again.

So, to be absolutely certain everything was purged from memory I did the same steps - but after purging the blacklist I rebooted (rather than just quitting) and tried again. Same result.

It seems that the blacklist items are correctly ignored until a manual refresh. From then on they pop up again. Is this "normal"? (I have never seen it work otherwise, so I don't know).
Have you backed up your computer recently?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Thu Jan 25, 2018 6:13 am

It is difficult to reproduce it, because my 18.3 test system is up to date, so there is nothing to put on the blacklist.

I wonder if this problem with the blacklist is specific for the microcode or if you have a general problem with blacklisting. To find that out you will have to wait a day or a few days, until you get an update (anything except the microcode). Now put it on the blacklist, quit UM as described, restart it and see, if this exclusion gets obeyed as expected.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Thu Jan 25, 2018 11:18 am

Cosmo. wrote:I wonder if this problem with the blacklist is specific for the microcode or if you have a general problem with blacklisting. To find that out you will have to wait a day or a few days, until you get an update (anything except the microcode). Now put it on the blacklist, quit UM as described, restart it and see, if this exclusion gets obeyed as expected.
This is getting weird. To be unambiguous, here are the steps.
1) intel-microcode "ignored" in mintupdate
2) computer shutdown for the night
3) upon computer boot this morning:
Update Manager:
firefox v58
gcab v0.7-1ubuntu0.1

(and the above is correct - intel-microcode is ignored by the update manager.)

4) mintupdate "Refresh" clicked
Update Manager:
firefox v58
gcab v0.7-1ubuntu0.1
intel-microcode

5) firefox v58 - IGNORE
Update Manager:
gcab v0.7-1ubuntu0.1

6) mintupdate "Refresh" clicked
Update Manager:
firefox v58
gcab v0.7-1ubuntu0.1
intel-microcode

7) gcab - IGNORE
Update Manager:
Your system is up to date

8) mintupdate "Refresh" clicked
Update Manager:
firefox v58
gcab v0.7-1ubuntu0.1
intel-microcode


9) quit update manager
10) restart update manager and wait a few seconds
Update Manager:
Your system is up to date

11) mintupdate "Refresh" clicked
Update Manager:
firefox v58
gcab v0.7-1ubuntu0.1
intel-microcode
Have you backed up your computer recently?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Thu Jan 25, 2018 4:37 pm

As I already wrote I cannot try to reproduce it with the installed test system out of understandable reasons. So I did the following:

I booted the live system of 18.3 (Cinnamon 64 bit), launched UM and applied at first mint-upgrade-info (necessary for being able to proceed. I selected the third update policy for getting as much updates offered as possible (gave 64). Now I put all level 1 updates into the blacklist (that were 9). 54 updates remained. I clicked refresh, nothing changed. I exited UM and launched it again - still no change, that means, none of the level 1 updates got offered and UM 5.3.2 works here as expected. That gives, that the problem is somewhere in your machine.

Create a fresh new user account for testing. In this case it is needed, that you choose the admin type for the test account to ensure, that the test account is member of the group sudo. Log out the main account and log into the test account. You have to select a policy, when you open UM at first; select the same as in the main account. You should get the same updates offered. Now put the same updates into the blacklist (the blacklist and all preferences get stored separately for each user) and see, if UM respects those blacklistings after refreshing or exiting UM.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Tue Jan 30, 2018 12:31 pm

Cosmo. wrote: Create a fresh new user account for testing. In this case it is needed, that you choose the admin type for the test account to ensure, that the test account is member of the group sudo. Log out the main account and log into the test account. You have to select a policy, when you open UM at first; select the same as in the main account. You should get the same updates offered. Now put the same updates into the blacklist (the blacklist and all preferences get stored separately for each user) and see, if UM respects those blacklistings after refreshing or exiting UM.
This is a good suggestion, but I had a few issues putting it into practice - so it took me a while (yes, it took me more time than it should have, but remember - this is a noob thread).

I rebooted, logged into the new account and tried to "ignore" a few of the patches and... upon refresh even this new account has this problem.
----------
Over the weekend I upgraded the HDD in my laptop (a different computer) and installed Mint 18.3 Mate. Now the laptop does not have this strange quirk anymore (however this desktop computer still does).
Have you backed up your computer recently?

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update Manager: Ignore updates for this package (not working)

Post by Cosmo. » Tue Jan 30, 2018 3:57 pm

The culprit is obviously somewhere deep in your system. I am sorry, that I cannot give you any other advice than to backup your user data and install the system new.

JohnFrumm
Level 2
Level 2
Posts: 55
Joined: Sun Dec 03, 2017 12:49 pm

Re: Update Manager: Ignore updates for this package (not working)

Post by JohnFrumm » Tue Jan 30, 2018 4:30 pm

Cosmo. wrote:The culprit is obviously somewhere deep in your system. I am sorry, that I cannot give you any other advice than to backup your user data and install the system new.
Yeah, I figured this. Right now it is just an annoyance, but I suspect that some of the other problems I have may be related to this same issue, although I may wait until Mint 19 is released (June 2018) before flushing my system.
Have you backed up your computer recently?

Post Reply

Return to “Newbie Questions”