[Solved] Playonlinux - fullscreen won't come to foreground. Can see it running in thumbnail

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
SpookyWatcher
Level 3
Level 3
Posts: 182
Joined: Fri May 10, 2013 4:06 pm

[Solved] Playonlinux - fullscreen won't come to foreground. Can see it running in thumbnail

Post by SpookyWatcher »

This is going to be hard to explain. When I run playonlinux with an emulated desktop (only way for the app to run 1920x1080) it runs but it will simply not be in the foreground.

If I ALT-TAB I can see the thumbnail of the game running. With a joystick I can even control it and see it responding. But as soon as I "select" it..it flashes fullscreen then moves to the background and I just see my desktop without the bottom panel. This doesn't happen in kde...so I'm assuming it's a window manager thing.

I tried all sorts of different settings... among them being:
"Automatically raise focused windows"
"Bring windows that require attention to the current"
"Prevent focus stealing"
etc etc.

Now the kicker is...if in the game settings I change the resolution to something lower than native (1920x1080) then Cinnamon puts the window on top and is perfectly playable. It only sends it to background if the game resolution is set to same as emulate desktop at 1920x1080

I've also tried to move it to a different workspace. I can do that...but it won't come to foreground when I change to that workspace. I've tried sending it to an external monitor and same thing.

Any ideas?
Last edited by SpookyWatcher on Wed Jan 24, 2018 5:02 pm, edited 1 time in total.

SpookyWatcher
Level 3
Level 3
Posts: 182
Joined: Fri May 10, 2013 4:06 pm

Re: Playonlinux - fullscreen won't come to foreground. Can see it running in thumbnail

Post by SpookyWatcher »

I solved it. Within the game configuration I set it to run in borderless window mode. Now the Cinnamon window manager keeps it in the foreground.

Weird solution..but it works.

Post Reply

Return to “Newbie Questions”