[SOLVED] How to completely disable or remove workspaces in LM 18.3?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
darkwolf
Level 2
Level 2
Posts: 55
Joined: Sat Feb 03, 2018 5:37 am

[SOLVED] How to completely disable or remove workspaces in LM 18.3?

Post by darkwolf » Fri Feb 09, 2018 7:26 am

Like i said in the title, is there any way to completely disable or even remove (if it's possible) workspaces in LM 18.3?
I know that many people use the "workspaces" feature, but for me it is totally useless.
Last edited by darkwolf on Fri Feb 09, 2018 8:16 am, edited 1 time in total.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: How to completely disable or remove workspaces in LM 18.3?

Post by Cosmo. » Fri Feb 09, 2018 7:30 am

What is your version of Mint and what is the desktop environment? If you don't know open a terminal and enter:

Code: Select all

inxi -Sz
Paste the output here.

darkwolf
Level 2
Level 2
Posts: 55
Joined: Sat Feb 03, 2018 5:37 am

Re: How to completely disable or remove workspaces in LM 18.3?

Post by darkwolf » Fri Feb 09, 2018 7:39 am

Cosmo. wrote:
Fri Feb 09, 2018 7:30 am
What is your version of Mint and what is the desktop environment? If you don't know open a terminal and enter:

Code: Select all

inxi -Sz
Paste the output here.
This is the result

Code: Select all

System:    Host: ....-PC Kernel: 4.13.0-32-generic x86_64 (64 bit)
           Desktop: Cinnamon 3.6.7  Distro: Linux Mint 18.3 Sylvia

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: How to completely disable or remove workspaces in LM 18.3?

Post by Cosmo. » Fri Feb 09, 2018 7:45 am

Press either alt-F1 or ctrl-alt-up to open the workspace overview. If you hover the workspaces you will see a close cross at the top right of this workspace. Click it and the workspace gets removed. Cinnamon remembers this decision, so you do not have to do something more. If you want to add a workspace t a later time click the + icon at the very right side. Leave the overview by pressing ESC.

User avatar
Moem
Level 17
Level 17
Posts: 7040
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: How to completely disable or remove workspaces in LM 18.3?

Post by Moem » Fri Feb 09, 2018 7:50 am

Press Alt+F1 to get into Expo mode. Close all workspaces except one. Now you effectively have only one desktop. Alt+F1 will get you out of Expo mode and back to that, and there is no reason why extra workspaces should ever exist on your system again. The shortcuts to swap workspaces will do exactly nothing because there is only one and nothing to swap.

As for how to remove the feature, I don't think that can (safely) be done.

On preview, exactly what Cosmo. said but a bit more wordy. :-)
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

darkwolf
Level 2
Level 2
Posts: 55
Joined: Sat Feb 03, 2018 5:37 am

Re: How to completely disable or remove workspaces in LM 18.3?

Post by darkwolf » Fri Feb 09, 2018 8:10 am

Press either alt-F1 or ctrl-alt-up to open the workspace overview. If you hover the workspaces you will see a close cross at the top right of this workspace. Click it and the workspace gets removed.
Actually i have done this right before starting this topic.
Cinnamon remembers this decision
Really? well that's good news.
Thanks!! both of you, i will mark this topic as solved.

Post Reply

Return to “Newbie Questions”