Page 1 of 1

Asus laptop, Realtek wifi nightmare, need help please

Posted: Fri Feb 09, 2018 11:05 pm
by Glockdoc
Let me know what you guys need to see to walk me through this.

I searched around and came up with the 2 following solutions and tried both. Still cannot keep a connection. Same issue across 3 or 4 different connections.

I have already done everything on this page:

viewtopic.php?f=53&t=204172&start=80#p1123045

Wifi worked fine with my vpn for several hours. Since then we are back to 15 minutes and drop.

I have done everything on this page also:

https://connectwww.com/how-to-solve-rea ... untu/4625/

No change after this round of tries. I have tried both ant 1 and ant 2. Same results.

Here is iwconfig. I guess we can start there.


oem@BigJohnny ~ $ iwconfiglo no wireless extensions.

wlp2s0 IEEE 802.11 ESSID:"Marriott_GUEST"
Mode:Managed Frequency:2.412 GHz Access Point: E0:10:7F:8F:08:68
Bit Rate=72.2 Mb/s Tx-Power=20 dBm
Retry short limit:7 RTS thr=2347 B Fragment thr:off
Power Management:off
Link Quality=70/70 Signal level=-37 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:30 Missed beacon:0

enp1s0 no wireless extensions.

oem@BigJohnny ~ $

Just let me know what else you wizards need to see.

Thank you in advance for your guidance. JC

Re: Asus laptop, Realtek wifi nightmare, need help please

Posted: Fri Feb 09, 2018 11:12 pm
by Glockdoc
Some more info:

oem@BigJohnny ~ $ inxi -Fxz
System: Host: BigJohnny Kernel: 4.13.0-32-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: ASUSTeK (portable) product: X541NA v: 1.0
Mobo: ASUSTeK model: X541NA v: 1.0
Bios: American Megatrends v: X541NA.313 date: 08/10/2017
CPU: Quad core Intel Pentium N4200 (-MCP-) cache: 1024 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8755
clock speeds: max: 2500 MHz 1: 1094 MHz 2: 1094 MHz 3: 1094 MHz
4: 1094 MHz
Graphics: Card: Intel Device 5a84 bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
GLX Renderer: Mesa DRI Intel HD Graphics 505 (Broxton)
GLX Version: 3.0 Mesa 17.2.4 Direct Rendering: Yes
Audio: Card Intel Device 5a98 driver: snd_hda_intel bus-ID: 00:0e.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network: Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
IF: enp1s0 state: down mac: <filter>
Card-2: Realtek RTL8723BE PCIe Wireless Network Adapter
driver: rtl8723be port: d000 bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Drives: HDD Total Size: 500.1GB (2.4% used)
ID-1: /dev/sda model: TOSHIBA_MQ01ABF0 size: 500.1GB
Partition: ID-1: / size: 108G used: 7.4G (8%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 4.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 36.0C mobo: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 206 Uptime: 16 min Memory: 1169.6/3809.2MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35
oem@BigJohnny ~ $






and a little more

oem@BigJohnny ~ $ rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

Re: Asus laptop, Realtek wifi nightmare, need help please

Posted: Fri Feb 09, 2018 11:53 pm
by AZgl1500
Your 2nd link is bad, but it brought up for me several relevant links:


https://sites.google.com/site/easylinux ... t/internet
This is one I had to use with my ASUS laptop, different WiFi card though.... plus I got a lot of help from the forum members here...

viewtopic.php?f=53&t=204172&start=80

https://github.com/lwfinger/rtlwifi_new/issues/34


https://social.technet.microsoft.com/Fo ... progeneral


https://askubuntu.com/questions/768843/ ... untu-16-04

Re: Asus laptop, Realtek wifi nightmare, need help please

Posted: Sat Feb 10, 2018 12:35 am
by Glockdoc
Thank you for the links. I read through them and have tried everything.

The only thing I had not tried was country code, and it is set to US, and "ignore" on ipv6 connections. I decided not to mess with that one as my connection has been active and stable since I originally posted an hour and a 1/2 ago. I have not had my vpn connected. I will turn it on and see if that causes any trouble.

If the vpn is the problem though, I wonder why the network card does not work after a crash.