Win 10 time is incorrect after using Linux

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Turbo2
Level 1
Level 1
Posts: 24
Joined: Fri Feb 09, 2018 9:04 pm

Win 10 time is incorrect after using Linux

Post by Turbo2 » Thu Feb 15, 2018 12:05 pm

I installed Linux Mint 18.3 alongside Windows 10 and every time that I use Linux and then go back to Windows 10 the time is way off. I have to go to Windows settings and turn off auto time update and then turn it back on to get it to read correctly. Also, Linux has turned off my hot USB ports when the computer shuts down.

User avatar
Moem
Level 17
Level 17
Posts: 7177
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Win 10 time is incorrect after using Linux

Post by Moem » Thu Feb 15, 2018 12:22 pm

Here's the fix for the first problem: viewtopic.php?f=18&t=263711
It happens all the time, so the answer was pretty easy to find.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
Pjotr
Level 20
Level 20
Posts: 11053
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Win 10 time is incorrect after using Linux

Post by Pjotr » Thu Feb 15, 2018 12:25 pm

This should solve your time issue: https://askubuntu.com/a/800965

Hot USB ports: assuming that you don't mean using your USB ports as electrical heating, what do you mean? :)

--Edit: Moem was too fast for me...
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Turbo2
Level 1
Level 1
Posts: 24
Joined: Fri Feb 09, 2018 9:04 pm

Re: Win 10 time is incorrect after using Linux

Post by Turbo2 » Thu Feb 15, 2018 12:50 pm

Pjotr wrote:
Thu Feb 15, 2018 12:25 pm
This should solve your time issue: https://askubuntu.com/a/800965

Hot USB ports: assuming that you don't mean using your USB ports as electrical heating, what do you mean? :)

--Edit: Moem was too fast for me...
When I turn my computer off there is (or I should say was) power still going to them to charge phones, etc. even when the computer is off.

User avatar
Pjotr
Level 20
Level 20
Posts: 11053
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Win 10 time is incorrect after using Linux

Post by Pjotr » Thu Feb 15, 2018 2:03 pm

Turbo2 wrote:
Thu Feb 15, 2018 12:50 pm
Pjotr wrote:
Thu Feb 15, 2018 12:25 pm
This should solve your time issue: https://askubuntu.com/a/800965

Hot USB ports: assuming that you don't mean using your USB ports as electrical heating, what do you mean? :)

--Edit: Moem was too fast for me...
When I turn my computer off there is (or I should say was) power still going to them to charge phones, etc. even when the computer is off.
Then your computer isn't/wasn't really off.... Still consuming power.

Seems rather undesirable to me. When I charge my phone, I use the dedicated charger for it. And I pull it from the wall socket when the job is done: no sense in letting it use more electricity then.
Tip: 10 things to do after installing Linux Mint 19 Tara
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
Termy
Level 5
Level 5
Posts: 762
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Win 10 time is incorrect after using Linux

Post by Termy » Thu Feb 15, 2018 3:00 pm

I always charge my phone via the PC. It's right next to me, and since I'm the computer every day, I need my phone nearby. I have a dedicated charger by the bed and spare chargers around if needed, but it's yet to be a concern.
Here to help.

I'm LearnLinux (LL) on YouTube: https://www.youtube.com/channel/UCfp-lN ... naEE6NtDSg
I'm also terminalforlife (TFL) on GitHub: https://github.com/terminalforlife

User avatar
Lord Boltar
Level 4
Level 4
Posts: 381
Joined: Mon Jan 09, 2017 7:24 pm

Re: Win 10 time is incorrect after using Linux

Post by Lord Boltar » Thu Feb 15, 2018 3:22 pm

Set Clock Time on Dual-Boot Systems

If you're dual-booting Linux Mint 18 and Windows 10, you may find that changing time in one system affects the other and the two systems can't display the same time.

This happens as Linux Mint 18 interprets the hardware clock or real time clock (RTC) in universal time (UTC) by default while Windows 10 maintains the clock in local time.

You can fix this by keeping RTC in local time in Linux Mint, same as Windows, by running a command in the terminal below.

timedatectl set-local-rtc 1 --adjust-system-clock
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

User avatar
gld59
Level 2
Level 2
Posts: 61
Joined: Thu Nov 30, 2017 11:05 pm
Location: Australia

Re: Win 10 time is incorrect after using Linux

Post by gld59 » Fri Feb 16, 2018 4:14 am

In spite of the suggestions to change Linux's timezone behaviour to match that of Windows, changing recent versions of Windows to match Linux's preferred behaviour may be more convenient. If you live somewhere with daylight saving, each OS will want to make the ds adjustment twice a year. If Linux is changed to match Windows, that means both will change the RTC (hardware clock), therefore a double adjustment. If Windows is instead changed to match Linux, both will only change the time "internally", by changing their offset from the (unchanged) RTC.

The topic at viewtopic.php?f=90&t=262667 is worth a look - it's only 11 posts.

User avatar
JoeFootball
Level 6
Level 6
Posts: 1497
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Win 10 time is incorrect after using Linux

Post by JoeFootball » Fri Feb 16, 2018 10:34 am

Augmenting the above post, here's another article for easily editung the Windows registry to force it to use UTC time where its local time is governed by the user session, the way the rest of the world's computers work.

Joe

User avatar
Joe2Shoe
Level 4
Level 4
Posts: 387
Joined: Wed Oct 18, 2017 8:12 pm
Location: Ozone

Re: Win 10 time is incorrect after using Linux

Post by Joe2Shoe » Fri Feb 16, 2018 11:26 am

In BIOS, set the USB ports to allow charging when the laptop is turned OFF.
"Tolerance is the refuge of men without conviction."
"Common sense is not so common" - Voltaire

Turbo2
Level 1
Level 1
Posts: 24
Joined: Fri Feb 09, 2018 9:04 pm

Re: Win 10 time is incorrect after using Linux

Post by Turbo2 » Fri Feb 16, 2018 3:18 pm

Moem wrote:
Thu Feb 15, 2018 12:22 pm
Here's the fix for the first problem: viewtopic.php?f=18&t=263711
It happens all the time, so the answer was pretty easy to find.
I changes the registry in Windows10 and now it's back to normal. Thanks for the help.

Post Reply

Return to “Newbie Questions”