Cinnamon is running in software rendering mode

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
LordNicoll
Level 1
Level 1
Posts: 3
Joined: Tue Feb 20, 2018 8:18 pm

Cinnamon is running in software rendering mode

Post by LordNicoll » Tue Feb 20, 2018 8:27 pm

While I seen this asked a few times before, I have a slightly different problem with mine, probably to do with the the fact it's running in a VM on a VMWare ESXi host, and Mint doesn't seem to know what to do with the virtual GPU. Ubuntu and OpenSuSE seemed not to mind the virtualised GPU so I'm guessing this might be a cinnamon thing? It's a pain to copy and paste from a VM like this so I took a screenshot of the output from inxi -Fxz, although most of what I mentioned probably makes that info redundant.
screenshot
Image

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Cinnamon is running in software rendering mode

Post by Cosmo. » Wed Feb 21, 2018 6:34 am

It sounds, as if 3D acceleration is missing in the settings for the VM. I don't use VMW, so I cannot tell you, where you have to set it.

User avatar
jimallyn
Level 18
Level 18
Posts: 8419
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Cinnamon is running in software rendering mode

Post by jimallyn » Thu Feb 22, 2018 4:59 am

Cinnamon requires 3D acceleration. I don't know anything about VMWare, but in VirtualBox you have to install the Guest Additions. I suppose it's something like that in VMWare.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

LordNicoll
Level 1
Level 1
Posts: 3
Joined: Tue Feb 20, 2018 8:18 pm

Re: Cinnamon is running in software rendering mode

Post by LordNicoll » Mon Mar 05, 2018 9:35 pm

jimallyn wrote:
Thu Feb 22, 2018 4:59 am
Cinnamon requires 3D acceleration. I don't know anything about VMWare, but in VirtualBox you have to install the Guest Additions. I suppose it's something like that in VMWare.
I installed the 3rd party software from VMWare that allows control by the host, but that didn't help at all. I know on other Linux OSes it works fine, and the vGPU is correctly detected, but not on this. I guess I could pass through a low powered GPU so it can use 3D acceleration as well as screen drawing.

edit: I did find an enable 3D option in the virtual GPU controls, I'm seeing if that changes the software rending error. Yes it does, thank's a million, that was easy!

User avatar
pbear
Level 5
Level 5
Posts: 564
Joined: Wed Jun 21, 2017 12:25 pm
Location: San Francisco

Re: Cinnamon is running in software rendering mode

Post by pbear » Mon Mar 05, 2018 11:00 pm

LordNicoll wrote:
Mon Mar 05, 2018 9:35 pm
I know on other Linux OSes it works fine
Mint's MATE and XFCE versions also work fine without 3D acceleration. Only Cinnamon requires it. Congrats on finding the appropriate VMWare setting.
Time flies like an arrow. Fruit flies like a banana.
Running Mate 18.3 64 bit (by upgrade from 18.1-2)

Post Reply

Return to “Newbie Questions”