Broadcom wireless won't connect to router (SOLVED)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jsb
Level 3
Level 3
Posts: 102
Joined: Sat Feb 11, 2017 11:20 am

Broadcom wireless won't connect to router (SOLVED)

Post by jsb » Wed Feb 21, 2018 3:43 pm

Trying to resurrect an old HP Mini 1000 netbook. I can not get it connect to the wireless router. When password did not work, I turned on guest option with no security, but it still won't connect. I can connect other devices to the router with no problems.

I tried all 3 drivers: Both bcmwl-kernel-source and firmware-b43-installer both work in terms of showing all the wireless networks. The third one b43legacy does not work at all.

Running Mint 18.1 XFCE, 32 bit and router is Western Digital MyNet 600.

output from inxi -Fxz:

Code: Select all

System:    Host: mint-HP-Mini Kernel: 4.4.0-53-generic i686 (32 bit gcc: 5.4.0)
           Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.1 Serena
Machine:   System: Hewlett-Packard product: HP Mini v: F.05
           Mobo: Hewlett-Packard model: 361A v: KBC Version 02.0E
           Bios: Hewlett-Packard v: 361A0 Ver. F.10 date: 12/25/2008
CPU:       Single core Intel Atom N270 (-HT-) cache: 512 KB
           flags: (nx pae sse sse2 sse3 ssse3) bmips: 3191
           clock speeds: max: 1600 MHz 1: 1333 MHz 2: 1067 MHz
Graphics:  Card: Intel Mobile 945GSE Express Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1024x600@60.00hz
           GLX Renderer: Mesa DRI Intel 945GME x86/MMX/SSE2
           GLX Version: 1.4 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-53-generic
Network:   Card-1: Broadcom BCM4312 802.11b/g LP-PHY
           driver: wl bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
           Card-2: Marvell 88E8040 PCI-E Fast Ethernet Controller
           driver: sky2 v: 1.30 port: ec00 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 18.4GB (34.1% used)
           ID-1: /dev/sda model: SanDisk_pSSD_16G size: 16.4GB
           ID-2: USB /dev/sdb model: Transcend_2GB size: 2.0GB
Partition: ID-1: / size: 14G used: 4.9G (38%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 1.06GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 49.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 184 Uptime: 2 min Memory: 189.1/990.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.461) inxi: 2.2.35 
Further background:
Had not used netbook in years, it had Peppermint 4 on it. When I turned it on with Peppermint 4, it would not connect to our wireless router. Wireless had worked long ago, when I was using this daily, but that also was a different router. I thought maybe updates were needed, since P4 could not update, tried Mint 18.3, then Peppermint 8, then Lubuntu. Wireless goes on but would not connect with any of these.

Ended up on Mint 18.1, after seeing this post, indicating it worked for someone else with similar wireless:
viewtopic.php?t=238961
Last edited by jsb on Thu Mar 01, 2018 4:18 pm, edited 1 time in total.

User avatar
kc1di
Level 13
Level 13
Posts: 4645
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Broadcom wireless won't connect to router

Post by kc1di » Wed Feb 21, 2018 5:46 pm

Hello jsb,

The correct driver for that card is the bcmwl-kernel-source. I have the same card and it works great.
The problem must be in authentication with your new router. Here is what I would try first.

make sure b43 is not loaded

Code: Select all

sudo modprobe -r b43
go to network manager and click on left click it choose network settings then highlight the connection your trying to connect to.
then click edit go to security tab see what athentication it's set for (you should be using wpa and wpa2 personal (Note if your router is set to wep it should be changed as wep is no longer secure.) Double check the password while your there make sure it is in the right case. then click on IPV6 and click on the dropdown box and select ignore - close that out and reboot machine. see if you can connect.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

User avatar
Lord Boltar
Level 4
Level 4
Posts: 216
Joined: Mon Jan 09, 2017 7:24 pm

Re: Broadcom wireless won't connect to router

Post by Lord Boltar » Wed Feb 21, 2018 10:38 pm

1. Click on "Network" icon
2. Click on "Newtwork Connections"
3. Select your WIFI network and click "Delete"
4. Turn Off WIFI. Wait 10 Seconds or so then turn back on.
5. Under "Network Connections" > WIFI Click ADD then select WIFI
6. Manually Enter Network details
7. Try to Connect

jsb
Level 3
Level 3
Posts: 102
Joined: Sat Feb 11, 2017 11:20 am

Re: Broadcom wireless won't connect to router

Post by jsb » Sat Feb 24, 2018 11:18 am

Thanks will try that stuff when I am back home.

It is definitely an issue with the the specific router. I took the netbook with on a visit to my sister, to test it on a different router. It connected with no issues on her Netgear router which is newer than mine.

jsb
Level 3
Level 3
Posts: 102
Joined: Sat Feb 11, 2017 11:20 am

Re: Broadcom wireless won't connect to router (SOLVED)

Post by jsb » Thu Mar 01, 2018 4:12 pm

Thanks again for the suggestions. Tried both and still couldn't get it to work.

Then in looking through router wireless settings, noticed that network mode was set to 802.11n only. It occurred to me that this was a newer protocol and maybe not compatible with the ancient hardware, so changed that to "mixed 802.11 b+g+n" and it connected.

User avatar
kc1di
Level 13
Level 13
Posts: 4645
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Broadcom wireless won't connect to router (SOLVED)

Post by kc1di » Thu Mar 01, 2018 6:55 pm

Glad you found it and it's working :)
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

Post Reply

Return to “Newbie Questions”