[SOLVED] How to Change Login Background?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Healena
Level 1
Level 1
Posts: 11
Joined: Sat Feb 17, 2018 12:45 pm

[SOLVED] How to Change Login Background?

Post by Healena » Wed Feb 21, 2018 7:09 pm

Hi again, and sorry again for my inability, however it would seem something simple is indeed far from it.

I installed XFCE 4 to have a peek at that without downloading a whole distro again. It was very quick, I logged out, changed to it and logged in, nothing to write home about in terms of performance increases so decided to go back to cinnamon.

I know it's stupid, but having changed back to cinnamon, the login screen still shows the blue xfce background with mouse, After googling it and going into "Login Window" it showed the correct background, so I decided to change it to one of the others (the XFCE one was nowhere to be found) and rebooted the machine. STILL showing the XFCE background. I went into synaptic and uninstalled XFCE 4 and rebooted and yet STILL it persists.

I've spent more time trying to sort it out than it would have taken to just reinstall mint from scratch and update it and make the necessary grub change to fix the reboot/shutdown issue, but SURELY this should not be a difficult task? What is overriding it and why?

Thanks!

Edit: I used synaptic package manager and marked xfce 4 for complete removal, no change after reboot, marked everything with Cinnamon in the name for Reinstall and still no change after reboot. If XFCE is added as another window manager, what does it use to change the login background and how do I set it back to whatever Cinnamon uses? I'm just going to reinstall from scratch for now, but I came across so many other people asking this question and not one answer has worked, I'm super curious how to actually fix it.
Last edited by Healena on Thu Feb 22, 2018 9:32 am, edited 1 time in total.

User avatar
Lord Boltar
Level 4
Level 4
Posts: 216
Joined: Mon Jan 09, 2017 7:24 pm

Re: How to Change Login Bakcground?

Post by Lord Boltar » Wed Feb 21, 2018 10:25 pm

Try this

sudo apt-get -f install
sudo apt-get clean
sudo apt-get autoclean
sudo apt-get update

then
sudo apt-get purge xfce4

Healena
Level 1
Level 1
Posts: 11
Joined: Sat Feb 17, 2018 12:45 pm

Re: How to Change Login Bakcground?

Post by Healena » Thu Feb 22, 2018 8:42 am

Thanks Lord Boltar, sadly no change. Although it said XFCE was not installed it did show some other packages with XFCE in it and suggested I used auto-remove which I duly did and it took those off, but on reboot, am still faced with the same annoying XFCE background. I can't seem to find out what has taken over the login background, if I knew that, I'd use that to change it and job done.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1832
Joined: Thu Jan 04, 2018 1:00 pm

Re: How to Change Login Bakcground?

Post by Sir Charles » Thu Feb 22, 2018 8:58 am

Run this in a terminal:
sudo <your-text-editor> /etc/lightdm/lightdm-gtk-greeter.conf.d/99_linuxmint.conf
Replace <your-text-editor> with your text editor (xed, mousepad or else)
When the file opens change the path to the background picture after "background=" to point to your prefered picture.
Mine is: background=/usr/share/backgrounds/linuxmint/default_background.jpg
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

Healena
Level 1
Level 1
Posts: 11
Joined: Sat Feb 17, 2018 12:45 pm

Re: How to Change Login Bakcground?

Post by Healena » Thu Feb 22, 2018 9:32 am

Ok, so I CAN get the XFCE background to go, if I use the Admin>Login Window and turn off "Draw user backgrounds". After rebooting I switched it back on and rebooted and it's straight back to the XFCE background (which is not my desktop background or anything so WHERE is it getting this information?) and if I click "Guest Session" it shows the correct background, but going back to the user brings up that annoying blue mouse again.

Changing the theme to aqua did NOTHING at all.

HOWEVER, I have just cured it, I found where the stupid xfce background was located, /usr/share/backgrounds/xfce, deleted that folder, right clicked on the desktop and chose the same background that was already showing and finally it's showing correctly. Have now confirmed behavior, by changing the desktop background and sure enough that's what I see on the login screen (and selecting guest session shows the linuxmint background). SOOOOO, I am pretty sure at this point, just selecting the desktop background again would have cured the problem (I am almost tempted to put XFCE back and find out LMAO) which leaves only one question...

How did it show a background on the greeter that was never set as either the desktop background or login background?

Post Reply

Return to “Newbie Questions”