Newbie with Steam issues and more

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Supern90
Level 1
Level 1
Posts: 2
Joined: Thu Feb 22, 2018 8:44 am

Newbie with Steam issues and more

Post by Supern90 » Thu Feb 22, 2018 9:34 am

Hello good people of the forums!

I tried/tested Linux Mint Cinnamon (18.3?) on my laptop about a week ago, while waiting for my new stationary computer to arrive. I liked it so much I decided to use it as my only OS. Most things seem to work fine, but I have a couple of problems. Keep in mind I'm a complete noob, and not a particularly good noob either. :lol:

I have two main issues I need help to solve and I have googled them like crazy while copying others Terminal lines without result. I probably have only made things worse. They might be connected even..?

1. Steam does not react.

And ofc I have found many a thread where people have had the same problem and offered terminal command lines, but non to my success. Actually, it were just in my first tries where Steam didn't react at all. After a while I decided to download steam from their webpage and now I get a error-message when I click on steam. I have deleted and installed steam from the software manager and from the webpages so many times I don't know which way is up any longer. Usually I accept the licence agreement, then steam updates and when I try to open it, either nothing happens or I get an error message. First error message was something grey and red, which I unfortunately don't remember but now I get a black box with "Fatal Error: Failed to load Steamui.so". In the Terminal last time I tried to delete it all, but Steam is still everywhere on my comp. Copying others lines that has worked before has not helped me, as I get stuff like "Steam library is not installed" and others like "runetime error". Now I have just lost total control.

I would like to delete everything steam related, and re-install with a fix so I can use it and play games.

2. Starting the computer is giving me an error message.

"Running in software rendering mode

Cinnamon is currently running without video hardware acceleration and, as a result, you may observe much higher than normal CPU usage. There could be a problem with your drivers or some other issue. For the best experience, it is recommended that you only use this mode for troubleshooting purposes."

Everything seem to work fine, but I don't really know as my comp is all new and is my first build. And I don't have steam to try games on. Anyways I would like to know what it means and hopefully remove it, as it scares me about as much as having to clean my bathroom. I really just want the both of them to go away. And before I got that "rendering mode" problem, I had a problem where my computer simply refused to restart, starting in something other than safe mode. I have already forgotten what it was called, something starting with an "F" i believe? Forcing me to change drivers and getting this newer but "better" problem I know nothing about.

Lastly I probably should mention one other thing, I don't have a computer screen at the moment, so I connected my PC to the TV, could this have something to do with one of or both of the problems?

Thanks so much for reading through my problems and please tell me how and what information to send you guys to make this easier for us both.

Expect to see a lot more of me in the future.

Kind regards Supern90

Supern90
Level 1
Level 1
Posts: 2
Joined: Thu Feb 22, 2018 8:44 am

Re: Newbie with Steam issues and more

Post by Supern90 » Thu Feb 22, 2018 9:59 am

Well, now I suddenly feel even more stupid. I entered "steam" in the software manager and noticed there were more than one download. So i downloaded three different ones. And it seems like the one called "flathub" actually works. I now have managed to login to my user and hopefully will be able to download my games and play them.

Will update you on what happens next.

What does flathub mean, and why is that one the one that works for me? I now have two steamlogos in my system where the black one don't work and the blue one does, atm. Have I missed something very, very basic here? I also downloaded minetest, which seems to work fine (not the flathub one). So why does that one work without flathub?

Post Reply

Return to “Newbie Questions”