Unable to launch "cinnamon-session-cinnamon

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Rob1911
Level 1
Level 1
Posts: 21
Joined: Tue Nov 26, 2013 3:03 pm

Unable to launch "cinnamon-session-cinnamon

Post by Rob1911 » Thu Feb 22, 2018 7:24 pm

Operating System: Linux Mint 17.3 Cinnamon 32-bit
Cinnamon Version 2.8.8
Linux Kernel 4.4.0-112-generic
Processor Intel Core 2 CPU 6600 @ 2.40GHz x 2
Memory 7.9GiB
Hard Drives 289.0GB
Graphics Card NVIDIA Corporation GM107[GeForce GTX 750]

Have a dual boot system Mint 18.2 and Mint 17.3 with two monitors. After installing Mint 18.2. I booted into Mint 18.2 and everything worked. I forgot a license number on a piece of software. Did a restart and booted into Mint 17.3. Shut computer down for the night and booted into Mint 18.2 in the morning and got the following error message.
(EE) Fatal Server Error: (EE) Server is already active for display 0. If this server is no longer running, remove /tmp/.XOlock and start again.

Black screen with error message window: Unable to launch "cinnamon-session=cinnamon" not found falling back to default sessions.

First try to fix: https://askubuntu.com/questions/135483/ ... op-session

Instructions:
First you should have cinnamon on your system :)

Second issue the commands

echo "cinnamon" > ~/.xsession
sudo service xrdp restart

OR if you like to do it hard:) do the following:

Edit the file /etc/xrdp/startwm.sh

sudo -H gedit /etc/xrdp/startwm.sh

At the end of the file you will find the following lines:

pre_start
wm_start
post_start

These are calls to functions above. So in order to make cinnamon the default just put # before wm_start to comment it (to stop calling the function which searches for the sessions)

Add the following line in front of the above three lines gnome-session --session=cinnamon

restart xrdp sudo service xrdp restart



Restart xrdp:

sudo /etc/init.d/xrdp restart

Second to Fourth try to fix:
From community.linuxmint.com Fixing the black screen after grub boot-up: Edited the grub menu for Mint 18.2. At the end of the linux line: tried nvidia.modeset=0 (locked up password), Tried Nouveaulmodeset=0, Tried nomodeset xforcevesa

Fifth try:
mint@mint ~ $ apt install mint-meta-cinnamon
Reading package lists... Done
Building dependency tree
Reading state information... Done
mint-meta-cinnamon is already the newest version (2017.06.02).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
mint@mint ~ $ inxi -Sr
System: Host: mint Kernel: 4.8.0-53-generic i686 (32 bit)
Desktop: Cinnamon 3.4.3 Distro: Linux Mint 18.2 Sonya
Repos: Active apt sources in file: /etc/apt/sources.list
deb cdrom:[Linux Mint 18.2 _Sonya_ - Release i386 20170628]/ xenial contrib main non-free
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://packages.linuxmint.com sonya main upstream import backport #id:linuxmint_main
deb http://archive.ubuntu.com/ubuntu xenial main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu xenial-backports main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ xenial partner
mint@mint ~ $

Sixth Try to fix:
https://www.x.org/wiki/FAQErrorMessages/ item #5 Server is already active for display 0

Instructions:
I keep getting the message: "Server is already active for display 0"

You get an error message like:

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

The number denotes the display number (in this case 0). This number needs to be unique on the system, so you cannot run two servers on one system with identical display numbers. This message indicates that there is already a server with this number running on the system. You can verify this by running

ps aux | grep `cat /tmp/.X0-lock`

If you see an output like:

root 2283 0.5 5.1 27796 6536 ? S Apr21 59:03 [X]

it indicates that there is indeed an Xserver running under this PID. To start a second server on the same system you have to give it a different dislay number. If you start your servers using startx you can do

startx -- :1

to start a server with display number 1. If you are sure there is no other server running on your system and above ps command indicates that no server with this PID is running, you should remove the file /tmp/.X0-lock by doing (as 'root'):

rm -rf /tmp/.X0-lock

ps aux | grep `cat /tmp/.X0-lock` At this command it just went back to the command prompt. I did it again and got message back "No such file or directory.

Tried some other things from the command prompt to update packages but still did not work.

Am out of ideas. Please help. Linux Mint 17.3 still works just trying to get Mint 18.2 to work. Both monitors in Mint 17.3 are set 1920 x1080 (16.9). Monitors in Mint 17.3 are listed as DVI-I-1 and DVI-D-0.

Thanks
Rob

User avatar
Pierre
Level 16
Level 16
Posts: 6725
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Unable to launch "cinnamon-session-cinnamon

Post by Pierre » Fri Feb 23, 2018 2:16 am

was there any updates for the LM18.2 ? - - before you shutdown for the night ?

if there is no easy resolution, for your issue - - it may be just plain quicker,
to redo the Full Installation - again :o

and maybe, do a Full backup, this time, too.
8)
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
Termy
Level 5
Level 5
Posts: 761
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Unable to launch "cinnamon-session-cinnamon

Post by Termy » Fri Feb 23, 2018 8:05 am

Whenever I see that error, it tends to be because I removed the 'cinnamon' package, which is the Cinnamon session.
Here to help.

I'm LearnLinux (LL) on YouTube: https://www.youtube.com/channel/UCfp-lN ... naEE6NtDSg
I'm also terminalforlife (TFL) on GitHub: https://github.com/terminalforlife

Rob1911
Level 1
Level 1
Posts: 21
Joined: Tue Nov 26, 2013 3:03 pm

Re: Unable to launch "cinnamon-session-cinnamon

Post by Rob1911 » Fri Feb 23, 2018 1:16 pm

Pierre & Termy:

No, LM 18.2 did not do any updates before I shut it down for the night. Over the weekend, I will do redo a full installation and do all the updates "before" I import my software and settings. Will also do a full backup after the updates and importing my software and setting.

In regards to the "cinnamon package" removal. I do not believe the cinnamon package was removed by me but I have made mistakes before.

Will report back with how it turns out.

Thanks for all the replies.
Take Care!
Rob

Rob1911
Level 1
Level 1
Posts: 21
Joined: Tue Nov 26, 2013 3:03 pm

SOLVED Re: Unable to launch "cinnamon-session-cinnamon

Post by Rob1911 » Mon Feb 26, 2018 7:54 pm

SOLVED:

Pierre & Termy:

Thanks for the help.

I had a LM 18.2 live cd that I ordered. Tried 3 times to install but failed to work.

Finally downloaded and imaged LM 18.3 and got everything working.

Thanks again & Take Care!
Rob

Rob1911
Level 1
Level 1
Posts: 21
Joined: Tue Nov 26, 2013 3:03 pm

Re: Unable to launch "cinnamon-session-cinnamon

Post by Rob1911 » Mon Feb 26, 2018 8:00 pm

Add to last message marked SOLVED

Forgot to add when I got LM 18.3 to working.

Did all the updates and a backup BEFORE getting out of LM 18.3.

Worked great.

Thanks again!
Rob

Post Reply

Return to “Newbie Questions”