Cinnamon Crash/Fallback Mode

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
wwindexx
Level 1
Level 1
Posts: 6
Joined: Fri Feb 23, 2018 1:46 pm

Cinnamon Crash/Fallback Mode

Post by wwindexx » Fri Feb 23, 2018 1:53 pm

Hello everyone! I found a few similar issues searching the forums but following the instructions were confusing, and in some cases made things worse. I ended up having to do a fresh install and resign to posting my own thread. As the title implies, on boot Cinnamon crashes and I am stuck in Fallback Mode. I assume this is a video card issue because in Display Settings I am also stuck in Laptop Mode and my resolution is 1024x768. I can't change it to anything else or exit laptop mode. I had to use nomodeset to boot my live usb for the install and once the install was successful I installed the Nvidia drivers in the Driver Manager. I tried upgrading the drivers to 390 and that didn't help (384 is the one the Driver Manager reccomends). I purged and went back to 384. I am using the GTX 970 if that helps. glxinfo gives a very weird output:
alex@alex-desktop ~ $ glxinfo
name of display: :0
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".

Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".
Xlib: extension "GLX" missing on display ":0".


Help would be very much appreciated. I really don't want to switch to a different distro. Mint with Cinnamon has been my favorite for a long time now.

User avatar
Pjotr
Level 21
Level 21
Posts: 13476
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Cinnamon Crash/Fallback Mode

Post by Pjotr » Fri Feb 23, 2018 3:22 pm

Please generate an overview of your system like this:

- Launch a terminal window (this is how to launch a terminal window);

- make the terminal window full screen, to avoid chopped lines;

- copy/paste this command into the terminal:

Code: Select all

inxi -Fxz
(if you type: the letter F is a capital letter)

- Press Enter.

- Copy/paste the output in your next message.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

wwindexx
Level 1
Level 1
Posts: 6
Joined: Fri Feb 23, 2018 1:46 pm

Re: Cinnamon Crash/Fallback Mode

Post by wwindexx » Sat Feb 24, 2018 3:09 am

Code: Select all

alex@alex-desktop ~ $ inxi -Fxz
System:    Host: alex-desktop Kernel: 4.13.0-36-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine:   Mobo: ASUSTeK model: CROSSHAIR V FORMULA-Z v: Rev 1.xx
           Bios: American Megatrends v: 2201 date: 03/23/2015
CPU:       Hexa core AMD FX-6200 Six-Core (-MCP-) cache: 12288 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 48044
           clock speeds: max: 4003 MHz 1: 4003 MHz 2: 4003 MHz 3: 4003 MHz 4: 4003 MHz 5: 4003 MHz 6: 4003 MHz
Graphics:  Card: NVIDIA GM204 [GeForce GTX 970] bus-ID: 01:00.0
           Display Server: X.Org 1.18.4 drivers: nvidia,fbdev,nouveau (unloaded: vesa)
           Resolution: 1024x768@76.00hz
           GLX Renderer: N/A GLX Version: N/A Direct Rendering: N/A
Audio:     Card-1 NVIDIA GM204 High Definition Audio Controller driver: snd_hda_intel bus-ID: 01:00.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k4.13.0-36-generic
Network:   Card: Intel 82583V Gigabit Network Connection driver: e1000e v: 3.2.6-k port: c000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 490.1GB (2.4% used) ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
           ID-2: /dev/sdb model: Corsair_Force_GS size: 240.1GB
Partition: ID-1: / size: 20G used: 6.9G (38%) fs: ext4 dev: /dev/sdb1
           ID-2: /home size: 197G used: 209M (1%) fs: ext4 dev: /dev/sdb6
           ID-3: swap-1 size: 4.09GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 19.1C mobo: N/A
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 205 Uptime: 12:39 Memory: 1053.2/7874.4MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
alex@alex-desktop ~ $ 

User avatar
Pjotr
Level 21
Level 21
Posts: 13476
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Cinnamon Crash/Fallback Mode

Post by Pjotr » Sat Feb 24, 2018 5:48 am

Try this:

1. Install the latest kernel from the 4.4 series (4.4.0-116) by means of the kernel tool in Update Manager:
Update Manager - panel: View - Linux kernels

2. Boot from it (it's under the header Advanced in the Grub bootloader menu) and then remove all installed kernels from higher series (probably 4.10.x and 4.13.x).
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

wwindexx
Level 1
Level 1
Posts: 6
Joined: Fri Feb 23, 2018 1:46 pm

Re: Cinnamon Crash/Fallback Mode

Post by wwindexx » Sat Feb 24, 2018 10:27 am

I'm going to try this as soon as I get home from work. Isn't this booting into an incredibly old kernel? Doesn't that come with some serious security and compatibility issues? Either way I will try this. 4.4.0-116 is the last from that series.

User avatar
Pjotr
Level 21
Level 21
Posts: 13476
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Cinnamon Crash/Fallback Mode

Post by Pjotr » Sat Feb 24, 2018 11:01 am

wwindexx wrote:
Sat Feb 24, 2018 10:27 am
I'm going to try this as soon as I get home from work. Isn't this booting into an incredibly old kernel? Doesn't that come with some serious security and compatibility issues? Either way I will try this. 4.4.0-116 is the last from that series.
The 4.4 kernel series is alive and kicking: it'll be supported with security updates until May, 2021. :mrgreen:
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

wwindexx
Level 1
Level 1
Posts: 6
Joined: Fri Feb 23, 2018 1:46 pm

Re: Cinnamon Crash/Fallback Mode

Post by wwindexx » Sat Feb 24, 2018 10:10 pm

Pjotr wrote:
Sat Feb 24, 2018 5:48 am
Try this:

1. Install the latest kernel from the 4.4 series (4.4.0-116) by means of the kernel tool in Update Manager:
Update Manager - panel: View - Linux kernels

2. Boot from it (it's under the header Advanced in the Grub bootloader menu) and then remove all installed kernels from higher series (probably 4.10.x and 4.13.x).
Unfortunately that did not work either. Cinnamon still crashed upon loading 4.4 series. Should I try installing another DE and see if I can get full 1920x1080 resolution with that? Any other ideas on how to get cinnamon working?

wwindexx
Level 1
Level 1
Posts: 6
Joined: Fri Feb 23, 2018 1:46 pm

Re: Cinnamon Crash/Fallback Mode

Post by wwindexx » Sun Feb 25, 2018 12:20 am

I am at the point now where I am going to download Mint XFCE or MATE to see if that makes a difference. If I can get out of "laptop mode" and a proper 1920 x 1080 resolution that will be a huge improvement.

User avatar
Pjotr
Level 21
Level 21
Posts: 13476
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Cinnamon Crash/Fallback Mode

Post by Pjotr » Sun Feb 25, 2018 5:25 am

It's worth a try:

1. Do a clean installation of the Xfce edition of Linux Mint 18.3:
http://mintmirror.math.washington.edu/l ... -64bit.iso

2. Then disable its visual effects:
https://sites.google.com/site/easylinux ... ts-in-Xfce
(item 7.3, right column)

3. Roll it back to the latest kernel of the 4.4 series;

4. Finally, launch Driver Manager and install the closed non-free Nvidia driver it recommends to you (which is a matter of a few mouseclicks, provided that you have internet connection).
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

Post Reply

Return to “Newbie Questions”