Setting 'Do nothing' for 'When the lid is closed' is not preventing the secondary display from going off on lid closure

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
hax
Level 1
Level 1
Posts: 2
Joined: Sat Mar 03, 2018 10:37 pm

Setting 'Do nothing' for 'When the lid is closed' is not preventing the secondary display from going off on lid closure

Post by hax »

I am running Linux Mint on a laptop and I prefer working on a larger screen. I want to use only the large monitor and want to keep the laptop closed while I work on that one.

So I went to Power management settings and set 'When the lid is closed' to 'Do Nothing'.
However, it is turning off the secondary display as well the moment I close the monitor.
How can I resolve this?
User avatar
Tomgin5
Level 6
Level 6
Posts: 1002
Joined: Sat Mar 19, 2016 2:37 pm
Location: Beaverton, Oregon USA

Re: Setting 'Do nothing' for 'When the lid is closed' is not preventing the secondary display from going off on lid clos

Post by Tomgin5 »

There is another box in the assortment just below the "do nothing" box in Cinnamon. It spells it out.
hax
Level 1
Level 1
Posts: 2
Joined: Sat Mar 03, 2018 10:37 pm

Re: Setting 'Do nothing' for 'When the lid is closed' is not preventing the secondary display from going off on lid clos

Post by hax »

Tried that as well. It still is turning the secondary monitor off. Forgot to mention that in the thread.
jsb
Level 3
Level 3
Posts: 104
Joined: Sat Feb 11, 2017 11:20 am

Re: Setting 'Do nothing' for 'When the lid is closed' is not preventing the secondary display from going off on lid clos

Post by jsb »

FWIW, we used to have a closed Dell laptop connected to a TV, it was running Peppermint 5, though. I don't recall having any problems getting it to work.

I do remember that distro (or else it was the prior version of it) sometimes had conflicts between the screen saver settings and power manager settings. I do not remember if the screen saver affected the lid closing actions or not, but screen saver settings is something I would take a look at, if you have not already done so.
rickNS
Level 5
Level 5
Posts: 858
Joined: Tue Jan 25, 2011 11:59 pm

Re: Setting 'Do nothing' for 'When the lid is closed' is not preventing the secondary display from going off on lid clos

Post by rickNS »

Setting the external display to "primary" solves that problem...at least on MATE.

EDIT: actually mate does not seem to have that problem either way....sorry.
Feel free to delete.
Mint 19.0 mate on 2 identical Thinkpad T420's
Post Reply

Return to “Newbie Questions”